preload-hacks: Some patches to make it work.
[termux-packages] / termux.spec
1 # Android 5 requires position-independent executables, so we use the
2 # %{!S:X} Substitutes X, if the -S switch is not given to GCC"
3 # construct (see https://gcc.gnu.org/onlinedocs/gcc/Spec-Files.html for full reference)
4 # to add -fPIE and -pie flags as appropriate.
5
6 *cc1_options:
7 + %{!fpie: %{!fPIE: %{!fpic: %{!fPIC: %{!fno-pic:-fPIE}}}}}
8
9 *link:
10 + %{!nopie: %{!static: %{!shared: %{!nostdlib: %{!nostartfiles: %{!fno-PIE: %{!fno-pie: -pie}}}}}}}