Merge branch '2.4.x' into 2.5.x
[catacomb] / debian / changelog
1 catacomb (2.5.0) experimental; urgency=medium
2
3 * catacomb: MACs based on blockciphers: PMAC1 and CMAC (also known as
4 OMAC).
5 * catacomb: Authenticated Encryption with Additional Data (AEAD)
6 schemes. Some based on blockciphers: CCM, EAX, GCM (with CPU-specific
7 acceleration), OCB1 and OCB3 (OCB2 is broken). Also Salsa20 and
8 ChaCha20 with Poly1305: the RFC7539 scheme, and the NaCl `secret_box'
9 transform.
10 * catacomb: Implement Grantham's Frobenius test. Combine it with
11 Rabin--Miller, as Baillie--PSW, for testing given primes.
12 * catacomb-bin (catcrypt): Support AEAD schemes for bulk crypto.
13 * catacomb-bin (perftest): Options for batching; report cycle counts
14 where available.
15 * Many internal improvements: better documentation, debugging, testing,
16 etc.
17
18 -- Mark Wooding <mdw@distorted.org.uk> Sat, 21 Sep 2019 21:26:44 +0100
19
20 catacomb (2.4.3) experimental; urgency=medium
21
22 * catacomb (idea): Fix key-length descriptor.
23 * catacomb (xchachaNN): Fix nonce-size descriptor.
24 * catacomb (key-management): Fix incorrect handling of keyring
25 modifiability.
26 * catacomb-dev: Configure `pkg-config' correctly for static linking.
27 * catacomb, catacomb-bin (cookie, dsig): Fix hash-function length
28 padding on very long messages, and handling of large datestamps.
29 * catacomb-bin (catsign): Don't open temporary files unnecessarily.
30 * catacomb-bin (catcrypt): Fix key-attribute parsing.
31 * catacomb-bin (perftest): Add missing help-string text for `-n' used
32 with `enc' and `hash'
33
34 -- Mark Wooding <mdw@distorted.org.uk> Sat, 21 Sep 2019 17:43:59 +0100
35
36 catacomb (2.4.2) experimental; urgency=medium
37
38 * catacomb2: Support multi-arch at last.
39 * catacomb2: Fix mangled key-size data for HMAC.
40 * rspit: Support generating large files.
41 * pixie: Improve error-handling around dropping privilege.
42 * ed25519, ed448: Very minor performance improvement.
43 * salsa20, chacha: Fix crash if nonce is none, as it is when invoked by
44 `rspit'.
45 * salsa20, chacha: Fix declaration of cipher classes to prevent them
46 ending up as (useless) common symbols in client code.
47 * limlee: Improve the prime size heuristics.
48 * sha, sha256, sha512: Restructure compression function to improve
49 performance and use less memory.
50 * rijndael: Include enough round constants to make very tiny keys work
51 correctly.
52
53 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jun 2018 01:15:59 +0100
54
55 catacomb (2.4.1) experimental; urgency=low
56
57 * catacomb2: Two's-complement fix from 2.3.x release branch.
58
59 -- Mark Wooding <mdw@distorted.org.uk> Thu, 22 Jun 2017 09:37:40 +0100
60
61 catacomb (2.4.0.1) experimental; urgency=low
62
63 * Fix build failure with later ARM assemblers.
64
65 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 21:05:35 +0100
66
67 catacomb (2.4.0) experimental; urgency=low
68
69 * catacomb2: Implemented Bernstein's Poly1305 message-authentication
70 code.
71 * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
72 and Salsa20.
73 * catacomb2: Implement Bernstein's X25519.
74 * catacomb2: Implement Hamburg's X448 (RFC7748).
75 * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
76 as defined in RFC8032.
77 * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
78 RFC8032.
79 * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
80 * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
81 * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
82 * catacomb2: Allow RSA key generation with chosen public exponent.
83 * catacomb2: Optimize RSA public-key operations with common public
84 exponents.
85 * catacomb-bin: Support new algorithms in the provided tools.
86 * catacomb-bin: Allow parameters keys for all key types.
87
88 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 16:07:00 +0100
89
90 catacomb (2.3.2) experimental; urgency=low
91
92 * catacomb2: Fix bignum loading and storing in two's complement form.
93
94 -- Mark Wooding <mdw@distorted.org.uk> Thu, 22 Jun 2017 09:34:59 +0100
95
96 catacomb (2.3.1) experimental; urgency=low
97
98 * catacomb2: Fix memory corruption when allocating `salsa20' and
99 `chacha'-based RNGs.
100 * catacomb2: Fix segfault when opening read-only keyring with no
101 associated file.
102 * catacomb2: Return the correct stream offset in `chacha_tell*'.
103 * catacomb2: Produce correct keyring files when they contain empty
104 keys.
105 * catacomb2: Fix cross-compilation-unit type incompatibility in prime
106 and binary group implementations.
107 * catacomb-dev: Add missing licence notices to `salsa20.h'.
108 * catacomb-bin: Fix assertion failure in RSA-PSS signing.
109 * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
110 verifying.
111 * catacomb-bin: Compare MAC tags in constant time.
112 * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
113
114 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 04:05:00 +0100
115
116 catacomb (2.3.0.1) experimental; urgency=low
117
118 * catacomb2: Actually make the stack non-executable rather than just
119 pretending.
120
121 -- Mark Wooding <mdw@distorted.org.uk> Wed, 05 Apr 2017 09:00:55 +0100
122
123 catacomb (2.3.0) experimental; urgency=low
124
125 * catacomb2: Use the correct Oakley 2048 group. For a long time, this
126 was a duplicate of the Oakley 1536 group. There's a compatibility
127 break here, but it's for the best.
128 * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
129 so that the process stack doesn't get marked executable.
130 * catacomb2: New SSE2-based multipliers for i386 and AMD64.
131 * catacomb2: Lots of other improvements to the assembler code.
132
133 -- Mark Wooding <mdw@distorted.org.uk> Mon, 03 Apr 2017 10:24:17 +0100
134
135 catacomb (2.2.5) experimental; urgency=low
136
137 * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
138 is unaligned.
139 * build: Use less obsolete macro names in configure script.
140
141 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jul 2016 10:27:05 +0100
142
143 catacomb (2.2.4) experimental; urgency=low
144
145 * build: Fix build failures on post-wheezy Debian versions.
146 * catacomb2: Use ARM AES instructions if available. (But they can't be
147 assembled using wheezy's version of gas, so this doesn't work in the
148 binary package.)
149 * catacomb2: Fix poor performance (and wrong answers for very small
150 numbers) in prime generation.
151 * catacomb2: Return numbers of exactly the requested length in prime and
152 public-key generation. The `strongprime' and `limlee' algorithms have
153 changed as a result; previously verifiable parameters generated using
154 this algorithm won't be verifiable any more.
155 * catacomb-dev: Deprecate the old `dsa' functions. Use `gdsa' instead.
156
157 -- Mark Wooding <mdw@distorted.org.uk> Sun, 26 Jun 2016 14:18:14 +0100
158
159 catacomb (2.2.3) experimental; urgency=low
160
161 * rand: Make the main generator resiliant in the face of fork(2).
162 * rand: Introduce `rand_quick', which may also mix in CPU-level
163 randomness sources.
164 * rand: Use higher-resolution timer in the quick-win noise source.
165 * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
166 which got lost down the side of the sofas.
167
168 -- Mark Wooding <mdw@distorted.org.uk> Mon, 13 Jun 2016 22:22:33 +0100
169
170 catacomb (2.2.2) experimental; urgency=low
171
172 * build: Cope with newer Autotools and related equipment.
173 * Miscellaneous small fixes for Cygwin.
174 * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
175 particularly, this causes a segfault reading bit zero of a zero-length
176 integer.
177
178 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:12:01 +0100
179
180 catacomb (2.2.1.1) experimental; urgency=low
181
182 * Arrange that catacomb-dev Depends on correct version of mlib-dev. It
183 really won't work well without it.
184
185 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 09:04:50 +0000
186
187 catacomb (2.2.1) experimental; urgency=low
188
189 * Some internal improvements.
190 * Debian packaging cleanups (fix build-depends, update mLib dependency).
191
192 -- Mark Wooding <mdw@distorted.org.uk> Thu, 18 Feb 2016 16:43:09 +0000
193
194 catacomb (2.2.0) experimental; urgency=low
195
196 * catacomb2: Fix rsa_recover crash on even modulus.
197 * catacomb-bin: Report error taking factorial of negative input.
198 * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
199 * catacomb-dev: Support multiple flavours of EC point compression.
200 * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
201 out of prime numbers.
202 * catacomb2: Overhaul crypto primitives used in true-random generator.
203 * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
204 support.
205 * catacomb-dev: New conversions between MP integers and C integer types.
206 * catacomb2: Change gcipher for Seal incompatibly. The IV is now
207 big-endian bytes (rather than `uint32'), and the `block size' is 4.
208 * catacomb2: Mix a constant string into DSA nonce generation to improve
209 resistance to protocol interference.
210 * catacomb2: Fix the freewheel random source, which hasn't been enabled
211 for ages due to a configure-script bug.
212 * catacomb-bin: The key tool can now read and write multiple
213 presentations for key fingerprints.
214 * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
215 stream ciphers.
216
217 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 14:15:31 +0100
218
219 catacomb (2.1.7) experimental; urgency=low
220
221 * A number of entropy-source fixes.
222 * Internal tidying.
223 * Add more elliptic curves, from Brainpool and BADA55.
224 * hashsum: Fix hash file verification.
225
226 -- Mark Wooding <mdw@distorted.org.uk> Wed, 16 Jul 2014 10:21:23 +0100
227
228 catacomb (2.1.6.1) experimental; urgency=low
229
230 * Fix building from source tarball.
231 * Fix building with Python 2.5.
232
233 -- Mark Wooding <mdw@distorted.org.uk> Sat, 28 Dec 2013 14:21:36 +0000
234
235 catacomb (2.1.6) experimental; urgency=low
236
237 * mpreduce: Extend domain to all positive integers.
238 * gfreduce: Fix out-of-bounds memory access.
239 * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
240 * pixie: Don't replace existing pixie unless explicitly requested.
241
242 -- Mark Wooding <mdw@distorted.org.uk> Fri, 27 Dec 2013 14:28:57 +0000
243
244 catacomb (2.1.5) experimental; urgency=low
245
246 * New build system.
247
248 -- Mark Wooding <mdw@distorted.org.uk> Mon, 29 Jun 2013 00:38:58 +0100
249
250 catacomb (2.1.4) experimental; urgency=low
251
252 * Constant-time operations.
253 * Some minor fixes to header files.
254
255 -- Mark Wooding <mdw@distorted.org.uk> Mon, 27 May 2013 22:34:23 +0100
256
257 catacomb (2.1.3) experimental; urgency=low
258
259 * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
260 example program.
261 * Upper bounds on phrase entropy in mkphrase(1).
262 * Don't make the Pixie setuid-root by default. Make the documentation
263 less scary.
264
265 -- Mark Wooding <mdw@distorted.org.uk> Thu, 11 Apr 2013 12:06:28 +0100
266
267 catacomb (2.1.2.1) experimental; urgency=low
268
269 * hashsum: Document `--progress' option in `--help' output.
270
271 -- Mark Wooding <mdw@distorted.org.uk> Thu, 28 Feb 2013 17:35:49 +0000
272
273 catacomb (2.1.2) experimental; urgency=low
274
275 * hashsum: Correct return code when running in `-c' mode.
276 * dsig: Fix core dump on large-ish outputs.
277 * dsig: Fix repeat-close bug.
278 * dsig: Accept precomputed hashes when making signatures.
279 * Utilities: New `-p' option for progress bars.
280 * dsig, hashsum: New `-j' option checks for files not covered by
281 manifest.
282 * Various library improvements.
283
284 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 03:26:44 +0000
285
286 catacomb (2.1.1) experimental; urgency=low
287
288 * Do configuration through pkgconfig.
289
290 -- Mark Wooding <mdw@distorted.org.uk> Mon, 17 Mar 2008 18:36:30 +0000
291
292 catacomb (2.1.0) experimental; urgency=low
293
294 * Added support for elliptic curves, on both prime and binary fields
295 (polynomial basis only). No actual crypto, but there's enough already
296 to do ECDH and stuff on well-known curves Testing is currently a bit
297 patchy.
298
299 -- Mark Wooding <mdw@nsict.org> Sun, 21 Mar 2004 22:47:56 +0000
300
301 catacomb (2.0.1) experimental; urgency=low
302
303 * Debianization!
304 * (pixie): Don't report uninteresting errors when accepting connections.
305
306 -- Mark Wooding <mdw@nsict.org> Thu, 11 Dec 2003 10:47:59 +0000