catcrypt.c, catsign.c: Shorten chunk sizes.
[u/mdw/catacomb] / debian / rules
1 #! /usr/bin/make -f
2
3 export DH_COMPAT = 4
4
5 build:
6 rm -rf build deb-build
7 mkdir deb-build
8 cd deb-build; ../configure --prefix=/usr --mandir=/usr/share/man
9 make -C deb-build
10 make -C deb-build check
11 touch build
12
13 clean:
14 dh_clean
15 rm -rf deb-build build
16
17 install: build
18 dh_clean
19 make -C deb-build install DESTDIR=`pwd`/debian/catacomb2
20 mkdir -p debian/catacomb-dev/usr
21 mv debian/catacomb2/usr/include debian/catacomb-dev/usr
22 mkdir -p debian/catacomb-dev/usr/lib
23 mv debian/catacomb2/usr/lib/catacomb debian/catacomb-dev/usr/lib
24 mv debian/catacomb2/usr/lib/pkgconfig debian/catacomb-dev/usr/lib
25 mv debian/catacomb2/usr/lib/*.a debian/catacomb-dev/usr/lib
26 mv debian/catacomb2/usr/lib/*.so debian/catacomb-dev/usr/lib
27 mv debian/catacomb2/usr/lib/*.la debian/catacomb-dev/usr/lib
28 mkdir -p debian/catacomb-bin/usr
29 mv debian/catacomb2/usr/bin debian/catacomb-bin/usr
30 mkdir -p debian/catacomb-bin/usr/share/man
31 mv debian/catacomb2/usr/share/man/man1 \
32 debian/catacomb-bin/usr/share/man
33
34 binary-indep:
35
36 binary-arch: install
37 dh_testdir -a
38 dh_testroot -a
39 dh_compress -a
40 dh_installdocs -a
41 dh_strip -a
42 dh_makeshlibs -a -V
43 dh_undocumented -a
44 dh_shlibdeps -a
45 dh_installdebconf -a
46 dh_gencontrol -a
47 dh_fixperms -a
48 dh_installdeb -a
49 dh_md5sums -a
50 dh_builddeb -a
51
52 binary: binary-indep binary-arch
53
54 source:
55 rm -rf deb-build/*.tar.gz deb-build/=deb=
56 make -C deb-build dist
57 mkdir deb-build/=deb=
58 cd deb-build/=deb=; tar xvfz ../*.tar.gz
59 d=`pwd`; cd ..; dpkg-source -i -b $$d/deb-build/=deb=/*
60 rm -rf deb-build/=deb=
61
62 .PHONY: binary binary-arch binary-indep clean install source