Debianization fixes.
[xtoys] / debian / rules
1 #! /usr/bin/make -f
2
3 export DH_COMPAT = 4
4
5 build:
6 rm -rf deb-build build; mkdir deb-build
7 cd deb-build; ../configure --prefix=/usr --mandir=/usr/share/man
8 make -C deb-build
9 touch build
10
11 clean:
12 dh_clean
13 rm -rf deb-build build
14
15 install: build
16 dh_clean
17 for i in xscsize xwait xtell; do \
18 dh_install -p xtoys deb-build/$$i usr/bin; \
19 dh_installman -p xtoys $$i.1; \
20 done
21 for i in xcatch xgetline xmsg xshutdown; do \
22 dh_install -p xtoys-gtk deb-build/$$i usr/bin; \
23 dh_installman -p xtoys-gtk $$i.1; \
24 done
25 dh_strip -a
26
27 binary-indep:
28
29 binary-arch: install
30 dh_testdir -a
31 dh_testroot -a
32 dh_compress -a
33 dh_installdocs -a
34 dh_strip -a
35 dh_shlibdeps -a
36 dh_gencontrol -a
37 dh_fixperms -a
38 dh_installdeb -a
39 dh_md5sums -a
40 dh_builddeb -a
41
42 binary: binary-indep binary-arch
43
44 source:
45 rm -rf deb-build/*.tar.gz deb-build/=deb=
46 make -C deb-build dist
47 mkdir deb-build/=deb=
48 cd deb-build/=deb=; tar xvfz ../*.tar.gz
49 d=`pwd`; cd ..; dpkg-source -i -b $$d/deb-build/=deb=/*
50 rm -rf deb-build/=deb=
51
52 .PHONY: binary binary-arch binary-indep clean install source