dh(1): fix so that it works.
[userv-utils] / debian / rules
1 #!/usr/bin/make -f
2
3 # Copyright 1996-2013 Ian Jackson <ijackson@chiark.greenend.org.uk>
4 # Copyright 1998 David Damerell <damerell@chiark.greenend.org.uk>
5 # Copyright 1999,2003
6 # Chancellor Masters and Scholars of the University of Cambridge
7 # Copyright 2010 Tony Finch <fanf@dotat.at>
8 #
9 # This is free software; you can redistribute it and/or modify it
10 # under the terms of the GNU General Public License as published by
11 # the Free Software Foundation; either version 3 of the License, or
12 # (at your option) any later version.
13 #
14 # This program is distributed in the hope that it will be useful, but
15 # WITHOUT ANY WARRANTY; without even the implied warranty of
16 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
17 # General Public License for more details.
18 #
19 # You should have received a copy of the GNU General Public License
20 # along with userv-utils; if not, see http://www.gnu.org/licenses/.
21
22 subdirs_build= ipif www-cgi git-daemon
23 subdirs_nobuild=dyndns groupmanage misc
24 package= userv-utils
25 packages_indep= userv-dyndns userv-groupmanage userv-misc userv-git-daemon
26 packages_arch= userv-ipif userv-cgi
27 packages= $(packages_indep) $(packages_arch)
28
29 cwd= $(shell pwd)
30 d= $(cwd)/debian
31
32 %:
33 dh $@
34
35 override_dh_auto_configure:
36
37 override_dh_auto_build:
38 $(checkdir)
39 set -e; for s in $(subdirs_build); do \
40 $(MAKE) -C $$s all depr=disable; \
41 done
42 touch build
43
44 override_dh_auto_install:
45 $(checkdir)
46 -
47 set -e; for p in $(packages); do rm -rf $d/$$p; done
48 -
49 set -e; for s in $(subdirs_build) $(subdirs_nobuild); do \
50 t=$d/userv-$$s; \
51 rm -rf $$t; \
52 $(MAKE) -C $$s install install-docs install-examples \
53 prefix=$$t/usr \
54 etcdir=$$t/etc \
55 vardir=$$t/var \
56 depr=disable \
57 gituser=root \
58 ; \
59 done
60 -
61 mv debian/userv-www-cgi debian/userv-cgi
62 mv debian/userv-groupmanage/usr/share/doc/groupmanage \
63 debian/userv-groupmanage/usr/share/doc/userv-groupmanage
64 -
65 rename 's/\.example$$//' $d/userv-ipif/etc/userv/vpn/*.example \
66 $d/userv-dyndns/etc/userv/dyndns-service-users.example \
67 $d/userv-groupmanage/etc/groupmanage.conf.example
68 rename 's/\.distrib$$//' $d/*/etc/userv/services.d/*.distrib
69 rename 's/$$/\.disabled/' $d/userv-misc/etc/userv/services.d/mailq
70 -
71 mv $d/userv-misc/usr/bin/mailq $d/userv-misc/usr/bin/mailq.userv
72
73 override_dh_install:
74
75 override_dh_auto_clean:
76 $(checkdir)
77 rm -f build
78 set -e; for s in $(subdirs_build); do \
79 $(MAKE) -C $$s -i distclean || \
80 $(MAKE) -C $$s -f Makefile.in distclean; \
81 done
82 rm -rf *~ debian/tmp debian/*~ debian/files* debian/substvars*
83
84 define checkdir
85 test -f ipif/service.c
86 endef
87
88 # Below here is fairly generic really
89
90 checkroot:
91 $(checkdir)
92 test root = "`whoami`"