stgit.el: Use format-spec when formatting patch lines
[stgit] / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12
13
14
15 CFLAGS = -Wall -g
16
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18 CFLAGS += -O0
19 else
20 CFLAGS += -O2
21 endif
22
23 configure: configure-stamp
24 configure-stamp:
25 dh_testdir
26 # Add here commands to configure the package.
27
28 touch configure-stamp
29
30
31 build: build-stamp
32
33 build-stamp: configure-stamp
34 dh_testdir
35
36 $(MAKE) all doc
37
38 touch build-stamp
39
40 clean:
41 dh_testdir
42 dh_testroot
43 rm -f build-stamp configure-stamp
44
45 # Add here commands to clean up after the build process.
46 -$(MAKE) clean
47
48 dh_clean
49
50 install: build
51 dh_testdir
52 dh_testroot
53 dh_clean -k
54 dh_installdirs
55
56 # Add here commands to install the package into debian/stgit.
57 $(MAKE) DESTDIR=$(CURDIR)/debian/stgit prefix=/usr install install-doc install-html
58
59 # Build architecture-independent files here.
60 binary-indep: build install
61 # We have nothing to do by default.
62
63 # Build architecture-dependent files here.
64 binary-arch: build install
65 dh_testdir
66 dh_testroot
67 dh_installchangelogs
68 dh_installdocs
69 dh_installexamples
70 # dh_install
71 # dh_installmenu
72 # dh_installdebconf
73 # dh_installlogrotate
74 # dh_installemacsen
75 # dh_installpam
76 # dh_installmime
77 # dh_installinit
78 # dh_installcron
79 # dh_installinfo
80 dh_installman
81 dh_link
82 dh_strip
83 dh_compress
84 dh_fixperms
85 # dh_perl
86 dh_python
87 # dh_makeshlibs
88 dh_installdeb
89 dh_shlibdeps
90 dh_gencontrol
91 dh_md5sums
92 dh_builddeb
93
94 binary: binary-indep binary-arch
95 .PHONY: build clean binary-indep binary-arch binary install configure