debian/: Bump to Debhelper 10.
[sod] / debian / rules
1 #! /usr/bin/make -f
2 %:; dh $@ --parallel --without=autoreconf -Bdebian/build
3
4 ## The `sbuild' tool sets a fake `home' directory which doesn't exist. This
5 ## breaks ASDF, which wants to write FASL files into `~/.cache/common-lisp/'.
6 ## Set an explicit cache directory for it, and clear away the FASL cache
7 ## directory on clean.
8 export XDG_CACHE_HOME := $(shell pwd)/debian/build/cache
9 override_dh_auto_clean:
10 dh_auto_clean
11 rm -rf debian/build/cache
12 rm -f doc/*.pdf
13
14 ## Don't strip the main executable. (It doesn't work, and you get left with
15 ## a bare SBCL.)
16 override_dh_strip:; dh_strip -Xusr/bin/sod