Add an error check for correct formatting in Deflate uncompressed
[sgt/halibut] / misc / halibut.spec
1 # David Leonard <dleonard%vintela.com>, 2004.
2 # This file given to Simon Tatham to be released under the MIT licence
3 # of the Halibut distribution.
4 #
5 # SGT: I have no RedHat machine on which to test this file, so I
6 # cannot guarantee that it won't become out of date as the main
7 # Halibut code develops. It was submitted to me on 2004-11-17.
8
9 Name: halibut
10 Version: 0.9
11 Release: 1
12 Source: http://www.chiark.greenend.org.uk/~sgtatham/halibut/%{name}-%{version}.tar.gz
13 Group: Applications/Text
14 Summary: TeX-like software manual tool
15 License: MIT
16 URL: http://www.chiark.greenend.org.uk/~sgtatham/halibut.html
17 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
18
19 %package vim
20 Group: Applications/Editors
21 Summary: Syntax file for the halibut manual tool
22 PreReq: vim
23
24 %description
25 Halibut is yet another text formatting system, intended primarily for
26 writing software documentation. It accepts a single source format and
27 outputs a variety of formats, planned to include text, HTML, Texinfo,
28 Windows Help, Windows HTMLHelp, PostScript and PDF. It has comprehensive
29 indexing and cross-referencing support, and generates hyperlinks within
30 output documents wherever possible.
31
32 %description vim
33 This package provides vim syntax support for Halibut input files (*.but).
34
35 %prep
36 %setup
37
38 %build
39 gmake VERSION="%{version}"
40 (cd doc && gmake)
41
42 %install
43 mkdir -p %{buildroot}%{_bindir}
44 install -m 555 build/halibut %{buildroot}%{_bindir}/halibut
45 mkdir -p %{buildroot}%{_mandir}/man1
46 install -m 444 doc/halibut.1 %{buildroot}%{_mandir}/man1/halibut.1
47
48 VIMSYNTAX=%{_prefix}/share/vim/current/syntax
49 mkdir -p $RPM_BUILD_ROOT/$VIMSYNTAX
50 install -m 444 misc/halibut.vim %{buildroot}$VIMSYNTAX/halibut.vim
51
52 %files
53 %{_bindir}/halibut
54 %{_mandir}/man1/halibut.1*
55 %doc doc/halibut.txt doc/*.but doc/*.html LICENCE
56
57 %files vim
58 %{_prefix}/share/vim/current/syntax/halibut.vim