Build system: debian/rules: set DESTDIR (not prefix).
[secnet] / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # This file is public domain software, originally written by Joey Hess.
4 # Modified for secnet by Stephen Early <steve@greenend.org.uk>
5
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
8
9 build: build-stamp
10 build-stamp:
11 dh_testdir
12
13 # Add here commands to compile the package.
14 ./configure --prefix=/usr --sysconfdir=/etc && $(MAKE)
15
16 touch build-stamp
17
18 clean:
19 dh_testdir
20 dh_testroot
21 rm -f build-stamp
22
23 # Add here commands to clean up after the build process.
24 -$(MAKE) realclean
25
26 dh_clean
27
28 install: build
29 dh_testdir
30 dh_testroot
31 dh_clean -k
32 dh_installdirs
33
34 # Add here commands to install the package into debian/<packagename>
35 $(MAKE) DESTDIR=`pwd`/debian/`dh_listpackages` install
36
37 # Build architecture-independent files here.
38 binary-indep: build install
39 # We have nothing to do by default.
40
41 # Build architecture-dependent files here.
42 binary-arch: build install
43 dh_testdir
44 dh_testroot
45 # dh_installdebconf
46 dh_installdocs INSTALL README NOTES TODO NEWS BUGS CREDITS
47 dh_installexamples example.conf
48 # dh_installmenu
49 # dh_installlogrotate
50 # dh_installemacsen
51 # dh_installpam
52 # dh_installmime
53 dh_installinit
54 # dh_installcron
55 dh_installman
56 # dh_installinfo
57 dh_installchangelogs
58 dh_link
59 dh_strip
60 dh_compress
61 dh_fixperms
62 # dh_makeshlibs
63 dh_installdeb
64 # dh_perl
65 dh_shlibdeps
66 dh_gencontrol
67 dh_md5sums
68 dh_builddeb
69
70 binary: binary-indep binary-arch
71 .PHONY: build clean binary-indep binary-arch binary install