Build system: debian/rules: set DESTDIR (not prefix).
[secnet] / debian / changelog
1 secnet (0.4.0~beta2~) unstable; urgency=low
2
3 * polypath: Ignore IPv6 Unique Local unicast addresses.
4 * polypath: Skip "tentative" IPv6 local addresses.
5 * polypath: Improve logging and debug output.
6 * Portability fix: Build where size_t is not compatible with int.
7 * Makefile: support DESTDIR.
8 * debian/rules: set DESTDIR (not prefix).
9
10 --
11
12 secnet (0.4.0~beta1) unstable; urgency=low
13
14 New features:
15 * Support transport over IPv6. (We do not yet carry IPv6 in the private
16 network.) IPv6 support depends on IPv6-capable adns (adns 1.5.x).
17 * New polypath comm, which can duplicate packets so as to send them via
18 multiple routes over the public network, for increased
19 reliability/performance (but increased cost). Currently Linux-only
20 but should be fairly easy to port.
21 * Support multiple public addresses for peers.
22 * Discard previously-received packets (by default).
23
24 Logging improvements:
25 * Report (each first) transmission and reception success and failure.
26 * Log reason for DNS reolution failure.
27 * Log unexpected kinds of death from userv.
28 * Log authbind exit status as errno value (if appropriate).
29
30 Configuration adjustments:
31 * Adjust default number of mobile peer addresses to store when a peer
32 public address is also configured.
33 * Make specifying peer public port optional. This avoids making special
34 arrangements to bind to a port for in mobile sites with no public
35 stable address.
36
37 Bugfixes:
38 * Hackypar children will die if they get a terminating signal.
39 * Fix signal dispositions inherited by secnet's child processes.
40 * Fix off-by-one error which prevented setting transport-peers-max to 5.
41
42 Test, build and internal improvements:
43 * Use conventional IP address handling library ipaddr.py.
44 * Provide a fuzzer for the slip decoder.
45 * Build system improvements.
46 * Many source code cleanups.
47
48 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 26 Oct 2014 15:28:31 +0000
49
50 secnet (0.3.4) unstable; urgency=low
51
52 SECURITY FIX:
53 * The previous security fix to buffer handling was entirely wrong. This
54 one is better. Thanks to Simon Tatham for the report and the patch.
55
56 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 22 Sep 2014 16:16:11 +0100
57
58 secnet (0.3.3) unstable; urgency=high
59
60 SECURITY FIXES:
61 * Pass correct size argument to recvfrom. This is a serious security
62 problem which may be exploitable from outside the VPN.
63 * Fix a memory leak in some error logging.
64
65 Other related fixes:
66 * Two other latent bugs in buffer length handling found and fixed.
67 * Non-critical stylistic improvements to buffer length handling, to make
68 the code clearer and to assist audit.
69
70 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 23:50:45 +0100
71
72 secnet (0.3.3~beta1) unstable; urgency=low
73
74 Installation compatibility fix:
75 * In make-secnet-sites, always use our own ipaddr.py even if the
76 incompatible modern ipaddr.py is installed (eg via python-ipaddr.deb).
77 (Future versions of secnet are going to need that Python module to be
78 installed.)
79
80 For links involving mobile sites:
81 * Use source of NAK packets as hint for peer transport address.
82 * When initiating rekey, make use of data transport peer addresses.
83
84 Build fix:
85 * Provide clean target in test-example/Makefile.
86
87 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 00:11:44 +0100
88
89 secnet (0.3.2) unstable; urgency=low
90
91 * Release of 0.3.2. No code changes since 0.3.1~beta1.
92
93 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 26 Jun 2014 20:27:58 +0100
94
95 secnet (0.3.2~beta1) unstable; urgency=low
96
97 For links involving mobile sites:
98 * SECURITY: Properly update peer address array when it is full.
99 * Do name-resolution on peer-initiated key setup too, when we are mobile
100 (and other name-resolution improvements).
101
102 Other minor improvements:
103 * Log peer addresses on key exchange timeout.
104 * When printing version (eg during startup), use value from git-describe
105 and thus include git commit id where applicable.
106 * Updates to release checklist in Makefile.in.
107 * Use C99 _Bool for bool_t.
108
109 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 06 Jun 2014 01:17:54 +0100
110
111 secnet (0.3.1) unstable; urgency=low
112
113 * Release of 0.3.1. No code changes since 0.3.1~beta3.
114
115 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 15 May 2014 01:08:30 +0100
116
117 secnet (0.3.1~beta3) unstable; urgency=low
118
119 * Build fixes for non-i386 architectures and gcc 4.8.2.
120
121 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 08 May 2014 19:53:43 +0100
122
123 secnet (0.3.1~beta2) unstable; urgency=low
124
125 Fix relating to new fragmentation / ICMP functionality:
126 * Generate ICMP packets correctly in point-to-point configurations.
127
128 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 03 May 2014 18:58:09 +0100
129
130 secnet (0.3.1~beta1) unstable; urgency=low
131
132 Security fixes (vulnerabilities are to inside attackers only):
133 * SECURITY: Fixes to MTU and fragmentation handling.
134 * SECURITY: Correctly set "unused" ICMP header field.
135 * SECURITY: Fix IP length check not to crash on very short packets.
136
137 New feature:
138 * Make the inter-site MTU configurable, and negotiate it with the peer.
139
140 Bugfixes etc.:
141 * Fix netlink SEGV on clientless netlinks (i.e. configuration error).
142 * Fix formatting error in p-t-p startup message.
143 * Do not send ICMP errors in response to unknown incoming ICMP.
144 * Fix formatting error in secnet.8 manpage.
145 * Internal code rearrangements and improvements.
146
147 Packaging improvements:
148 * Updates to release checklist in Makefile.in.
149 * Additions to the test-example suite.
150
151 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 01 May 2014 19:02:56 +0100
152
153 secnet (0.3.0) unstable; urgency=low
154
155 * Release of 0.3.0. No code changes since 0.3.0~beta3.
156 * Update release checklist.
157
158 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 01 Sep 2013 20:27:48 +0100
159
160 secnet (0.3.0~beta3) unstable; urgency=low
161
162 * New upstream version.
163 - Stability bugfix: properly initialise site's scratch buffer.
164
165 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 05 Aug 2013 11:54:09 +0100
166
167 secnet (0.3.0~beta2) unstable; urgency=low
168
169 * New upstream version.
170 - SECURITY FIX: RSA public modulus and exponent buffer overflow.
171 - SECURITY FIX: Use constant-time memcmp for message authentication.
172 - SECURITY FIX: Provide a new transform, eax-serpent, to replace cbcmac.
173 - SECURITY FIX: No longer send NAKs for NAKs, avoiding NAK storm.
174 - SECURITY FIX: Fix site name checking when site name A is prefix of B.
175 - SECURITY FIX: Safely reject too-short IP packets.
176 - Better robustness for mobile sites (proper user of NAKs, new PROD msg).
177 - Better robustness against SLIP decoding errors.
178 - Fix bugs which caused routes to sometimes not be advertised.
179 - Protocol capability negotiation mechanism.
180 - Improvements and fixes to protocol and usage documentation.
181 - Other bugfixes and code tidying up.
182
183 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 25 Jul 2013 18:26:01 +0100
184
185 secnet (0.3.0~beta1) unstable; urgency=low
186
187 * New upstream version.
188 - SECURITY FIX: avoid crashes (or buffer overrun) on short packets.
189 - Bugfixes relating to packet loss during key exchange.
190 - Bugfixes relating to link up/down status.
191 - Bugfixes relating to logging.
192 - make-secnet-sites made more sophisticated to support two vpns on chiark.
193 - Documentation improvements.
194 - Build system improvements.
195 * Debian packaging improvements:
196 - Native package.
197 - Maintainer / uploaders.
198 - init script requires $remove_fs since we're in /usr.
199
200 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 12 Jul 2012 20:18:16 +0100
201
202 secnet (0.2.1-1) unstable; urgency=low
203
204 * New upstream version. (authbind endianness fix)
205
206 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 11 Dec 2011 13:14:57 +0000
207
208 secnet (0.2.0-1) unstable; urgency=low
209
210 * New upstream version.
211
212 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 10 Dec 2011 22:44:41 +0000
213
214 secnet (0.1.18-1) unstable; urgency=low
215
216 * New upstream version.
217
218 -- Stephen Early <steve@greenend.org.uk> Tue, 18 Mar 2008 17:45:00 +0000