When turning on debug, turn on verbose too.
[secnet] / debian / changelog
1 secnet (0.4.1~~) unstable; urgency=medium
2
3 * Implement comm-info and dedicated-interface-addr feature, for
4 benefit of hippotat.
5 * Implement `keepalive' site option, to try to keep link always up.
6 * When printing messages about dropping IPv6, do not print anything
7 about ihl. (Check the IP version field first!)
8 * When turning on debug, turn on verbose too.
9
10 --
11
12 secnet (0.4.0) unstable; urgency=low
13
14 Debugging improvements:
15 * Packet-level debugging from site notes errors from transmit.
16 * Report when transport peers updated as a result of transmit.
17
18 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 28 Feb 2015 15:03:00 +0000
19
20 secnet (0.4.0~beta2) unstable; urgency=low
21
22 Polypath bugfixes:
23 * Ignore IPv6 Unique Local unicast addresses.
24 * Skip "tentative" IPv6 local addresses.
25 * Improve logging and debug output.
26
27 Portability fix:
28 * Build where size_t is not compatible with int.
29
30 Build system and packaging fixes:
31 * Makefile: support DESTDIR.
32 * debian/rules: set DESTDIR (not prefix).
33 * debian/rules: Support dpkg-buildflags.
34 * Install ipaddrset.py and secnet.8 with correct permissions.
35 * Fix check for <linux/if_tun.h> and git rid of our copy.
36 * Use -lresolv only if inet_aton is not found otherwise.
37 * Use -lnsl only if inet_ntoa is not found otherwise.
38 * debian/rules: Provide build-arch and build-indep targets.
39 * debian/rules: Do not run build for *-indep (!)
40 * Makefile.in: Putative dual (backport and not) release build process doc.
41
42 Copyright updates:
43 * Update to GPLv3. Add missing copyright notices and credits.
44 * Get rid of old FSF street address; use URL instead.
45 * Remove obsolete LICENCE.txt (which was for snprintf reimplementation).
46 * Remove obsolete references to Cendio (for old ipaddr.py).
47
48 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 28 Dec 2014 17:14:10 +0000
49
50 secnet (0.4.0~beta1) unstable; urgency=low
51
52 New features:
53 * Support transport over IPv6. (We do not yet carry IPv6 in the private
54 network.) IPv6 support depends on IPv6-capable adns (adns 1.5.x).
55 * New polypath comm, which can duplicate packets so as to send them via
56 multiple routes over the public network, for increased
57 reliability/performance (but increased cost). Currently Linux-only
58 but should be fairly easy to port.
59 * Support multiple public addresses for peers.
60 * Discard previously-received packets (by default).
61
62 Logging improvements:
63 * Report (each first) transmission and reception success and failure.
64 * Log reason for DNS reolution failure.
65 * Log unexpected kinds of death from userv.
66 * Log authbind exit status as errno value (if appropriate).
67
68 Configuration adjustments:
69 * Adjust default number of mobile peer addresses to store when a peer
70 public address is also configured.
71 * Make specifying peer public port optional. This avoids making special
72 arrangements to bind to a port for in mobile sites with no public
73 stable address.
74
75 Bugfixes:
76 * Hackypar children will die if they get a terminating signal.
77 * Fix signal dispositions inherited by secnet's child processes.
78 * Fix off-by-one error which prevented setting transport-peers-max to 5.
79
80 Test, build and internal improvements:
81 * Use conventional IP address handling library ipaddr.py.
82 * Provide a fuzzer for the slip decoder.
83 * Build system improvements.
84 * Many source code cleanups.
85
86 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 26 Oct 2014 15:28:31 +0000
87
88 secnet (0.3.4) unstable; urgency=low
89
90 SECURITY FIX:
91 * The previous security fix to buffer handling was entirely wrong. This
92 one is better. Thanks to Simon Tatham for the report and the patch.
93
94 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 22 Sep 2014 16:16:11 +0100
95
96 secnet (0.3.3) unstable; urgency=high
97
98 SECURITY FIXES:
99 * Pass correct size argument to recvfrom. This is a serious security
100 problem which may be exploitable from outside the VPN.
101 * Fix a memory leak in some error logging.
102
103 Other related fixes:
104 * Two other latent bugs in buffer length handling found and fixed.
105 * Non-critical stylistic improvements to buffer length handling, to make
106 the code clearer and to assist audit.
107
108 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 23:50:45 +0100
109
110 secnet (0.3.3~beta1) unstable; urgency=low
111
112 Installation compatibility fix:
113 * In make-secnet-sites, always use our own ipaddr.py even if the
114 incompatible modern ipaddr.py is installed (eg via python-ipaddr.deb).
115 (Future versions of secnet are going to need that Python module to be
116 installed.)
117
118 For links involving mobile sites:
119 * Use source of NAK packets as hint for peer transport address.
120 * When initiating rekey, make use of data transport peer addresses.
121
122 Build fix:
123 * Provide clean target in test-example/Makefile.
124
125 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 00:11:44 +0100
126
127 secnet (0.3.2) unstable; urgency=low
128
129 * Release of 0.3.2. No code changes since 0.3.1~beta1.
130
131 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 26 Jun 2014 20:27:58 +0100
132
133 secnet (0.3.2~beta1) unstable; urgency=low
134
135 For links involving mobile sites:
136 * SECURITY: Properly update peer address array when it is full.
137 * Do name-resolution on peer-initiated key setup too, when we are mobile
138 (and other name-resolution improvements).
139
140 Other minor improvements:
141 * Log peer addresses on key exchange timeout.
142 * When printing version (eg during startup), use value from git-describe
143 and thus include git commit id where applicable.
144 * Updates to release checklist in Makefile.in.
145 * Use C99 _Bool for bool_t.
146
147 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 06 Jun 2014 01:17:54 +0100
148
149 secnet (0.3.1) unstable; urgency=low
150
151 * Release of 0.3.1. No code changes since 0.3.1~beta3.
152
153 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 15 May 2014 01:08:30 +0100
154
155 secnet (0.3.1~beta3) unstable; urgency=low
156
157 * Build fixes for non-i386 architectures and gcc 4.8.2.
158
159 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 08 May 2014 19:53:43 +0100
160
161 secnet (0.3.1~beta2) unstable; urgency=low
162
163 Fix relating to new fragmentation / ICMP functionality:
164 * Generate ICMP packets correctly in point-to-point configurations.
165
166 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 03 May 2014 18:58:09 +0100
167
168 secnet (0.3.1~beta1) unstable; urgency=low
169
170 Security fixes (vulnerabilities are to inside attackers only):
171 * SECURITY: Fixes to MTU and fragmentation handling.
172 * SECURITY: Correctly set "unused" ICMP header field.
173 * SECURITY: Fix IP length check not to crash on very short packets.
174
175 New feature:
176 * Make the inter-site MTU configurable, and negotiate it with the peer.
177
178 Bugfixes etc.:
179 * Fix netlink SEGV on clientless netlinks (i.e. configuration error).
180 * Fix formatting error in p-t-p startup message.
181 * Do not send ICMP errors in response to unknown incoming ICMP.
182 * Fix formatting error in secnet.8 manpage.
183 * Internal code rearrangements and improvements.
184
185 Packaging improvements:
186 * Updates to release checklist in Makefile.in.
187 * Additions to the test-example suite.
188
189 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 01 May 2014 19:02:56 +0100
190
191 secnet (0.3.0) unstable; urgency=low
192
193 * Release of 0.3.0. No code changes since 0.3.0~beta3.
194 * Update release checklist.
195
196 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 01 Sep 2013 20:27:48 +0100
197
198 secnet (0.3.0~beta3) unstable; urgency=low
199
200 * New upstream version.
201 - Stability bugfix: properly initialise site's scratch buffer.
202
203 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 05 Aug 2013 11:54:09 +0100
204
205 secnet (0.3.0~beta2) unstable; urgency=low
206
207 * New upstream version.
208 - SECURITY FIX: RSA public modulus and exponent buffer overflow.
209 - SECURITY FIX: Use constant-time memcmp for message authentication.
210 - SECURITY FIX: Provide a new transform, eax-serpent, to replace cbcmac.
211 - SECURITY FIX: No longer send NAKs for NAKs, avoiding NAK storm.
212 - SECURITY FIX: Fix site name checking when site name A is prefix of B.
213 - SECURITY FIX: Safely reject too-short IP packets.
214 - Better robustness for mobile sites (proper user of NAKs, new PROD msg).
215 - Better robustness against SLIP decoding errors.
216 - Fix bugs which caused routes to sometimes not be advertised.
217 - Protocol capability negotiation mechanism.
218 - Improvements and fixes to protocol and usage documentation.
219 - Other bugfixes and code tidying up.
220
221 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 25 Jul 2013 18:26:01 +0100
222
223 secnet (0.3.0~beta1) unstable; urgency=low
224
225 * New upstream version.
226 - SECURITY FIX: avoid crashes (or buffer overrun) on short packets.
227 - Bugfixes relating to packet loss during key exchange.
228 - Bugfixes relating to link up/down status.
229 - Bugfixes relating to logging.
230 - make-secnet-sites made more sophisticated to support two vpns on chiark.
231 - Documentation improvements.
232 - Build system improvements.
233 * Debian packaging improvements:
234 - Native package.
235 - Maintainer / uploaders.
236 - init script requires $remove_fs since we're in /usr.
237
238 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 12 Jul 2012 20:18:16 +0100
239
240 secnet (0.2.1-1) unstable; urgency=low
241
242 * New upstream version. (authbind endianness fix)
243
244 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 11 Dec 2011 13:14:57 +0000
245
246 secnet (0.2.0-1) unstable; urgency=low
247
248 * New upstream version.
249
250 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 10 Dec 2011 22:44:41 +0000
251
252 secnet (0.1.18-1) unstable; urgency=low
253
254 * New upstream version.
255
256 -- Stephen Early <steve@greenend.org.uk> Tue, 18 Mar 2008 17:45:00 +0000