Copyright updates - update to GPLv3, etc.
[secnet] / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # This file is public domain software, originally written by Joey Hess.
4 # Modified for secnet by Stephen Early <steve@greenend.org.uk>
5
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
8
9 # This file is Free Software. It has been incorporated into, and
10 # extensively modified, for secnet.
11 #
12 # Copyright 2001 Joey Hess
13 # Copyright 2011-2014 Ian Jackson
14 #
15 # You may redistribute this file (and the other source files in the
16 # debian/ subdirectory) freely - the copyrightholders declare that
17 # they wish these files to be in the public domain.
18 #
19 # You may redistribute secnet as a whole and/or modify it under the
20 # terms of the GNU General Public License as published by the Free
21 # Software Foundation; either version 3, or (at your option) any
22 # later version.
23 #
24 # This software is distributed in the hope that it will be useful,
25 # but WITHOUT ANY WARRANTY; without even the implied warranty of
26 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
27 # GNU General Public License for more details.
28 #
29 # You should have received a copy of the GNU General Public License
30 # along with this software; if not, see
31 # https://www.gnu.org/licenses/gpl.html.
32
33 build: build-stamp
34 build-stamp:
35 dh_testdir
36
37 # Add here commands to compile the package.
38 ./configure --prefix=/usr --sysconfdir=/etc && $(MAKE)
39
40 touch build-stamp
41
42 clean:
43 dh_testdir
44 dh_testroot
45 rm -f build-stamp
46
47 # Add here commands to clean up after the build process.
48 -$(MAKE) realclean
49
50 dh_clean
51
52 install: build
53 dh_testdir
54 dh_testroot
55 dh_clean -k
56 dh_installdirs
57
58 # Add here commands to install the package into debian/<packagename>
59 $(MAKE) DESTDIR=`pwd`/debian/`dh_listpackages` install
60
61 # Build architecture-independent files here.
62 binary-indep: build install
63 # We have nothing to do by default.
64
65 # Build architecture-dependent files here.
66 binary-arch: build install
67 dh_testdir
68 dh_testroot
69 # dh_installdebconf
70 dh_installdocs INSTALL README NOTES TODO NEWS BUGS CREDITS
71 dh_installexamples example.conf
72 # dh_installmenu
73 # dh_installlogrotate
74 # dh_installemacsen
75 # dh_installpam
76 # dh_installmime
77 dh_installinit
78 # dh_installcron
79 dh_installman
80 # dh_installinfo
81 dh_installchangelogs
82 dh_link
83 dh_strip
84 dh_compress
85 dh_fixperms
86 # dh_makeshlibs
87 dh_installdeb
88 # dh_perl
89 dh_shlibdeps
90 dh_gencontrol
91 dh_md5sums
92 dh_builddeb
93
94 binary: binary-indep binary-arch
95 .PHONY: build clean binary-indep binary-arch binary install