Build system: Makefile: support DESTDIR.
[secnet] / debian / changelog
1 secnet (0.4.0~beta2~) unstable; urgency=low
2
3 * polypath: Ignore IPv6 Unique Local unicast addresses.
4 * polypath: Skip "tentative" IPv6 local addresses.
5 * polypath: Improve logging and debug output.
6 * Portability fix: Build where size_t is not compatible with int.
7 * Makefile: support DESTDIR.
8
9 --
10
11 secnet (0.4.0~beta1) unstable; urgency=low
12
13 New features:
14 * Support transport over IPv6. (We do not yet carry IPv6 in the private
15 network.) IPv6 support depends on IPv6-capable adns (adns 1.5.x).
16 * New polypath comm, which can duplicate packets so as to send them via
17 multiple routes over the public network, for increased
18 reliability/performance (but increased cost). Currently Linux-only
19 but should be fairly easy to port.
20 * Support multiple public addresses for peers.
21 * Discard previously-received packets (by default).
22
23 Logging improvements:
24 * Report (each first) transmission and reception success and failure.
25 * Log reason for DNS reolution failure.
26 * Log unexpected kinds of death from userv.
27 * Log authbind exit status as errno value (if appropriate).
28
29 Configuration adjustments:
30 * Adjust default number of mobile peer addresses to store when a peer
31 public address is also configured.
32 * Make specifying peer public port optional. This avoids making special
33 arrangements to bind to a port for in mobile sites with no public
34 stable address.
35
36 Bugfixes:
37 * Hackypar children will die if they get a terminating signal.
38 * Fix signal dispositions inherited by secnet's child processes.
39 * Fix off-by-one error which prevented setting transport-peers-max to 5.
40
41 Test, build and internal improvements:
42 * Use conventional IP address handling library ipaddr.py.
43 * Provide a fuzzer for the slip decoder.
44 * Build system improvements.
45 * Many source code cleanups.
46
47 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 26 Oct 2014 15:28:31 +0000
48
49 secnet (0.3.4) unstable; urgency=low
50
51 SECURITY FIX:
52 * The previous security fix to buffer handling was entirely wrong. This
53 one is better. Thanks to Simon Tatham for the report and the patch.
54
55 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 22 Sep 2014 16:16:11 +0100
56
57 secnet (0.3.3) unstable; urgency=high
58
59 SECURITY FIXES:
60 * Pass correct size argument to recvfrom. This is a serious security
61 problem which may be exploitable from outside the VPN.
62 * Fix a memory leak in some error logging.
63
64 Other related fixes:
65 * Two other latent bugs in buffer length handling found and fixed.
66 * Non-critical stylistic improvements to buffer length handling, to make
67 the code clearer and to assist audit.
68
69 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 23:50:45 +0100
70
71 secnet (0.3.3~beta1) unstable; urgency=low
72
73 Installation compatibility fix:
74 * In make-secnet-sites, always use our own ipaddr.py even if the
75 incompatible modern ipaddr.py is installed (eg via python-ipaddr.deb).
76 (Future versions of secnet are going to need that Python module to be
77 installed.)
78
79 For links involving mobile sites:
80 * Use source of NAK packets as hint for peer transport address.
81 * When initiating rekey, make use of data transport peer addresses.
82
83 Build fix:
84 * Provide clean target in test-example/Makefile.
85
86 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 00:11:44 +0100
87
88 secnet (0.3.2) unstable; urgency=low
89
90 * Release of 0.3.2. No code changes since 0.3.1~beta1.
91
92 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 26 Jun 2014 20:27:58 +0100
93
94 secnet (0.3.2~beta1) unstable; urgency=low
95
96 For links involving mobile sites:
97 * SECURITY: Properly update peer address array when it is full.
98 * Do name-resolution on peer-initiated key setup too, when we are mobile
99 (and other name-resolution improvements).
100
101 Other minor improvements:
102 * Log peer addresses on key exchange timeout.
103 * When printing version (eg during startup), use value from git-describe
104 and thus include git commit id where applicable.
105 * Updates to release checklist in Makefile.in.
106 * Use C99 _Bool for bool_t.
107
108 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 06 Jun 2014 01:17:54 +0100
109
110 secnet (0.3.1) unstable; urgency=low
111
112 * Release of 0.3.1. No code changes since 0.3.1~beta3.
113
114 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 15 May 2014 01:08:30 +0100
115
116 secnet (0.3.1~beta3) unstable; urgency=low
117
118 * Build fixes for non-i386 architectures and gcc 4.8.2.
119
120 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 08 May 2014 19:53:43 +0100
121
122 secnet (0.3.1~beta2) unstable; urgency=low
123
124 Fix relating to new fragmentation / ICMP functionality:
125 * Generate ICMP packets correctly in point-to-point configurations.
126
127 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 03 May 2014 18:58:09 +0100
128
129 secnet (0.3.1~beta1) unstable; urgency=low
130
131 Security fixes (vulnerabilities are to inside attackers only):
132 * SECURITY: Fixes to MTU and fragmentation handling.
133 * SECURITY: Correctly set "unused" ICMP header field.
134 * SECURITY: Fix IP length check not to crash on very short packets.
135
136 New feature:
137 * Make the inter-site MTU configurable, and negotiate it with the peer.
138
139 Bugfixes etc.:
140 * Fix netlink SEGV on clientless netlinks (i.e. configuration error).
141 * Fix formatting error in p-t-p startup message.
142 * Do not send ICMP errors in response to unknown incoming ICMP.
143 * Fix formatting error in secnet.8 manpage.
144 * Internal code rearrangements and improvements.
145
146 Packaging improvements:
147 * Updates to release checklist in Makefile.in.
148 * Additions to the test-example suite.
149
150 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 01 May 2014 19:02:56 +0100
151
152 secnet (0.3.0) unstable; urgency=low
153
154 * Release of 0.3.0. No code changes since 0.3.0~beta3.
155 * Update release checklist.
156
157 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 01 Sep 2013 20:27:48 +0100
158
159 secnet (0.3.0~beta3) unstable; urgency=low
160
161 * New upstream version.
162 - Stability bugfix: properly initialise site's scratch buffer.
163
164 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 05 Aug 2013 11:54:09 +0100
165
166 secnet (0.3.0~beta2) unstable; urgency=low
167
168 * New upstream version.
169 - SECURITY FIX: RSA public modulus and exponent buffer overflow.
170 - SECURITY FIX: Use constant-time memcmp for message authentication.
171 - SECURITY FIX: Provide a new transform, eax-serpent, to replace cbcmac.
172 - SECURITY FIX: No longer send NAKs for NAKs, avoiding NAK storm.
173 - SECURITY FIX: Fix site name checking when site name A is prefix of B.
174 - SECURITY FIX: Safely reject too-short IP packets.
175 - Better robustness for mobile sites (proper user of NAKs, new PROD msg).
176 - Better robustness against SLIP decoding errors.
177 - Fix bugs which caused routes to sometimes not be advertised.
178 - Protocol capability negotiation mechanism.
179 - Improvements and fixes to protocol and usage documentation.
180 - Other bugfixes and code tidying up.
181
182 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 25 Jul 2013 18:26:01 +0100
183
184 secnet (0.3.0~beta1) unstable; urgency=low
185
186 * New upstream version.
187 - SECURITY FIX: avoid crashes (or buffer overrun) on short packets.
188 - Bugfixes relating to packet loss during key exchange.
189 - Bugfixes relating to link up/down status.
190 - Bugfixes relating to logging.
191 - make-secnet-sites made more sophisticated to support two vpns on chiark.
192 - Documentation improvements.
193 - Build system improvements.
194 * Debian packaging improvements:
195 - Native package.
196 - Maintainer / uploaders.
197 - init script requires $remove_fs since we're in /usr.
198
199 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 12 Jul 2012 20:18:16 +0100
200
201 secnet (0.2.1-1) unstable; urgency=low
202
203 * New upstream version. (authbind endianness fix)
204
205 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 11 Dec 2011 13:14:57 +0000
206
207 secnet (0.2.0-1) unstable; urgency=low
208
209 * New upstream version.
210
211 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 10 Dec 2011 22:44:41 +0000
212
213 secnet (0.1.18-1) unstable; urgency=low
214
215 * New upstream version.
216
217 -- Stephen Early <steve@greenend.org.uk> Tue, 18 Mar 2008 17:45:00 +0000