Finalise changelog for 0.4.0~beta2
[secnet] / debian / changelog
1 secnet (0.4.0~beta2) unstable; urgency=low
2
3 Polypath bugfixes:
4 * Ignore IPv6 Unique Local unicast addresses.
5 * Skip "tentative" IPv6 local addresses.
6 * Improve logging and debug output.
7
8 Portability fix:
9 * Build where size_t is not compatible with int.
10
11 Build system and packaging fixes:
12 * Makefile: support DESTDIR.
13 * debian/rules: set DESTDIR (not prefix).
14 * debian/rules: Support dpkg-buildflags.
15 * Install ipaddrset.py and secnet.8 with correct permissions.
16 * Fix check for <linux/if_tun.h> and git rid of our copy.
17 * Use -lresolv only if inet_aton is not found otherwise.
18 * Use -lnsl only if inet_ntoa is not found otherwise.
19 * debian/rules: Provide build-arch and build-indep targets.
20 * debian/rules: Do not run build for *-indep (!)
21 * Makefile.in: Putative dual (backport and not) release build process doc.
22
23 Copyright updates:
24 * Update to GPLv3. Add missing copyright notices and credits.
25 * Get rid of old FSF street address; use URL instead.
26 * Remove obsolete LICENCE.txt (which was for snprintf reimplementation).
27 * Remove obsolete references to Cendio (for old ipaddr.py).
28
29 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 28 Dec 2014 17:14:10 +0000
30
31 secnet (0.4.0~beta1) unstable; urgency=low
32
33 New features:
34 * Support transport over IPv6. (We do not yet carry IPv6 in the private
35 network.) IPv6 support depends on IPv6-capable adns (adns 1.5.x).
36 * New polypath comm, which can duplicate packets so as to send them via
37 multiple routes over the public network, for increased
38 reliability/performance (but increased cost). Currently Linux-only
39 but should be fairly easy to port.
40 * Support multiple public addresses for peers.
41 * Discard previously-received packets (by default).
42
43 Logging improvements:
44 * Report (each first) transmission and reception success and failure.
45 * Log reason for DNS reolution failure.
46 * Log unexpected kinds of death from userv.
47 * Log authbind exit status as errno value (if appropriate).
48
49 Configuration adjustments:
50 * Adjust default number of mobile peer addresses to store when a peer
51 public address is also configured.
52 * Make specifying peer public port optional. This avoids making special
53 arrangements to bind to a port for in mobile sites with no public
54 stable address.
55
56 Bugfixes:
57 * Hackypar children will die if they get a terminating signal.
58 * Fix signal dispositions inherited by secnet's child processes.
59 * Fix off-by-one error which prevented setting transport-peers-max to 5.
60
61 Test, build and internal improvements:
62 * Use conventional IP address handling library ipaddr.py.
63 * Provide a fuzzer for the slip decoder.
64 * Build system improvements.
65 * Many source code cleanups.
66
67 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 26 Oct 2014 15:28:31 +0000
68
69 secnet (0.3.4) unstable; urgency=low
70
71 SECURITY FIX:
72 * The previous security fix to buffer handling was entirely wrong. This
73 one is better. Thanks to Simon Tatham for the report and the patch.
74
75 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 22 Sep 2014 16:16:11 +0100
76
77 secnet (0.3.3) unstable; urgency=high
78
79 SECURITY FIXES:
80 * Pass correct size argument to recvfrom. This is a serious security
81 problem which may be exploitable from outside the VPN.
82 * Fix a memory leak in some error logging.
83
84 Other related fixes:
85 * Two other latent bugs in buffer length handling found and fixed.
86 * Non-critical stylistic improvements to buffer length handling, to make
87 the code clearer and to assist audit.
88
89 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 23:50:45 +0100
90
91 secnet (0.3.3~beta1) unstable; urgency=low
92
93 Installation compatibility fix:
94 * In make-secnet-sites, always use our own ipaddr.py even if the
95 incompatible modern ipaddr.py is installed (eg via python-ipaddr.deb).
96 (Future versions of secnet are going to need that Python module to be
97 installed.)
98
99 For links involving mobile sites:
100 * Use source of NAK packets as hint for peer transport address.
101 * When initiating rekey, make use of data transport peer addresses.
102
103 Build fix:
104 * Provide clean target in test-example/Makefile.
105
106 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 00:11:44 +0100
107
108 secnet (0.3.2) unstable; urgency=low
109
110 * Release of 0.3.2. No code changes since 0.3.1~beta1.
111
112 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 26 Jun 2014 20:27:58 +0100
113
114 secnet (0.3.2~beta1) unstable; urgency=low
115
116 For links involving mobile sites:
117 * SECURITY: Properly update peer address array when it is full.
118 * Do name-resolution on peer-initiated key setup too, when we are mobile
119 (and other name-resolution improvements).
120
121 Other minor improvements:
122 * Log peer addresses on key exchange timeout.
123 * When printing version (eg during startup), use value from git-describe
124 and thus include git commit id where applicable.
125 * Updates to release checklist in Makefile.in.
126 * Use C99 _Bool for bool_t.
127
128 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 06 Jun 2014 01:17:54 +0100
129
130 secnet (0.3.1) unstable; urgency=low
131
132 * Release of 0.3.1. No code changes since 0.3.1~beta3.
133
134 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 15 May 2014 01:08:30 +0100
135
136 secnet (0.3.1~beta3) unstable; urgency=low
137
138 * Build fixes for non-i386 architectures and gcc 4.8.2.
139
140 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 08 May 2014 19:53:43 +0100
141
142 secnet (0.3.1~beta2) unstable; urgency=low
143
144 Fix relating to new fragmentation / ICMP functionality:
145 * Generate ICMP packets correctly in point-to-point configurations.
146
147 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 03 May 2014 18:58:09 +0100
148
149 secnet (0.3.1~beta1) unstable; urgency=low
150
151 Security fixes (vulnerabilities are to inside attackers only):
152 * SECURITY: Fixes to MTU and fragmentation handling.
153 * SECURITY: Correctly set "unused" ICMP header field.
154 * SECURITY: Fix IP length check not to crash on very short packets.
155
156 New feature:
157 * Make the inter-site MTU configurable, and negotiate it with the peer.
158
159 Bugfixes etc.:
160 * Fix netlink SEGV on clientless netlinks (i.e. configuration error).
161 * Fix formatting error in p-t-p startup message.
162 * Do not send ICMP errors in response to unknown incoming ICMP.
163 * Fix formatting error in secnet.8 manpage.
164 * Internal code rearrangements and improvements.
165
166 Packaging improvements:
167 * Updates to release checklist in Makefile.in.
168 * Additions to the test-example suite.
169
170 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 01 May 2014 19:02:56 +0100
171
172 secnet (0.3.0) unstable; urgency=low
173
174 * Release of 0.3.0. No code changes since 0.3.0~beta3.
175 * Update release checklist.
176
177 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 01 Sep 2013 20:27:48 +0100
178
179 secnet (0.3.0~beta3) unstable; urgency=low
180
181 * New upstream version.
182 - Stability bugfix: properly initialise site's scratch buffer.
183
184 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 05 Aug 2013 11:54:09 +0100
185
186 secnet (0.3.0~beta2) unstable; urgency=low
187
188 * New upstream version.
189 - SECURITY FIX: RSA public modulus and exponent buffer overflow.
190 - SECURITY FIX: Use constant-time memcmp for message authentication.
191 - SECURITY FIX: Provide a new transform, eax-serpent, to replace cbcmac.
192 - SECURITY FIX: No longer send NAKs for NAKs, avoiding NAK storm.
193 - SECURITY FIX: Fix site name checking when site name A is prefix of B.
194 - SECURITY FIX: Safely reject too-short IP packets.
195 - Better robustness for mobile sites (proper user of NAKs, new PROD msg).
196 - Better robustness against SLIP decoding errors.
197 - Fix bugs which caused routes to sometimes not be advertised.
198 - Protocol capability negotiation mechanism.
199 - Improvements and fixes to protocol and usage documentation.
200 - Other bugfixes and code tidying up.
201
202 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 25 Jul 2013 18:26:01 +0100
203
204 secnet (0.3.0~beta1) unstable; urgency=low
205
206 * New upstream version.
207 - SECURITY FIX: avoid crashes (or buffer overrun) on short packets.
208 - Bugfixes relating to packet loss during key exchange.
209 - Bugfixes relating to link up/down status.
210 - Bugfixes relating to logging.
211 - make-secnet-sites made more sophisticated to support two vpns on chiark.
212 - Documentation improvements.
213 - Build system improvements.
214 * Debian packaging improvements:
215 - Native package.
216 - Maintainer / uploaders.
217 - init script requires $remove_fs since we're in /usr.
218
219 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 12 Jul 2012 20:18:16 +0100
220
221 secnet (0.2.1-1) unstable; urgency=low
222
223 * New upstream version. (authbind endianness fix)
224
225 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 11 Dec 2011 13:14:57 +0000
226
227 secnet (0.2.0-1) unstable; urgency=low
228
229 * New upstream version.
230
231 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 10 Dec 2011 22:44:41 +0000
232
233 secnet (0.1.18-1) unstable; urgency=low
234
235 * New upstream version.
236
237 -- Stephen Early <steve@greenend.org.uk> Tue, 18 Mar 2008 17:45:00 +0000