Administrivia: Fix erroneous GPL3+ licence notices "version d or later" (!)
[secnet] / debian / changelog
1 secnet (0.4.4~) unstable; urgency=medium
2
3 Administrivia:
4 * Fix erroneous GPL3+ licence notices "version d or later" (!)
5
6 --
7
8 secnet (0.4.3) unstable; urgency=low
9
10 Security improvement:
11 * Use `mpz_powm_sec' for modexps.
12
13 Enhancements:
14 * Implement comm-info and dedicated-interface-addr feature, for
15 benefit of hippotat.
16 * Implement `keepalive' site option, to try to keep link always up.
17
18 Build etc. fixes:
19 * #include <limits.h> (fixes the build on jessie).
20 * Tolerate building from a git checkout, but with git not installed.
21 (This can happen in chroots.)
22 * Turn off -Wsign-compare for bison output.
23 * Makefile.in: Fix `check-ipaddrset' rule to get reference from
24 $(srcdir). (Makes out-of-tree builds work properly.)
25 * Release checklist fixes.
26 * Burn version numbers 0.4.1 and 0.4.2 due to errors in release prep.
27
28 Bugfixes:
29 * When printing messages about dropping IPv6, do not print anything
30 about ihl. (Check the IP version field first!)
31 * When turning on debug, turn on verbose too.
32
33 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 25 Nov 2017 13:36:41 +0000
34
35 secnet (0.4.0) unstable; urgency=low
36
37 Debugging improvements:
38 * Packet-level debugging from site notes errors from transmit.
39 * Report when transport peers updated as a result of transmit.
40
41 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 28 Feb 2015 15:03:00 +0000
42
43 secnet (0.4.0~beta2) unstable; urgency=low
44
45 Polypath bugfixes:
46 * Ignore IPv6 Unique Local unicast addresses.
47 * Skip "tentative" IPv6 local addresses.
48 * Improve logging and debug output.
49
50 Portability fix:
51 * Build where size_t is not compatible with int.
52
53 Build system and packaging fixes:
54 * Makefile: support DESTDIR.
55 * debian/rules: set DESTDIR (not prefix).
56 * debian/rules: Support dpkg-buildflags.
57 * Install ipaddrset.py and secnet.8 with correct permissions.
58 * Fix check for <linux/if_tun.h> and git rid of our copy.
59 * Use -lresolv only if inet_aton is not found otherwise.
60 * Use -lnsl only if inet_ntoa is not found otherwise.
61 * debian/rules: Provide build-arch and build-indep targets.
62 * debian/rules: Do not run build for *-indep (!)
63 * Makefile.in: Putative dual (backport and not) release build process doc.
64
65 Copyright updates:
66 * Update to GPLv3. Add missing copyright notices and credits.
67 * Get rid of old FSF street address; use URL instead.
68 * Remove obsolete LICENCE.txt (which was for snprintf reimplementation).
69 * Remove obsolete references to Cendio (for old ipaddr.py).
70
71 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 28 Dec 2014 17:14:10 +0000
72
73 secnet (0.4.0~beta1) unstable; urgency=low
74
75 New features:
76 * Support transport over IPv6. (We do not yet carry IPv6 in the private
77 network.) IPv6 support depends on IPv6-capable adns (adns 1.5.x).
78 * New polypath comm, which can duplicate packets so as to send them via
79 multiple routes over the public network, for increased
80 reliability/performance (but increased cost). Currently Linux-only
81 but should be fairly easy to port.
82 * Support multiple public addresses for peers.
83 * Discard previously-received packets (by default).
84
85 Logging improvements:
86 * Report (each first) transmission and reception success and failure.
87 * Log reason for DNS reolution failure.
88 * Log unexpected kinds of death from userv.
89 * Log authbind exit status as errno value (if appropriate).
90
91 Configuration adjustments:
92 * Adjust default number of mobile peer addresses to store when a peer
93 public address is also configured.
94 * Make specifying peer public port optional. This avoids making special
95 arrangements to bind to a port for in mobile sites with no public
96 stable address.
97
98 Bugfixes:
99 * Hackypar children will die if they get a terminating signal.
100 * Fix signal dispositions inherited by secnet's child processes.
101 * Fix off-by-one error which prevented setting transport-peers-max to 5.
102
103 Test, build and internal improvements:
104 * Use conventional IP address handling library ipaddr.py.
105 * Provide a fuzzer for the slip decoder.
106 * Build system improvements.
107 * Many source code cleanups.
108
109 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 26 Oct 2014 15:28:31 +0000
110
111 secnet (0.3.4) unstable; urgency=low
112
113 SECURITY FIX:
114 * The previous security fix to buffer handling was entirely wrong. This
115 one is better. Thanks to Simon Tatham for the report and the patch.
116
117 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 22 Sep 2014 16:16:11 +0100
118
119 secnet (0.3.3) unstable; urgency=high
120
121 SECURITY FIXES:
122 * Pass correct size argument to recvfrom. This is a serious security
123 problem which may be exploitable from outside the VPN.
124 * Fix a memory leak in some error logging.
125
126 Other related fixes:
127 * Two other latent bugs in buffer length handling found and fixed.
128 * Non-critical stylistic improvements to buffer length handling, to make
129 the code clearer and to assist audit.
130
131 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 23:50:45 +0100
132
133 secnet (0.3.3~beta1) unstable; urgency=low
134
135 Installation compatibility fix:
136 * In make-secnet-sites, always use our own ipaddr.py even if the
137 incompatible modern ipaddr.py is installed (eg via python-ipaddr.deb).
138 (Future versions of secnet are going to need that Python module to be
139 installed.)
140
141 For links involving mobile sites:
142 * Use source of NAK packets as hint for peer transport address.
143 * When initiating rekey, make use of data transport peer addresses.
144
145 Build fix:
146 * Provide clean target in test-example/Makefile.
147
148 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 00:11:44 +0100
149
150 secnet (0.3.2) unstable; urgency=low
151
152 * Release of 0.3.2. No code changes since 0.3.1~beta1.
153
154 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 26 Jun 2014 20:27:58 +0100
155
156 secnet (0.3.2~beta1) unstable; urgency=low
157
158 For links involving mobile sites:
159 * SECURITY: Properly update peer address array when it is full.
160 * Do name-resolution on peer-initiated key setup too, when we are mobile
161 (and other name-resolution improvements).
162
163 Other minor improvements:
164 * Log peer addresses on key exchange timeout.
165 * When printing version (eg during startup), use value from git-describe
166 and thus include git commit id where applicable.
167 * Updates to release checklist in Makefile.in.
168 * Use C99 _Bool for bool_t.
169
170 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 06 Jun 2014 01:17:54 +0100
171
172 secnet (0.3.1) unstable; urgency=low
173
174 * Release of 0.3.1. No code changes since 0.3.1~beta3.
175
176 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 15 May 2014 01:08:30 +0100
177
178 secnet (0.3.1~beta3) unstable; urgency=low
179
180 * Build fixes for non-i386 architectures and gcc 4.8.2.
181
182 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 08 May 2014 19:53:43 +0100
183
184 secnet (0.3.1~beta2) unstable; urgency=low
185
186 Fix relating to new fragmentation / ICMP functionality:
187 * Generate ICMP packets correctly in point-to-point configurations.
188
189 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 03 May 2014 18:58:09 +0100
190
191 secnet (0.3.1~beta1) unstable; urgency=low
192
193 Security fixes (vulnerabilities are to inside attackers only):
194 * SECURITY: Fixes to MTU and fragmentation handling.
195 * SECURITY: Correctly set "unused" ICMP header field.
196 * SECURITY: Fix IP length check not to crash on very short packets.
197
198 New feature:
199 * Make the inter-site MTU configurable, and negotiate it with the peer.
200
201 Bugfixes etc.:
202 * Fix netlink SEGV on clientless netlinks (i.e. configuration error).
203 * Fix formatting error in p-t-p startup message.
204 * Do not send ICMP errors in response to unknown incoming ICMP.
205 * Fix formatting error in secnet.8 manpage.
206 * Internal code rearrangements and improvements.
207
208 Packaging improvements:
209 * Updates to release checklist in Makefile.in.
210 * Additions to the test-example suite.
211
212 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 01 May 2014 19:02:56 +0100
213
214 secnet (0.3.0) unstable; urgency=low
215
216 * Release of 0.3.0. No code changes since 0.3.0~beta3.
217 * Update release checklist.
218
219 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 01 Sep 2013 20:27:48 +0100
220
221 secnet (0.3.0~beta3) unstable; urgency=low
222
223 * New upstream version.
224 - Stability bugfix: properly initialise site's scratch buffer.
225
226 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 05 Aug 2013 11:54:09 +0100
227
228 secnet (0.3.0~beta2) unstable; urgency=low
229
230 * New upstream version.
231 - SECURITY FIX: RSA public modulus and exponent buffer overflow.
232 - SECURITY FIX: Use constant-time memcmp for message authentication.
233 - SECURITY FIX: Provide a new transform, eax-serpent, to replace cbcmac.
234 - SECURITY FIX: No longer send NAKs for NAKs, avoiding NAK storm.
235 - SECURITY FIX: Fix site name checking when site name A is prefix of B.
236 - SECURITY FIX: Safely reject too-short IP packets.
237 - Better robustness for mobile sites (proper user of NAKs, new PROD msg).
238 - Better robustness against SLIP decoding errors.
239 - Fix bugs which caused routes to sometimes not be advertised.
240 - Protocol capability negotiation mechanism.
241 - Improvements and fixes to protocol and usage documentation.
242 - Other bugfixes and code tidying up.
243
244 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 25 Jul 2013 18:26:01 +0100
245
246 secnet (0.3.0~beta1) unstable; urgency=low
247
248 * New upstream version.
249 - SECURITY FIX: avoid crashes (or buffer overrun) on short packets.
250 - Bugfixes relating to packet loss during key exchange.
251 - Bugfixes relating to link up/down status.
252 - Bugfixes relating to logging.
253 - make-secnet-sites made more sophisticated to support two vpns on chiark.
254 - Documentation improvements.
255 - Build system improvements.
256 * Debian packaging improvements:
257 - Native package.
258 - Maintainer / uploaders.
259 - init script requires $remove_fs since we're in /usr.
260
261 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 12 Jul 2012 20:18:16 +0100
262
263 secnet (0.2.1-1) unstable; urgency=low
264
265 * New upstream version. (authbind endianness fix)
266
267 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 11 Dec 2011 13:14:57 +0000
268
269 secnet (0.2.0-1) unstable; urgency=low
270
271 * New upstream version.
272
273 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 10 Dec 2011 22:44:41 +0000
274
275 secnet (0.1.18-1) unstable; urgency=low
276
277 * New upstream version.
278
279 -- Stephen Early <steve@greenend.org.uk> Tue, 18 Mar 2008 17:45:00 +0000