changelog: mention hippotat
[secnet] / debian / changelog
1 secnet (0.4.1~~) unstable; urgency=medium
2
3 * Implement comm-info and dedicated-interface-addr feature, for
4 benefit of hippotat.
5 * Implement `keepalive' site option, to try to keep link always up.
6
7 --
8
9 secnet (0.4.0) unstable; urgency=low
10
11 Debugging improvements:
12 * Packet-level debugging from site notes errors from transmit.
13 * Report when transport peers updated as a result of transmit.
14
15 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 28 Feb 2015 15:03:00 +0000
16
17 secnet (0.4.0~beta2) unstable; urgency=low
18
19 Polypath bugfixes:
20 * Ignore IPv6 Unique Local unicast addresses.
21 * Skip "tentative" IPv6 local addresses.
22 * Improve logging and debug output.
23
24 Portability fix:
25 * Build where size_t is not compatible with int.
26
27 Build system and packaging fixes:
28 * Makefile: support DESTDIR.
29 * debian/rules: set DESTDIR (not prefix).
30 * debian/rules: Support dpkg-buildflags.
31 * Install ipaddrset.py and secnet.8 with correct permissions.
32 * Fix check for <linux/if_tun.h> and git rid of our copy.
33 * Use -lresolv only if inet_aton is not found otherwise.
34 * Use -lnsl only if inet_ntoa is not found otherwise.
35 * debian/rules: Provide build-arch and build-indep targets.
36 * debian/rules: Do not run build for *-indep (!)
37 * Makefile.in: Putative dual (backport and not) release build process doc.
38
39 Copyright updates:
40 * Update to GPLv3. Add missing copyright notices and credits.
41 * Get rid of old FSF street address; use URL instead.
42 * Remove obsolete LICENCE.txt (which was for snprintf reimplementation).
43 * Remove obsolete references to Cendio (for old ipaddr.py).
44
45 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 28 Dec 2014 17:14:10 +0000
46
47 secnet (0.4.0~beta1) unstable; urgency=low
48
49 New features:
50 * Support transport over IPv6. (We do not yet carry IPv6 in the private
51 network.) IPv6 support depends on IPv6-capable adns (adns 1.5.x).
52 * New polypath comm, which can duplicate packets so as to send them via
53 multiple routes over the public network, for increased
54 reliability/performance (but increased cost). Currently Linux-only
55 but should be fairly easy to port.
56 * Support multiple public addresses for peers.
57 * Discard previously-received packets (by default).
58
59 Logging improvements:
60 * Report (each first) transmission and reception success and failure.
61 * Log reason for DNS reolution failure.
62 * Log unexpected kinds of death from userv.
63 * Log authbind exit status as errno value (if appropriate).
64
65 Configuration adjustments:
66 * Adjust default number of mobile peer addresses to store when a peer
67 public address is also configured.
68 * Make specifying peer public port optional. This avoids making special
69 arrangements to bind to a port for in mobile sites with no public
70 stable address.
71
72 Bugfixes:
73 * Hackypar children will die if they get a terminating signal.
74 * Fix signal dispositions inherited by secnet's child processes.
75 * Fix off-by-one error which prevented setting transport-peers-max to 5.
76
77 Test, build and internal improvements:
78 * Use conventional IP address handling library ipaddr.py.
79 * Provide a fuzzer for the slip decoder.
80 * Build system improvements.
81 * Many source code cleanups.
82
83 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 26 Oct 2014 15:28:31 +0000
84
85 secnet (0.3.4) unstable; urgency=low
86
87 SECURITY FIX:
88 * The previous security fix to buffer handling was entirely wrong. This
89 one is better. Thanks to Simon Tatham for the report and the patch.
90
91 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 22 Sep 2014 16:16:11 +0100
92
93 secnet (0.3.3) unstable; urgency=high
94
95 SECURITY FIXES:
96 * Pass correct size argument to recvfrom. This is a serious security
97 problem which may be exploitable from outside the VPN.
98 * Fix a memory leak in some error logging.
99
100 Other related fixes:
101 * Two other latent bugs in buffer length handling found and fixed.
102 * Non-critical stylistic improvements to buffer length handling, to make
103 the code clearer and to assist audit.
104
105 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 23:50:45 +0100
106
107 secnet (0.3.3~beta1) unstable; urgency=low
108
109 Installation compatibility fix:
110 * In make-secnet-sites, always use our own ipaddr.py even if the
111 incompatible modern ipaddr.py is installed (eg via python-ipaddr.deb).
112 (Future versions of secnet are going to need that Python module to be
113 installed.)
114
115 For links involving mobile sites:
116 * Use source of NAK packets as hint for peer transport address.
117 * When initiating rekey, make use of data transport peer addresses.
118
119 Build fix:
120 * Provide clean target in test-example/Makefile.
121
122 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 00:11:44 +0100
123
124 secnet (0.3.2) unstable; urgency=low
125
126 * Release of 0.3.2. No code changes since 0.3.1~beta1.
127
128 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 26 Jun 2014 20:27:58 +0100
129
130 secnet (0.3.2~beta1) unstable; urgency=low
131
132 For links involving mobile sites:
133 * SECURITY: Properly update peer address array when it is full.
134 * Do name-resolution on peer-initiated key setup too, when we are mobile
135 (and other name-resolution improvements).
136
137 Other minor improvements:
138 * Log peer addresses on key exchange timeout.
139 * When printing version (eg during startup), use value from git-describe
140 and thus include git commit id where applicable.
141 * Updates to release checklist in Makefile.in.
142 * Use C99 _Bool for bool_t.
143
144 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 06 Jun 2014 01:17:54 +0100
145
146 secnet (0.3.1) unstable; urgency=low
147
148 * Release of 0.3.1. No code changes since 0.3.1~beta3.
149
150 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 15 May 2014 01:08:30 +0100
151
152 secnet (0.3.1~beta3) unstable; urgency=low
153
154 * Build fixes for non-i386 architectures and gcc 4.8.2.
155
156 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 08 May 2014 19:53:43 +0100
157
158 secnet (0.3.1~beta2) unstable; urgency=low
159
160 Fix relating to new fragmentation / ICMP functionality:
161 * Generate ICMP packets correctly in point-to-point configurations.
162
163 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 03 May 2014 18:58:09 +0100
164
165 secnet (0.3.1~beta1) unstable; urgency=low
166
167 Security fixes (vulnerabilities are to inside attackers only):
168 * SECURITY: Fixes to MTU and fragmentation handling.
169 * SECURITY: Correctly set "unused" ICMP header field.
170 * SECURITY: Fix IP length check not to crash on very short packets.
171
172 New feature:
173 * Make the inter-site MTU configurable, and negotiate it with the peer.
174
175 Bugfixes etc.:
176 * Fix netlink SEGV on clientless netlinks (i.e. configuration error).
177 * Fix formatting error in p-t-p startup message.
178 * Do not send ICMP errors in response to unknown incoming ICMP.
179 * Fix formatting error in secnet.8 manpage.
180 * Internal code rearrangements and improvements.
181
182 Packaging improvements:
183 * Updates to release checklist in Makefile.in.
184 * Additions to the test-example suite.
185
186 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 01 May 2014 19:02:56 +0100
187
188 secnet (0.3.0) unstable; urgency=low
189
190 * Release of 0.3.0. No code changes since 0.3.0~beta3.
191 * Update release checklist.
192
193 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 01 Sep 2013 20:27:48 +0100
194
195 secnet (0.3.0~beta3) unstable; urgency=low
196
197 * New upstream version.
198 - Stability bugfix: properly initialise site's scratch buffer.
199
200 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 05 Aug 2013 11:54:09 +0100
201
202 secnet (0.3.0~beta2) unstable; urgency=low
203
204 * New upstream version.
205 - SECURITY FIX: RSA public modulus and exponent buffer overflow.
206 - SECURITY FIX: Use constant-time memcmp for message authentication.
207 - SECURITY FIX: Provide a new transform, eax-serpent, to replace cbcmac.
208 - SECURITY FIX: No longer send NAKs for NAKs, avoiding NAK storm.
209 - SECURITY FIX: Fix site name checking when site name A is prefix of B.
210 - SECURITY FIX: Safely reject too-short IP packets.
211 - Better robustness for mobile sites (proper user of NAKs, new PROD msg).
212 - Better robustness against SLIP decoding errors.
213 - Fix bugs which caused routes to sometimes not be advertised.
214 - Protocol capability negotiation mechanism.
215 - Improvements and fixes to protocol and usage documentation.
216 - Other bugfixes and code tidying up.
217
218 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 25 Jul 2013 18:26:01 +0100
219
220 secnet (0.3.0~beta1) unstable; urgency=low
221
222 * New upstream version.
223 - SECURITY FIX: avoid crashes (or buffer overrun) on short packets.
224 - Bugfixes relating to packet loss during key exchange.
225 - Bugfixes relating to link up/down status.
226 - Bugfixes relating to logging.
227 - make-secnet-sites made more sophisticated to support two vpns on chiark.
228 - Documentation improvements.
229 - Build system improvements.
230 * Debian packaging improvements:
231 - Native package.
232 - Maintainer / uploaders.
233 - init script requires $remove_fs since we're in /usr.
234
235 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 12 Jul 2012 20:18:16 +0100
236
237 secnet (0.2.1-1) unstable; urgency=low
238
239 * New upstream version. (authbind endianness fix)
240
241 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 11 Dec 2011 13:14:57 +0000
242
243 secnet (0.2.0-1) unstable; urgency=low
244
245 * New upstream version.
246
247 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 10 Dec 2011 22:44:41 +0000
248
249 secnet (0.1.18-1) unstable; urgency=low
250
251 * New upstream version.
252
253 -- Stephen Early <steve@greenend.org.uk> Tue, 18 Mar 2008 17:45:00 +0000