changelog: start 0.4.2~
[secnet] / debian / changelog
1 secnet (0.4.2~) unstable; urgency=medium
2
3 *
4
5 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 25 Nov 2017 14:04:42 +0000
6
7 secnet (0.4.1) unstable; urgency=low
8
9 * Implement comm-info and dedicated-interface-addr feature, for
10 benefit of hippotat.
11 * Implement `keepalive' site option, to try to keep link always up.
12 * When printing messages about dropping IPv6, do not print anything
13 about ihl. (Check the IP version field first!)
14 * When turning on debug, turn on verbose too.
15
16 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 25 Nov 2017 13:36:41 +0000
17
18 secnet (0.4.0) unstable; urgency=low
19
20 Debugging improvements:
21 * Packet-level debugging from site notes errors from transmit.
22 * Report when transport peers updated as a result of transmit.
23
24 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 28 Feb 2015 15:03:00 +0000
25
26 secnet (0.4.0~beta2) unstable; urgency=low
27
28 Polypath bugfixes:
29 * Ignore IPv6 Unique Local unicast addresses.
30 * Skip "tentative" IPv6 local addresses.
31 * Improve logging and debug output.
32
33 Portability fix:
34 * Build where size_t is not compatible with int.
35
36 Build system and packaging fixes:
37 * Makefile: support DESTDIR.
38 * debian/rules: set DESTDIR (not prefix).
39 * debian/rules: Support dpkg-buildflags.
40 * Install ipaddrset.py and secnet.8 with correct permissions.
41 * Fix check for <linux/if_tun.h> and git rid of our copy.
42 * Use -lresolv only if inet_aton is not found otherwise.
43 * Use -lnsl only if inet_ntoa is not found otherwise.
44 * debian/rules: Provide build-arch and build-indep targets.
45 * debian/rules: Do not run build for *-indep (!)
46 * Makefile.in: Putative dual (backport and not) release build process doc.
47
48 Copyright updates:
49 * Update to GPLv3. Add missing copyright notices and credits.
50 * Get rid of old FSF street address; use URL instead.
51 * Remove obsolete LICENCE.txt (which was for snprintf reimplementation).
52 * Remove obsolete references to Cendio (for old ipaddr.py).
53
54 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 28 Dec 2014 17:14:10 +0000
55
56 secnet (0.4.0~beta1) unstable; urgency=low
57
58 New features:
59 * Support transport over IPv6. (We do not yet carry IPv6 in the private
60 network.) IPv6 support depends on IPv6-capable adns (adns 1.5.x).
61 * New polypath comm, which can duplicate packets so as to send them via
62 multiple routes over the public network, for increased
63 reliability/performance (but increased cost). Currently Linux-only
64 but should be fairly easy to port.
65 * Support multiple public addresses for peers.
66 * Discard previously-received packets (by default).
67
68 Logging improvements:
69 * Report (each first) transmission and reception success and failure.
70 * Log reason for DNS reolution failure.
71 * Log unexpected kinds of death from userv.
72 * Log authbind exit status as errno value (if appropriate).
73
74 Configuration adjustments:
75 * Adjust default number of mobile peer addresses to store when a peer
76 public address is also configured.
77 * Make specifying peer public port optional. This avoids making special
78 arrangements to bind to a port for in mobile sites with no public
79 stable address.
80
81 Bugfixes:
82 * Hackypar children will die if they get a terminating signal.
83 * Fix signal dispositions inherited by secnet's child processes.
84 * Fix off-by-one error which prevented setting transport-peers-max to 5.
85
86 Test, build and internal improvements:
87 * Use conventional IP address handling library ipaddr.py.
88 * Provide a fuzzer for the slip decoder.
89 * Build system improvements.
90 * Many source code cleanups.
91
92 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 26 Oct 2014 15:28:31 +0000
93
94 secnet (0.3.4) unstable; urgency=low
95
96 SECURITY FIX:
97 * The previous security fix to buffer handling was entirely wrong. This
98 one is better. Thanks to Simon Tatham for the report and the patch.
99
100 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 22 Sep 2014 16:16:11 +0100
101
102 secnet (0.3.3) unstable; urgency=high
103
104 SECURITY FIXES:
105 * Pass correct size argument to recvfrom. This is a serious security
106 problem which may be exploitable from outside the VPN.
107 * Fix a memory leak in some error logging.
108
109 Other related fixes:
110 * Two other latent bugs in buffer length handling found and fixed.
111 * Non-critical stylistic improvements to buffer length handling, to make
112 the code clearer and to assist audit.
113
114 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 23:50:45 +0100
115
116 secnet (0.3.3~beta1) unstable; urgency=low
117
118 Installation compatibility fix:
119 * In make-secnet-sites, always use our own ipaddr.py even if the
120 incompatible modern ipaddr.py is installed (eg via python-ipaddr.deb).
121 (Future versions of secnet are going to need that Python module to be
122 installed.)
123
124 For links involving mobile sites:
125 * Use source of NAK packets as hint for peer transport address.
126 * When initiating rekey, make use of data transport peer addresses.
127
128 Build fix:
129 * Provide clean target in test-example/Makefile.
130
131 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 00:11:44 +0100
132
133 secnet (0.3.2) unstable; urgency=low
134
135 * Release of 0.3.2. No code changes since 0.3.1~beta1.
136
137 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 26 Jun 2014 20:27:58 +0100
138
139 secnet (0.3.2~beta1) unstable; urgency=low
140
141 For links involving mobile sites:
142 * SECURITY: Properly update peer address array when it is full.
143 * Do name-resolution on peer-initiated key setup too, when we are mobile
144 (and other name-resolution improvements).
145
146 Other minor improvements:
147 * Log peer addresses on key exchange timeout.
148 * When printing version (eg during startup), use value from git-describe
149 and thus include git commit id where applicable.
150 * Updates to release checklist in Makefile.in.
151 * Use C99 _Bool for bool_t.
152
153 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 06 Jun 2014 01:17:54 +0100
154
155 secnet (0.3.1) unstable; urgency=low
156
157 * Release of 0.3.1. No code changes since 0.3.1~beta3.
158
159 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 15 May 2014 01:08:30 +0100
160
161 secnet (0.3.1~beta3) unstable; urgency=low
162
163 * Build fixes for non-i386 architectures and gcc 4.8.2.
164
165 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 08 May 2014 19:53:43 +0100
166
167 secnet (0.3.1~beta2) unstable; urgency=low
168
169 Fix relating to new fragmentation / ICMP functionality:
170 * Generate ICMP packets correctly in point-to-point configurations.
171
172 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 03 May 2014 18:58:09 +0100
173
174 secnet (0.3.1~beta1) unstable; urgency=low
175
176 Security fixes (vulnerabilities are to inside attackers only):
177 * SECURITY: Fixes to MTU and fragmentation handling.
178 * SECURITY: Correctly set "unused" ICMP header field.
179 * SECURITY: Fix IP length check not to crash on very short packets.
180
181 New feature:
182 * Make the inter-site MTU configurable, and negotiate it with the peer.
183
184 Bugfixes etc.:
185 * Fix netlink SEGV on clientless netlinks (i.e. configuration error).
186 * Fix formatting error in p-t-p startup message.
187 * Do not send ICMP errors in response to unknown incoming ICMP.
188 * Fix formatting error in secnet.8 manpage.
189 * Internal code rearrangements and improvements.
190
191 Packaging improvements:
192 * Updates to release checklist in Makefile.in.
193 * Additions to the test-example suite.
194
195 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 01 May 2014 19:02:56 +0100
196
197 secnet (0.3.0) unstable; urgency=low
198
199 * Release of 0.3.0. No code changes since 0.3.0~beta3.
200 * Update release checklist.
201
202 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 01 Sep 2013 20:27:48 +0100
203
204 secnet (0.3.0~beta3) unstable; urgency=low
205
206 * New upstream version.
207 - Stability bugfix: properly initialise site's scratch buffer.
208
209 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 05 Aug 2013 11:54:09 +0100
210
211 secnet (0.3.0~beta2) unstable; urgency=low
212
213 * New upstream version.
214 - SECURITY FIX: RSA public modulus and exponent buffer overflow.
215 - SECURITY FIX: Use constant-time memcmp for message authentication.
216 - SECURITY FIX: Provide a new transform, eax-serpent, to replace cbcmac.
217 - SECURITY FIX: No longer send NAKs for NAKs, avoiding NAK storm.
218 - SECURITY FIX: Fix site name checking when site name A is prefix of B.
219 - SECURITY FIX: Safely reject too-short IP packets.
220 - Better robustness for mobile sites (proper user of NAKs, new PROD msg).
221 - Better robustness against SLIP decoding errors.
222 - Fix bugs which caused routes to sometimes not be advertised.
223 - Protocol capability negotiation mechanism.
224 - Improvements and fixes to protocol and usage documentation.
225 - Other bugfixes and code tidying up.
226
227 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 25 Jul 2013 18:26:01 +0100
228
229 secnet (0.3.0~beta1) unstable; urgency=low
230
231 * New upstream version.
232 - SECURITY FIX: avoid crashes (or buffer overrun) on short packets.
233 - Bugfixes relating to packet loss during key exchange.
234 - Bugfixes relating to link up/down status.
235 - Bugfixes relating to logging.
236 - make-secnet-sites made more sophisticated to support two vpns on chiark.
237 - Documentation improvements.
238 - Build system improvements.
239 * Debian packaging improvements:
240 - Native package.
241 - Maintainer / uploaders.
242 - init script requires $remove_fs since we're in /usr.
243
244 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 12 Jul 2012 20:18:16 +0100
245
246 secnet (0.2.1-1) unstable; urgency=low
247
248 * New upstream version. (authbind endianness fix)
249
250 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 11 Dec 2011 13:14:57 +0000
251
252 secnet (0.2.0-1) unstable; urgency=low
253
254 * New upstream version.
255
256 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 10 Dec 2011 22:44:41 +0000
257
258 secnet (0.1.18-1) unstable; urgency=low
259
260 * New upstream version.
261
262 -- Stephen Early <steve@greenend.org.uk> Tue, 18 Mar 2008 17:45:00 +0000