Build system: debian/rules: Support dpkg-buildflags.
[secnet] / debian / changelog
1 secnet (0.4.0~beta2~) unstable; urgency=low
2
3 * polypath: Ignore IPv6 Unique Local unicast addresses.
4 * polypath: Skip "tentative" IPv6 local addresses.
5 * polypath: Improve logging and debug output.
6 * Portability fix: Build where size_t is not compatible with int.
7 * Makefile: support DESTDIR.
8 * debian/rules: set DESTDIR (not prefix).
9 * Do not install ipaddrset.py and secnet.8 executable.
10 * Fix check for <linux/if_tun.h>.
11 * debian/rules: Support dpkg-buildflags.
12
13 Copyright updates:
14 * Update to GPLv3. Add missing copyright notices and credits.
15 * Get rid of old FSF street address; use URL instead.
16 * Remove obsolete LICENCE.txt (which was for snprintf reimplementation).
17 * Remove obsolete references to Cendio (for old ipaddr.py).
18
19 --
20
21 secnet (0.4.0~beta1) unstable; urgency=low
22
23 New features:
24 * Support transport over IPv6. (We do not yet carry IPv6 in the private
25 network.) IPv6 support depends on IPv6-capable adns (adns 1.5.x).
26 * New polypath comm, which can duplicate packets so as to send them via
27 multiple routes over the public network, for increased
28 reliability/performance (but increased cost). Currently Linux-only
29 but should be fairly easy to port.
30 * Support multiple public addresses for peers.
31 * Discard previously-received packets (by default).
32
33 Logging improvements:
34 * Report (each first) transmission and reception success and failure.
35 * Log reason for DNS reolution failure.
36 * Log unexpected kinds of death from userv.
37 * Log authbind exit status as errno value (if appropriate).
38
39 Configuration adjustments:
40 * Adjust default number of mobile peer addresses to store when a peer
41 public address is also configured.
42 * Make specifying peer public port optional. This avoids making special
43 arrangements to bind to a port for in mobile sites with no public
44 stable address.
45
46 Bugfixes:
47 * Hackypar children will die if they get a terminating signal.
48 * Fix signal dispositions inherited by secnet's child processes.
49 * Fix off-by-one error which prevented setting transport-peers-max to 5.
50
51 Test, build and internal improvements:
52 * Use conventional IP address handling library ipaddr.py.
53 * Provide a fuzzer for the slip decoder.
54 * Build system improvements.
55 * Many source code cleanups.
56
57 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 26 Oct 2014 15:28:31 +0000
58
59 secnet (0.3.4) unstable; urgency=low
60
61 SECURITY FIX:
62 * The previous security fix to buffer handling was entirely wrong. This
63 one is better. Thanks to Simon Tatham for the report and the patch.
64
65 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 22 Sep 2014 16:16:11 +0100
66
67 secnet (0.3.3) unstable; urgency=high
68
69 SECURITY FIXES:
70 * Pass correct size argument to recvfrom. This is a serious security
71 problem which may be exploitable from outside the VPN.
72 * Fix a memory leak in some error logging.
73
74 Other related fixes:
75 * Two other latent bugs in buffer length handling found and fixed.
76 * Non-critical stylistic improvements to buffer length handling, to make
77 the code clearer and to assist audit.
78
79 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 23:50:45 +0100
80
81 secnet (0.3.3~beta1) unstable; urgency=low
82
83 Installation compatibility fix:
84 * In make-secnet-sites, always use our own ipaddr.py even if the
85 incompatible modern ipaddr.py is installed (eg via python-ipaddr.deb).
86 (Future versions of secnet are going to need that Python module to be
87 installed.)
88
89 For links involving mobile sites:
90 * Use source of NAK packets as hint for peer transport address.
91 * When initiating rekey, make use of data transport peer addresses.
92
93 Build fix:
94 * Provide clean target in test-example/Makefile.
95
96 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 19 Sep 2014 00:11:44 +0100
97
98 secnet (0.3.2) unstable; urgency=low
99
100 * Release of 0.3.2. No code changes since 0.3.1~beta1.
101
102 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 26 Jun 2014 20:27:58 +0100
103
104 secnet (0.3.2~beta1) unstable; urgency=low
105
106 For links involving mobile sites:
107 * SECURITY: Properly update peer address array when it is full.
108 * Do name-resolution on peer-initiated key setup too, when we are mobile
109 (and other name-resolution improvements).
110
111 Other minor improvements:
112 * Log peer addresses on key exchange timeout.
113 * When printing version (eg during startup), use value from git-describe
114 and thus include git commit id where applicable.
115 * Updates to release checklist in Makefile.in.
116 * Use C99 _Bool for bool_t.
117
118 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 06 Jun 2014 01:17:54 +0100
119
120 secnet (0.3.1) unstable; urgency=low
121
122 * Release of 0.3.1. No code changes since 0.3.1~beta3.
123
124 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 15 May 2014 01:08:30 +0100
125
126 secnet (0.3.1~beta3) unstable; urgency=low
127
128 * Build fixes for non-i386 architectures and gcc 4.8.2.
129
130 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 08 May 2014 19:53:43 +0100
131
132 secnet (0.3.1~beta2) unstable; urgency=low
133
134 Fix relating to new fragmentation / ICMP functionality:
135 * Generate ICMP packets correctly in point-to-point configurations.
136
137 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 03 May 2014 18:58:09 +0100
138
139 secnet (0.3.1~beta1) unstable; urgency=low
140
141 Security fixes (vulnerabilities are to inside attackers only):
142 * SECURITY: Fixes to MTU and fragmentation handling.
143 * SECURITY: Correctly set "unused" ICMP header field.
144 * SECURITY: Fix IP length check not to crash on very short packets.
145
146 New feature:
147 * Make the inter-site MTU configurable, and negotiate it with the peer.
148
149 Bugfixes etc.:
150 * Fix netlink SEGV on clientless netlinks (i.e. configuration error).
151 * Fix formatting error in p-t-p startup message.
152 * Do not send ICMP errors in response to unknown incoming ICMP.
153 * Fix formatting error in secnet.8 manpage.
154 * Internal code rearrangements and improvements.
155
156 Packaging improvements:
157 * Updates to release checklist in Makefile.in.
158 * Additions to the test-example suite.
159
160 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 01 May 2014 19:02:56 +0100
161
162 secnet (0.3.0) unstable; urgency=low
163
164 * Release of 0.3.0. No code changes since 0.3.0~beta3.
165 * Update release checklist.
166
167 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 01 Sep 2013 20:27:48 +0100
168
169 secnet (0.3.0~beta3) unstable; urgency=low
170
171 * New upstream version.
172 - Stability bugfix: properly initialise site's scratch buffer.
173
174 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 05 Aug 2013 11:54:09 +0100
175
176 secnet (0.3.0~beta2) unstable; urgency=low
177
178 * New upstream version.
179 - SECURITY FIX: RSA public modulus and exponent buffer overflow.
180 - SECURITY FIX: Use constant-time memcmp for message authentication.
181 - SECURITY FIX: Provide a new transform, eax-serpent, to replace cbcmac.
182 - SECURITY FIX: No longer send NAKs for NAKs, avoiding NAK storm.
183 - SECURITY FIX: Fix site name checking when site name A is prefix of B.
184 - SECURITY FIX: Safely reject too-short IP packets.
185 - Better robustness for mobile sites (proper user of NAKs, new PROD msg).
186 - Better robustness against SLIP decoding errors.
187 - Fix bugs which caused routes to sometimes not be advertised.
188 - Protocol capability negotiation mechanism.
189 - Improvements and fixes to protocol and usage documentation.
190 - Other bugfixes and code tidying up.
191
192 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 25 Jul 2013 18:26:01 +0100
193
194 secnet (0.3.0~beta1) unstable; urgency=low
195
196 * New upstream version.
197 - SECURITY FIX: avoid crashes (or buffer overrun) on short packets.
198 - Bugfixes relating to packet loss during key exchange.
199 - Bugfixes relating to link up/down status.
200 - Bugfixes relating to logging.
201 - make-secnet-sites made more sophisticated to support two vpns on chiark.
202 - Documentation improvements.
203 - Build system improvements.
204 * Debian packaging improvements:
205 - Native package.
206 - Maintainer / uploaders.
207 - init script requires $remove_fs since we're in /usr.
208
209 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 12 Jul 2012 20:18:16 +0100
210
211 secnet (0.2.1-1) unstable; urgency=low
212
213 * New upstream version. (authbind endianness fix)
214
215 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 11 Dec 2011 13:14:57 +0000
216
217 secnet (0.2.0-1) unstable; urgency=low
218
219 * New upstream version.
220
221 -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 10 Dec 2011 22:44:41 +0000
222
223 secnet (0.1.18-1) unstable; urgency=low
224
225 * New upstream version.
226
227 -- Stephen Early <steve@greenend.org.uk> Tue, 18 Mar 2008 17:45:00 +0000