debian/: Add packaging support.
[runlisp] / debian / rules
1 #! /usr/bin/make -f
2
3 DH_OPTIONS = --parallel -Bdebian/build
4
5 OVERRIDES += auto_configure
6 dh_auto_configure_OPTS = --
7 dh_auto_configure_OPTS += --with-imagedir=/var/lib/runlisp
8
9 OVERRIDES += auto_install
10 dh_auto_install_OPTS = --destdir=debian/tmp
11
12 %:; dh $@ $(DH_OPTIONS)
13
14 $(foreach o, $(sort $(OVERRIDES)), dh-$o-hook)::; @:
15 $(foreach o, $(sort $(OVERRIDES)), override_dh_$o): override_dh_%: dh-%-hook
16 dh_$* $(addprefix -O, $(DH_OPTIONS)) $(dh_$*_OPTS)