packaging fixes
[hippotat] / debian / rules
1 #!/usr/bin/make -f
2
3 SHELL=/bin/bash
4
5 export PYBUILD_INSTALL_DIR=/usr/share/hippotat/python3
6
7 %:
8 dh $@ --with python3 --buildsystem=pybuild
9
10 i=debian/hippotat
11
12 debian/copyright: COPYING AGPLv3+CAFv2
13 cat $^ >$@.tmp && mv -f $@.tmp $@
14
15 override_dh_python3:
16 dh_python3 -O--buildsystem=pybuild
17 dh_installdirs /usr/sbin
18 mv $i/usr/{bin,sbin}/hippotatd
19
20 #install -m755 -o0 -g0 -d $i//usr/sbin
21
22 override_dh_installinit:
23 dh_installinit --name=hippotatd
24
25 override_dh_compress:
26 find $i/usr/{bin,sbin} -type f | xargs ./subst-sys-path
27 dh_compress