debian, build: Big overhaul.
[getdate-python] / debian / rules
index 05e0fc0..6ebce3c 100755 (executable)
@@ -1,44 +1,9 @@
 #! /usr/bin/make -f
 
-export DH_COMPAT = 4
+CDBS = /usr/share/cdbs/1
 
-build: build-stamp
+DEB_PYTHON_SYSTEM = pycentral
+include $(CDBS)/rules/debhelper.mk
+include $(CDBS)/class/python-distutils.mk
 
-build-stamp:
-       python setup.py build
-       touch build-stamp
-
-clean:
-       dh_clean
-       rm -rf build build-stamp
-
-install: build
-       dh_clean
-       python setup.py build
-       python setup.py install --root=debian/python-getdate
-
-binary-arch: install
-       dh_testdir -a
-       dh_testroot -a
-       dh_compress -a
-       dh_installdocs -a
-       dh_strip -a
-       dh_shlibdeps -a
-       dh_python -a
-       dh_gencontrol -a
-       dh_fixperms -a
-       dh_installdeb -a
-       dh_md5sums -a
-       dh_builddeb -a
-
-binary: binary-arch
-
-source:
-       rm -rf dist/*.tar.gz dist/=deb=
-       python$(DEFVERSION) setup.py sdist
-       mkdir dist/=deb=
-       cd dist/=deb=; tar xvfz ../*.tar.gz
-       d=`pwd`; cd ..; dpkg-source -i -i'/\.svn/' -b $$d/dist/=deb=/*
-       rm -rf dist/=deb=
-
-.PHONY: binary binary-arch binary-indep clean install source build
+###----- That's all, folks --------------------------------------------------