cope without main config file
[disorder] / debian / rules.m4
1 #
2 # This file is part of DisOrder.
3 # Copyright (C) 2004, 2005, 2006, 2007 Richard Kettlewell
4 #
5 # This program is free software; you can redistribute it and/or modify
6 # it under the terms of the GNU General Public License as published by
7 # the Free Software Foundation; either version 2 of the License, or
8 # (at your option) any later version.
9 #
10 # This program is distributed in the hope that it will be useful, but
11 # WITHOUT ANY WARRANTY; without even the implied warranty of
12 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
13 # General Public License for more details.
14 #
15 # You should have received a copy of the GNU General Public License
16 # along with this program; if not, write to the Free Software
17 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
18 # USA
19 #
20
21 CONFIGURE=--prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib --mandir=/usr/share/man
22 LIBTOOL=./libtool
23
24 build
25
26 archpkg([disorder], [ m4_dnl
27 $(MAKE) DESTDIR=`pwd`/debian/disorder staticdir=/var/www/disorder installdirs install
28 rm -f debian/disorder/usr/bin/disorder-playrtp
29 rm -f debian/disorder/usr/share/man/man1/disorder-playrtp.1
30 mkdir -m 755 -p debian/disorder/etc/disorder
31 mkdir -m 755 -p debian/disorder/etc/init.d
32 mkdir -m 755 -p debian/disorder/usr/lib/cgi-bin/disorder
33 mkdir -m 755 -p debian/disorder/var/lib/disorder
34 mkdir -m 755 -p debian/disorder/usr/share/doc/disorder/ChangeLog.d
35 $(INSTALL) -m 755 examples/disorder.init \
36 debian/disorder/etc/init.d/disorder
37 $(INSTALL) -m 644 debian/disorder.config \
38 debian/disorder/etc/disorder/config
39 $(INSTALL) -m 644 debian/options.debian \
40 debian/disorder/etc/disorder/options
41 $(LIBTOOL) --mode=install $(INSTALL) -m 755 server/disorder.cgi \
42 $(shell pwd)/debian/disorder/usr/lib/cgi-bin/disorder/disorder
43 dpkg-shlibdeps -Tdebian/substvars.disorder \
44 debian/disorder/usr/bin/* \
45 debian/disorder/usr/lib/cgi-bin/disorder/* \
46 debian/disorder/usr/sbin/* \
47 debian/disorder/usr/lib/disorder/*.so*
48 $(INSTALL) -m 644 debian/htaccess \
49 debian/disorder/usr/lib/cgi-bin/disorder/.htaccess
50 $(INSTALL) -m 644 CHANGES README debian/README.Debian \
51 BUGS README.* \
52 debian/disorder/usr/share/doc/disorder/.
53 $(INSTALL) -m 644 ChangeLog.d/*--* \
54 debian/disorder/usr/share/doc/disorder/ChangeLog.d
55 $(INSTALL) -m 644 COPYING debian/disorder/usr/share/doc/disorder/GPL
56 gzip -9f debian/disorder/usr/share/doc/disorder/ChangeLog.d/*--* \
57 debian/disorder/usr/share/doc/disorder/CHANGES \
58 debian/disorder/usr/share/doc/disorder/README \
59 debian/disorder/usr/share/doc/disorder/README.* \
60 debian/disorder/usr/share/doc/disorder/BUGS \
61 debian/disorder/usr/share/doc/disorder/GPL \
62 debian/disorder/usr/share/man/man*/*
63 $(INSTALL) -m 755 debian/postinst debian/prerm debian/postrm \
64 debian/config \
65 debian/disorder/DEBIAN/.
66 $(INSTALL) -m 644 debian/conffiles debian/templates \
67 debian/disorder/DEBIAN/.
68 ])
69
70 archpkg([disorder-playrtp], [ m4_dnl
71 mkdir -p debian/disorder-playrtp/usr/bin
72 mkdir -p debian/disorder-playrtp/usr/share/man/man1
73 $(INSTALL) -m 755 clients/disorder-playrtp \
74 debian/disorder-playrtp/usr/bin/disorder-playrtp
75 $(INSTALL) -m 755 doc/disorder-playrtp.1 \
76 debian/disorder-playrtp/usr/share/man/man1/disorder-playrtp.1
77 dpkg-shlibdeps -Tdebian/substvars.disorder-playrtp \
78 debian/disorder-playrtp/usr/bin/*
79 $(INSTALL) -m 644 debian/README.RTP \
80 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/README
81 $(INSTALL) -m 644 COPYING debian/disorder-playrtp/usr/share/doc/disorder-playrtp/GPL
82 gzip -9f debian/disorder-playrtp/usr/share/doc/disorder-playrtp/GPL \
83 debian/disorder-playrtp/usr/share/man/man*/*
84 ])
85
86 binary
87
88 clean
89
90 regenerate