New README.developers and README.freebsd. README.client improved.
[disorder] / debian / rules
1 #! /usr/bin/make -f
2 #
3 # Copyright (C) 2004-2008 Richard Kettlewell
4 #
5 # This program is free software; you can redistribute it and/or modify
6 # it under the terms of the GNU General Public License as published by
7 # the Free Software Foundation; either version 2 of the License, or
8 # (at your option) any later version.
9 #
10 # This program is distributed in the hope that it will be useful, but
11 # WITHOUT ANY WARRANTY; without even the implied warranty of
12 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
13 # General Public License for more details.
14 #
15 # You should have received a copy of the GNU General Public License
16 # along with this program; if not, write to the Free Software
17 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
18 # USA
19 #
20
21 # Options to configure. This can be overridden by the caller if necessary.
22 CONFIGURE=--prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib --mandir=/usr/share/man --with-browser=x-www-browser
23
24 # Set DEB_BUILD_OPTIONS=noopt to produce a non-optimized build.
25 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
26 CFLAGS=-O0 -g
27 else
28 CFLAGS=-O2 -g
29 endif
30 export CFLAGS
31
32 # Install commands. You wouldn't normally override these.
33 INSTALL=install
34 INSTALL_DATA=$(INSTALL) -p -o root -g root -m 644
35 INSTALL_PROGRAM=$(INSTALL) -p -o root -g root -m 755
36 INSTALL_SCRIPT=$(INSTALL) -p -o root -g root -m 755
37 MKDIR=mkdir -p -m 755
38
39 # Set DEB_BUILD_OPTIONS=nostrip to install debuggable executables.
40 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
41 INSTALL_PROGRAM += -s
42 endif
43
44 export INSTALL_DATA
45 export INSTALL_SCRIPT
46 export INSTALL_PROGRAM
47
48 LIBTOOL=./libtool
49 FAKEROOT=fakeroot
50
51 .PHONY: build
52 # ./prepare is the script that generates configure etc. It only needs to be
53 # run if building from a checkout rather than a tarball.
54 build:
55 @if test ! -f configure; then \
56 echo ./prepare ${CONFIGURE} ${CONFIGURE_EXTRA};\
57 ./prepare ${CONFIGURE} ${CONFIGURE_EXTRA};\
58 elif test ! -f config.status; then \
59 echo ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
60 ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
61 else\
62 echo ./config.status;\
63 ./config.status;\
64 fi
65 $(MAKE)
66
67 .PHONY: cleanpkg-disorder
68 cleanpkg-disorder:
69 rm -rf debian/disorder
70
71 .PHONY: pkg-disorder
72 pkg-disorder: build
73 rm -rf debian/disorder
74 $(MKDIR) debian/disorder
75 $(MKDIR) debian/disorder/DEBIAN
76 $(MKDIR) debian/disorder/usr/share/doc/disorder
77 $(MKDIR) debian/disorder/etc/bash_completion.d
78 $(INSTALL_DATA) debian/copyright \
79 debian/disorder/usr/share/doc/disorder/copyright
80 $(INSTALL_DATA) debian/changelog \
81 debian/disorder/usr/share/doc/disorder/changelog.Debian
82 gzip -9 debian/disorder/usr/share/doc/disorder/changelog.Debian
83 @for f in preinst postinst prerm postrm conffiles templates config; do\
84 if test -e debian/$$f.disorder; then\
85 echo $(INSTALL_SCRIPT) debian/$$f.disorder debian/disorder/DEBIAN/$$f; \
86 $(INSTALL_SCRIPT) debian/$$f.disorder debian/disorder/DEBIAN/$$f; \
87 fi;\
88 done
89 $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C doc
90 $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C clients
91 $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C lib
92 $(INSTALL_DATA) scripts/completion.bash \
93 debian/disorder/etc/bash_completion.d/disorder
94 rm -rf debian/disorder/usr/share/man/man8
95 rm -rf debian/disorder/usr/share/disorder/*.html
96 rmdir debian/disorder/usr/share/disorder
97 rm -f debian/disorder/usr/bin/disorder-playrtp
98 rm -f debian/disorder/usr/bin/disobedience
99 rm -f debian/disorder/usr/share/man/man1/disorder-playrtp.1
100 rm -f debian/disorder/usr/share/man/man1/disobedience.1
101 $(MKDIR) debian/disorder/etc/disorder
102 dpkg-shlibdeps -Tdebian/substvars.disorder \
103 debian/disorder/usr/bin/*
104 $(INSTALL_DATA) CHANGES README debian/README.Debian \
105 BUGS README.* \
106 debian/disorder/usr/share/doc/disorder/.
107 rm -f debian/disorder/usr/share/doc/disorder/README.mac
108 rm -f debian/disorder/usr/share/doc/disorder/README.freebsd
109 bzr log > debian/disorder/usr/share/doc/disorder/changelog
110 gzip -9f debian/disorder/usr/share/doc/disorder/changelog \
111 debian/disorder/usr/share/doc/disorder/CHANGES \
112 debian/disorder/usr/share/doc/disorder/README \
113 debian/disorder/usr/share/doc/disorder/README.* \
114 debian/disorder/usr/share/doc/disorder/BUGS \
115 debian/disorder/usr/share/man/man*/*
116 dpkg-gencontrol -isp -pdisorder -Pdebian/disorder -Tdebian/substvars.disorder
117 chown -R root:root debian/disorder
118 chmod -R g-ws debian/disorder
119 dpkg --build debian/disorder ..
120
121
122 .PHONY: cleanpkg-disorder-server
123 cleanpkg-disorder-server:
124 rm -rf debian/disorder-server
125
126 .PHONY: pkg-disorder-server
127 pkg-disorder-server: build
128 rm -rf debian/disorder-server
129 $(MKDIR) debian/disorder-server
130 $(MKDIR) debian/disorder-server/DEBIAN
131 $(MKDIR) debian/disorder-server/usr/share/doc/disorder-server
132 $(INSTALL_DATA) debian/copyright \
133 debian/disorder-server/usr/share/doc/disorder-server/copyright
134 $(INSTALL_DATA) debian/changelog \
135 debian/disorder-server/usr/share/doc/disorder-server/changelog.Debian
136 gzip -9 debian/disorder-server/usr/share/doc/disorder-server/changelog.Debian
137 @for f in preinst postinst prerm postrm conffiles templates config; do\
138 if test -e debian/$$f.disorder-server; then\
139 echo $(INSTALL_SCRIPT) debian/$$f.disorder-server debian/disorder-server/DEBIAN/$$f; \
140 $(INSTALL_SCRIPT) debian/$$f.disorder-server debian/disorder-server/DEBIAN/$$f; \
141 fi;\
142 done
143 $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C images
144 $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C server
145 $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C templates
146 $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C driver
147 $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C plugins
148 $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C sounds
149 $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C doc
150 rm -rf debian/disorder-server/usr/share/man/man1
151 rm -rf debian/disorder-server/usr/share/man/man3
152 rm -rf debian/disorder-server/usr/share/man/man5
153 $(MKDIR) debian/disorder-server/etc/disorder
154 $(MKDIR) debian/disorder-server/etc/init.d
155 $(MKDIR) debian/disorder-server/usr/lib/cgi-bin
156 $(MKDIR) debian/disorder-server/var/lib/disorder
157 $(INSTALL_SCRIPT) examples/disorder.init \
158 debian/disorder-server/etc/init.d/disorder
159 $(INSTALL_DATA) debian/etc.disorder.config \
160 debian/disorder-server/etc/disorder/config
161 $(INSTALL_DATA) templates/options \
162 debian/disorder-server/etc/disorder/options
163 $(INSTALL_DATA) debian/etc.disorder.options.user \
164 debian/disorder-server/etc/disorder/options.user
165 $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) server/disorder.cgi \
166 $(shell pwd)/debian/disorder-server/usr/lib/cgi-bin/disorder
167 dpkg-shlibdeps -Tdebian/substvars.disorder-server \
168 debian/disorder-server/usr/lib/cgi-bin/disorder \
169 debian/disorder-server/usr/sbin/* \
170 debian/disorder-server/usr/lib/disorder/*.so*
171 rm -rf debian/disorder-server/usr/share/doc/disorder-server
172 ln -s disorder debian/disorder-server/usr/share/doc/disorder-server
173 dpkg-gencontrol -isp -pdisorder-server -Pdebian/disorder-server -Tdebian/substvars.disorder-server
174 chown -R root:root debian/disorder-server
175 chmod -R g-ws debian/disorder-server
176 dpkg --build debian/disorder-server ..
177
178
179 .PHONY: cleanpkg-disorder-playrtp
180 cleanpkg-disorder-playrtp:
181 rm -rf debian/disorder-playrtp
182
183 .PHONY: pkg-disorder-playrtp
184 pkg-disorder-playrtp: build
185 rm -rf debian/disorder-playrtp
186 $(MKDIR) debian/disorder-playrtp
187 $(MKDIR) debian/disorder-playrtp/DEBIAN
188 $(MKDIR) debian/disorder-playrtp/usr/share/doc/disorder-playrtp
189 $(INSTALL_DATA) debian/copyright \
190 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/copyright
191 $(INSTALL_DATA) debian/changelog \
192 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/changelog.Debian
193 gzip -9 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/changelog.Debian
194 @for f in preinst postinst prerm postrm conffiles templates config; do\
195 if test -e debian/$$f.disorder-playrtp; then\
196 echo $(INSTALL_SCRIPT) debian/$$f.disorder-playrtp debian/disorder-playrtp/DEBIAN/$$f; \
197 $(INSTALL_SCRIPT) debian/$$f.disorder-playrtp debian/disorder-playrtp/DEBIAN/$$f; \
198 fi;\
199 done
200 $(MKDIR) debian/disorder-playrtp/usr/bin
201 $(MKDIR) debian/disorder-playrtp/usr/share/man/man1
202 $(INSTALL_PROGRAM) clients/disorder-playrtp \
203 debian/disorder-playrtp/usr/bin/disorder-playrtp
204 $(INSTALL_DATA) doc/disorder-playrtp.1 \
205 debian/disorder-playrtp/usr/share/man/man1/disorder-playrtp.1
206 dpkg-shlibdeps -Tdebian/substvars.disorder-playrtp \
207 debian/disorder-playrtp/usr/bin/*
208 $(INSTALL_DATA) debian/README.RTP \
209 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/README
210 $(INSTALL_DATA) CHANGES debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES
211 gzip -9f debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES \
212 debian/disorder-playrtp/usr/share/man/man*/*
213 dpkg-gencontrol -isp -pdisorder-playrtp -Pdebian/disorder-playrtp -Tdebian/substvars.disorder-playrtp
214 chown -R root:root debian/disorder-playrtp
215 chmod -R g-ws debian/disorder-playrtp
216 dpkg --build debian/disorder-playrtp ..
217
218
219 .PHONY: cleanpkg-disobedience
220 cleanpkg-disobedience:
221 rm -rf debian/disobedience
222
223 .PHONY: pkg-disobedience
224 pkg-disobedience: build
225 rm -rf debian/disobedience
226 $(MKDIR) debian/disobedience
227 $(MKDIR) debian/disobedience/DEBIAN
228 $(MKDIR) debian/disobedience/usr/share/doc/disobedience
229 $(INSTALL_DATA) debian/copyright \
230 debian/disobedience/usr/share/doc/disobedience/copyright
231 $(INSTALL_DATA) debian/changelog \
232 debian/disobedience/usr/share/doc/disobedience/changelog.Debian
233 gzip -9 debian/disobedience/usr/share/doc/disobedience/changelog.Debian
234 @for f in preinst postinst prerm postrm conffiles templates config; do\
235 if test -e debian/$$f.disobedience; then\
236 echo $(INSTALL_SCRIPT) debian/$$f.disobedience debian/disobedience/DEBIAN/$$f; \
237 $(INSTALL_SCRIPT) debian/$$f.disobedience debian/disobedience/DEBIAN/$$f; \
238 fi;\
239 done
240 $(MKDIR) debian/disobedience/usr/bin
241 $(MKDIR) debian/disobedience/usr/share/man/man1
242 $(MKDIR) debian/disobedience/usr/share/pixmaps
243 $(MKDIR) debian/disobedience/usr/share/menu
244 $(MAKE) -C disobedience install DESTDIR=`pwd`/debian/disobedience
245 $(INSTALL_DATA) doc/disobedience.1 \
246 debian/disobedience/usr/share/man/man1/disobedience.1
247 $(INSTALL_DATA) images/disobedience16x16.xpm \
248 images/disobedience32x32.xpm \
249 debian/disobedience/usr/share/pixmaps
250 $(INSTALL_DATA) debian/usr.share.menu.disobedience \
251 debian/disobedience/usr/share/menu/disobedience
252 dpkg-shlibdeps -Tdebian/substvars.disobedience \
253 debian/disobedience/usr/bin/*
254 rm -rf debian/disobedience/usr/share/doc/disobedience
255 ln -s disorder debian/disobedience/usr/share/doc/disobedience
256 dpkg-gencontrol -isp -pdisobedience -Pdebian/disobedience -Tdebian/substvars.disobedience
257 chown -R root:root debian/disobedience
258 chmod -R g-ws debian/disobedience
259 dpkg --build debian/disobedience ..
260
261
262 DEBVERSION:=$(shell dpkg-parsechangelog|awk '/Version:/ {print $$2}')
263 DSC=disorder_$(DEBVERSION).dsc
264 DEBSRC=disorder_$(DEBVERSION).tar.gz
265 VERSION=$(shell $(MAKE) echo-version)
266
267 source:
268 $(MAKE) dist
269 rm -rf disorder-$(VERSION)
270 tar xfz disorder-$(VERSION).tar.gz
271 dpkg-source -b disorder-$(VERSION)
272 rm -rf disorder-$(VERSION) disorder-$(VERSION).tar.gz
273
274 source-check: source
275 rm -rf disorder-$(DEBVERSION)
276 dpkg-source -x $(DSC)
277 cd disorder-$(DEBVERSION) && dpkg-buildpackage -r$(FAKEROOT)
278
279 .PHONY: source source-check
280
281 .PHONY: binary binary-arch binary-indep
282 binary: binary-arch binary-indep
283 binary-arch: pkg-disorder pkg-disorder-server pkg-disorder-playrtp pkg-disobedience
284 binary-indep:
285
286 .PHONY: clean
287 clean: cleanpkg-disorder cleanpkg-disorder-server cleanpkg-disorder-playrtp cleanpkg-disobedience
288 -$(MAKE) distclean
289 rm -f config.cache
290 rm -f debian/files
291 rm -f debian/substvars.*