Upgrade build system.
[checkpath] / debian / rules
index 1e1d915..abe7ec8 100755 (executable)
@@ -1,54 +1,12 @@
 #! /usr/bin/make -f
 
-build:
-       rm -rf build deb-build
-       mkdir deb-build
-       cd deb-build; ../configure --prefix=/usr --mandir=/usr/share/man
-       make -C deb-build
-       touch build
+CDBS = /usr/share/cdbs/1
+include $(CDBS)/class/autotools.mk
+include $(CDBS)/rules/debhelper.mk
 
-clean:
-       dh_clean
-       rm -rf deb-build build
+###--------------------------------------------------------------------------
+### General settings.
 
-install: build
-       dh_clean
-       make -C deb-build install DESTDIR=/home/mdw/src/chkpath/debian/tmp
-       mkdir -p debian/libcheckpath/usr debian/libcheckpath-dev/usr
-       mv debian/tmp/usr/lib debian/libcheckpath/usr/lib
-       rm -f debian/libcheckpath/usr/lib/*.la
-       mkdir -p debian/libcheckpath-dev/usr/lib
-       mv debian/libcheckpath/usr/lib/*.a debian/libcheckpath/usr/lib/*.so \
-               debian/libcheckpath-dev/usr/lib
-       mkdir -p debian/libcheckpath-dev/usr/share/man
-       mv debian/tmp/usr/share/man/man3 \
-               debian/libcheckpath-dev/usr/share/man
-       mkdir -p debian/libcheckpath-dev/usr/bin
-       mv debian/tmp/usr/bin/checkpath-config \
-               debian/libcheckpath-dev/usr/bin
+DEB_BUILDDIR = $(CURDIR)/build
 
-binary-indep:
-
-binary-arch: install
-       dh_testdir -a
-       dh_testroot -a
-       dh_compress -a
-       dh_installdocs -a
-       dh_shlibdeps -a
-       dh_gencontrol -a
-       dh_fixperms -a
-       dh_installdeb -a
-       dh_md5sums -a
-       dh_builddeb -a
-
-binary: binary-indep binary-arch
-
-source:
-       rm -rf deb-build/*.tar.gz deb-build/=deb=
-       make -C deb-build dist PACKAGE=checkpath
-       mkdir deb-build/=deb=
-       cd deb-build/=deb=; tar xvfz ../*.tar.gz
-       d=`pwd`; cd ..; dpkg-source -i -b $$d/deb-build/=deb=/*
-       rm -rf deb-build/=deb=
-
-.PHONY: binary binary-arch binary-indep clean install source 
+###----- That's all, folks --------------------------------------------------