Debianization.
[checkpath-python] / debian / rules
1 #! /usr/bin/make -f
2
3 export DH_COMPAT = 4
4
5 DEFVERSION = 2.3
6 VERSIONS = $(DEFVERSION) 2.4
7
8 build: build-stamp
9
10 build-stamp:
11 for v in $(VERSIONS); do python$$v setup.py build; done
12 touch build-stamp
13
14 clean:
15 dh_clean
16 make clean
17 rm -rf build build-stamp
18
19 install: build
20 dh_clean
21 for v in $(VERSIONS); do \
22 python$$v setup.py build; \
23 python$$v setup.py install --root=debian/python$$v-checkpath; \
24 done
25 mkdir -p debian/python-checkpath
26
27 binary-indep: install
28 dh_testdir -i
29 dh_testroot -i
30 dh_compress -i
31 dh_installdocs -i
32 dh_python -i
33 dh_gencontrol -i
34 dh_fixperms -i
35 dh_installdeb -i
36 dh_md5sums -i
37 dh_builddeb -i
38
39 binary-arch: install
40 dh_testdir -a
41 dh_testroot -a
42 dh_compress -a
43 dh_installdocs -a
44 dh_strip -a
45 dh_shlibdeps -a
46 dh_python -a
47 dh_gencontrol -a
48 dh_fixperms -a
49 dh_installdeb -a
50 dh_md5sums -a
51 dh_builddeb -a
52
53 binary: binary-indep binary-arch
54
55 source:
56 rm -rf dist/*.tar.gz dist/=deb=
57 python setup.py sdist
58 mkdir dist/=deb=
59 cd dist/=deb=; tar xvfz ../*.tar.gz
60 d=`pwd`; cd ..; dpkg-source -i -i'/\.svn/' -b $$d/dist/=deb=/*
61 rm -rf dist/=deb=
62
63 .PHONY: binary binary-arch binary-indep clean install source build