Release 2.2.4.
[catacomb] / debian / changelog
1 catacomb (2.2.4) experimental; urgency=low
2
3 * build: Fix build failures on post-wheezy Debian versions.
4 * catacomb2: Use ARM AES instructions if available. (But they can't be
5 assembled using wheezy's version of gas, so this doesn't work in the
6 binary package.)
7 * catacomb2: Fix poor performance (and wrong answers for very small
8 numbers) in prime generation.
9 * catacomb2: Return numbers of exactly the requested length in prime and
10 public-key generation. The `strongprime' and `limlee' algorithms have
11 changed as a result; previously verifiable parameters generated using
12 this algorithm won't be verifiable any more.
13 * catacomb-dev: Deprecate the old `dsa' functions. Use `gdsa' instead.
14
15 -- Mark Wooding <mdw@distorted.org.uk> Sun, 26 Jun 2016 14:18:14 +0100
16
17 catacomb (2.2.3) experimental; urgency=low
18
19 * rand: Make the main generator resiliant in the face of fork(2).
20 * rand: Introduce `rand_quick', which may also mix in CPU-level
21 randomness sources.
22 * rand: Use higher-resolution timer in the quick-win noise source.
23 * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
24 which got lost down the side of the sofas.
25
26 -- Mark Wooding <mdw@distorted.org.uk> Mon, 13 Jun 2016 22:22:33 +0100
27
28 catacomb (2.2.2) experimental; urgency=low
29
30 * build: Cope with newer Autotools and related equipment.
31 * Miscellaneous small fixes for Cygwin.
32 * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
33 particularly, this causes a segfault reading bit zero of a zero-length
34 integer.
35
36 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:12:01 +0100
37
38 catacomb (2.2.1.1) experimental; urgency=low
39
40 * Arrange that catacomb-dev Depends on correct version of mlib-dev. It
41 really won't work well without it.
42
43 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 09:04:50 +0000
44
45 catacomb (2.2.1) experimental; urgency=low
46
47 * Some internal improvements.
48 * Debian packaging cleanups (fix build-depends, update mLib dependency).
49
50 -- Mark Wooding <mdw@distorted.org.uk> Thu, 18 Feb 2016 16:43:09 +0000
51
52 catacomb (2.2.0) experimental; urgency=low
53
54 * catacomb2: Fix rsa_recover crash on even modulus.
55 * catacomb-bin: Report error taking factorial of negative input.
56 * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
57 * catacomb-dev: Support multiple flavours of EC point compression.
58 * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
59 out of prime numbers.
60 * catacomb2: Overhaul crypto primitives used in true-random generator.
61 * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
62 support.
63 * catacomb-dev: New conversions between MP integers and C integer types.
64 * catacomb2: Change gcipher for Seal incompatibly. The IV is now
65 big-endian bytes (rather than `uint32'), and the `block size' is 4.
66 * catacomb2: Mix a constant string into DSA nonce generation to improve
67 resistance to protocol interference.
68 * catacomb2: Fix the freewheel random source, which hasn't been enabled
69 for ages due to a configure-script bug.
70 * catacomb-bin: The key tool can now read and write multiple
71 presentations for key fingerprints.
72 * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
73 stream ciphers.
74
75 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 14:15:31 +0100
76
77 catacomb (2.1.7) experimental; urgency=low
78
79 * A number of entropy-source fixes.
80 * Internal tidying.
81 * Add more elliptic curves, from Brainpool and BADA55.
82 * hashsum: Fix hash file verification.
83
84 -- Mark Wooding <mdw@distorted.org.uk> Wed, 16 Jul 2014 10:21:23 +0100
85
86 catacomb (2.1.6.1) experimental; urgency=low
87
88 * Fix building from source tarball.
89 * Fix building with Python 2.5.
90
91 -- Mark Wooding <mdw@distorted.org.uk> Sat, 28 Dec 2013 14:21:36 +0000
92
93 catacomb (2.1.6) experimental; urgency=low
94
95 * mpreduce: Extend domain to all positive integers.
96 * gfreduce: Fix out-of-bounds memory access.
97 * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
98 * pixie: Don't replace existing pixie unless explicitly requested.
99
100 -- Mark Wooding <mdw@distorted.org.uk> Fri, 27 Dec 2013 14:28:57 +0000
101
102 catacomb (2.1.5) experimental; urgency=low
103
104 * New build system.
105
106 -- Mark Wooding <mdw@distorted.org.uk> Mon, 29 Jun 2013 00:38:58 +0100
107
108 catacomb (2.1.4) experimental; urgency=low
109
110 * Constant-time operations.
111 * Some minor fixes to header files.
112
113 -- Mark Wooding <mdw@distorted.org.uk> Mon, 27 May 2013 22:34:23 +0100
114
115 catacomb (2.1.3) experimental; urgency=low
116
117 * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
118 example program.
119 * Upper bounds on phrase entropy in mkphrase(1).
120 * Don't make the Pixie setuid-root by default. Make the documentation
121 less scary.
122
123 -- Mark Wooding <mdw@distorted.org.uk> Thu, 11 Apr 2013 12:06:28 +0100
124
125 catacomb (2.1.2.1) experimental; urgency=low
126
127 * hashsum: Document `--progress' option in `--help' output.
128
129 -- Mark Wooding <mdw@distorted.org.uk> Thu, 28 Feb 2013 17:35:49 +0000
130
131 catacomb (2.1.2) experimental; urgency=low
132
133 * hashsum: Correct return code when running in `-c' mode.
134 * dsig: Fix core dump on large-ish outputs.
135 * dsig: Fix repeat-close bug.
136 * dsig: Accept precomputed hashes when making signatures.
137 * Utilities: New `-p' option for progress bars.
138 * dsig, hashsum: New `-j' option checks for files not covered by
139 manifest.
140 * Various library improvements.
141
142 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 03:26:44 +0000
143
144 catacomb (2.1.1) experimental; urgency=low
145
146 * Do configuration through pkgconfig.
147
148 -- Mark Wooding <mdw@distorted.org.uk> Mon, 17 Mar 2008 18:36:30 +0000
149
150 catacomb (2.1.0) experimental; urgency=low
151
152 * Added support for elliptic curves, on both prime and binary fields
153 (polynomial basis only). No actual crypto, but there's enough already
154 to do ECDH and stuff on well-known curves Testing is currently a bit
155 patchy.
156
157 -- Mark Wooding <mdw@nsict.org> Sun, 21 Mar 2004 22:47:56 +0000
158
159 catacomb (2.0.1) experimental; urgency=low
160
161 * Debianization!
162 * (pixie): Don't report uninteresting errors when accepting connections.
163
164 -- Mark Wooding <mdw@nsict.org> Thu, 11 Dec 2003 10:47:59 +0000