Release 2.3.0.
[catacomb] / debian / changelog
1 catacomb (2.3.0) experimental; urgency=low
2
3 * catacomb2: Use the correct Oakley 2048 group. For a long time, this
4 was a duplicate of the Oakley 1536 group. There's a compatibility
5 break here, but it's for the best.
6 * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
7 so that the process stack doesn't get marked executable.
8 * catacomb2: New SSE2-based multipliers for i386 and AMD64.
9 * catacomb2: Lots of other improvements to the assembler code.
10
11 -- Mark Wooding <mdw@distorted.org.uk> Mon, 03 Apr 2017 10:24:17 +0100
12
13 catacomb (2.2.5) experimental; urgency=low
14
15 * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
16 is unaligned.
17 * build: Use less obsolete macro names in configure script.
18
19 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jul 2016 10:27:05 +0100
20
21 catacomb (2.2.4) experimental; urgency=low
22
23 * build: Fix build failures on post-wheezy Debian versions.
24 * catacomb2: Use ARM AES instructions if available. (But they can't be
25 assembled using wheezy's version of gas, so this doesn't work in the
26 binary package.)
27 * catacomb2: Fix poor performance (and wrong answers for very small
28 numbers) in prime generation.
29 * catacomb2: Return numbers of exactly the requested length in prime and
30 public-key generation. The `strongprime' and `limlee' algorithms have
31 changed as a result; previously verifiable parameters generated using
32 this algorithm won't be verifiable any more.
33 * catacomb-dev: Deprecate the old `dsa' functions. Use `gdsa' instead.
34
35 -- Mark Wooding <mdw@distorted.org.uk> Sun, 26 Jun 2016 14:18:14 +0100
36
37 catacomb (2.2.3) experimental; urgency=low
38
39 * rand: Make the main generator resiliant in the face of fork(2).
40 * rand: Introduce `rand_quick', which may also mix in CPU-level
41 randomness sources.
42 * rand: Use higher-resolution timer in the quick-win noise source.
43 * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
44 which got lost down the side of the sofas.
45
46 -- Mark Wooding <mdw@distorted.org.uk> Mon, 13 Jun 2016 22:22:33 +0100
47
48 catacomb (2.2.2) experimental; urgency=low
49
50 * build: Cope with newer Autotools and related equipment.
51 * Miscellaneous small fixes for Cygwin.
52 * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
53 particularly, this causes a segfault reading bit zero of a zero-length
54 integer.
55
56 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:12:01 +0100
57
58 catacomb (2.2.1.1) experimental; urgency=low
59
60 * Arrange that catacomb-dev Depends on correct version of mlib-dev. It
61 really won't work well without it.
62
63 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 09:04:50 +0000
64
65 catacomb (2.2.1) experimental; urgency=low
66
67 * Some internal improvements.
68 * Debian packaging cleanups (fix build-depends, update mLib dependency).
69
70 -- Mark Wooding <mdw@distorted.org.uk> Thu, 18 Feb 2016 16:43:09 +0000
71
72 catacomb (2.2.0) experimental; urgency=low
73
74 * catacomb2: Fix rsa_recover crash on even modulus.
75 * catacomb-bin: Report error taking factorial of negative input.
76 * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
77 * catacomb-dev: Support multiple flavours of EC point compression.
78 * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
79 out of prime numbers.
80 * catacomb2: Overhaul crypto primitives used in true-random generator.
81 * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
82 support.
83 * catacomb-dev: New conversions between MP integers and C integer types.
84 * catacomb2: Change gcipher for Seal incompatibly. The IV is now
85 big-endian bytes (rather than `uint32'), and the `block size' is 4.
86 * catacomb2: Mix a constant string into DSA nonce generation to improve
87 resistance to protocol interference.
88 * catacomb2: Fix the freewheel random source, which hasn't been enabled
89 for ages due to a configure-script bug.
90 * catacomb-bin: The key tool can now read and write multiple
91 presentations for key fingerprints.
92 * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
93 stream ciphers.
94
95 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 14:15:31 +0100
96
97 catacomb (2.1.7) experimental; urgency=low
98
99 * A number of entropy-source fixes.
100 * Internal tidying.
101 * Add more elliptic curves, from Brainpool and BADA55.
102 * hashsum: Fix hash file verification.
103
104 -- Mark Wooding <mdw@distorted.org.uk> Wed, 16 Jul 2014 10:21:23 +0100
105
106 catacomb (2.1.6.1) experimental; urgency=low
107
108 * Fix building from source tarball.
109 * Fix building with Python 2.5.
110
111 -- Mark Wooding <mdw@distorted.org.uk> Sat, 28 Dec 2013 14:21:36 +0000
112
113 catacomb (2.1.6) experimental; urgency=low
114
115 * mpreduce: Extend domain to all positive integers.
116 * gfreduce: Fix out-of-bounds memory access.
117 * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
118 * pixie: Don't replace existing pixie unless explicitly requested.
119
120 -- Mark Wooding <mdw@distorted.org.uk> Fri, 27 Dec 2013 14:28:57 +0000
121
122 catacomb (2.1.5) experimental; urgency=low
123
124 * New build system.
125
126 -- Mark Wooding <mdw@distorted.org.uk> Mon, 29 Jun 2013 00:38:58 +0100
127
128 catacomb (2.1.4) experimental; urgency=low
129
130 * Constant-time operations.
131 * Some minor fixes to header files.
132
133 -- Mark Wooding <mdw@distorted.org.uk> Mon, 27 May 2013 22:34:23 +0100
134
135 catacomb (2.1.3) experimental; urgency=low
136
137 * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
138 example program.
139 * Upper bounds on phrase entropy in mkphrase(1).
140 * Don't make the Pixie setuid-root by default. Make the documentation
141 less scary.
142
143 -- Mark Wooding <mdw@distorted.org.uk> Thu, 11 Apr 2013 12:06:28 +0100
144
145 catacomb (2.1.2.1) experimental; urgency=low
146
147 * hashsum: Document `--progress' option in `--help' output.
148
149 -- Mark Wooding <mdw@distorted.org.uk> Thu, 28 Feb 2013 17:35:49 +0000
150
151 catacomb (2.1.2) experimental; urgency=low
152
153 * hashsum: Correct return code when running in `-c' mode.
154 * dsig: Fix core dump on large-ish outputs.
155 * dsig: Fix repeat-close bug.
156 * dsig: Accept precomputed hashes when making signatures.
157 * Utilities: New `-p' option for progress bars.
158 * dsig, hashsum: New `-j' option checks for files not covered by
159 manifest.
160 * Various library improvements.
161
162 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 03:26:44 +0000
163
164 catacomb (2.1.1) experimental; urgency=low
165
166 * Do configuration through pkgconfig.
167
168 -- Mark Wooding <mdw@distorted.org.uk> Mon, 17 Mar 2008 18:36:30 +0000
169
170 catacomb (2.1.0) experimental; urgency=low
171
172 * Added support for elliptic curves, on both prime and binary fields
173 (polynomial basis only). No actual crypto, but there's enough already
174 to do ECDH and stuff on well-known curves Testing is currently a bit
175 patchy.
176
177 -- Mark Wooding <mdw@nsict.org> Sun, 21 Mar 2004 22:47:56 +0000
178
179 catacomb (2.0.1) experimental; urgency=low
180
181 * Debianization!
182 * (pixie): Don't report uninteresting errors when accepting connections.
183
184 -- Mark Wooding <mdw@nsict.org> Thu, 11 Dec 2003 10:47:59 +0000