Release 2.4.5.
[catacomb] / debian / changelog
1 catacomb (2.4.5) experimental; urgency=medium
2
3 * catacomb: Fix memory leak in key-file error handling.
4 * catacomb: Don't leak internal `exptime' symbol into the global
5 namespace.
6 * catacomb: Check that the X86 `rdrand' instruction actually works
7 before leaning on it. This is in response to the well-publicized AMD
8 bug which always returns all-bits-set with the carry /set/ (indicating
9 success).
10 * catacomb: Mix in the random pool key during `rand_gate' and
11 `rand_stretch' operations.
12 * catacomb: Fix by-tag key lookups: if the query string looks like a hex
13 number, it's treated as a search by id; but if no such id is found,
14 the search wouldn't continue to look for a key by type or tag.
15 * catacomb: Fix reference leak in `key_split'.
16 * catacomb: Fix bug which completely broke `key_copydata'.
17 * catacomb: Fix segfault from `pgen', if it fails before setting up the
18 prime tester.
19 * catacomb: Propagate failure from `pgen' during Lim--Lee prime
20 generation, rather than immediately retrying.
21 * catacomb: Fix memory leak of factor vector from failed Lim--Lee prime
22 generation.
23 * catacomb: Fix segfault when multiplying the identity elliptic-curve
24 point.
25 * catacomb: Fix the `lcrand' descriptor, so that it's not advertised as
26 being cryptographically strong, and to fix a bias in its output.
27 * catacomb: Fix a memory leak in the error case of KCDSA prime
28 generation.
29 * catacomb-bin: Fix segfault from `pixie', if given an empty passphrase
30 to remember.
31 * catacomb: Check SIMD feature bit on ARM64 before using the optimized
32 code. I don't know of any ARM64 implementations which lack SIMD
33 instructions, but the bit must be there for a reason, so I might as
34 well use it.
35 * catacomb: Support parsing binary-group descriptions. This is a long-
36 standing lacuna that I've only recently noticed.
37
38 -- Mark Wooding <mdw@distorted.org.uk> Sat, 09 May 2020 17:46:24 +0100
39
40 catacomb (2.4.4) experimental; urgency=medium
41
42 * debian: Bump to Debhelper 10.
43 * debian: Ship a shared-library `symbols' file for more precise
44 dependencies.
45
46 -- Mark Wooding <mdw@distorted.org.uk> Sun, 29 Sep 2019 15:58:26 +0100
47
48 catacomb (2.4.3) experimental; urgency=medium
49
50 * catacomb (idea): Fix key-length descriptor.
51 * catacomb (xchachaNN): Fix nonce-size descriptor.
52 * catacomb (key-management): Fix incorrect handling of keyring
53 modifiability.
54 * catacomb-dev: Configure `pkg-config' correctly for static linking.
55 * catacomb, catacomb-bin (cookie, dsig): Fix hash-function length
56 padding on very long messages, and handling of large datestamps.
57 * catacomb-bin (catsign): Don't open temporary files unnecessarily.
58 * catacomb-bin (catcrypt): Fix key-attribute parsing.
59 * catacomb-bin (perftest): Add missing help-string text for `-n' used
60 with `enc' and `hash'
61
62 -- Mark Wooding <mdw@distorted.org.uk> Sat, 21 Sep 2019 17:43:59 +0100
63
64 catacomb (2.4.2) experimental; urgency=medium
65
66 * catacomb2: Support multi-arch at last.
67 * catacomb2: Fix mangled key-size data for HMAC.
68 * rspit: Support generating large files.
69 * pixie: Improve error-handling around dropping privilege.
70 * ed25519, ed448: Very minor performance improvement.
71 * salsa20, chacha: Fix crash if nonce is none, as it is when invoked by
72 `rspit'.
73 * salsa20, chacha: Fix declaration of cipher classes to prevent them
74 ending up as (useless) common symbols in client code.
75 * limlee: Improve the prime size heuristics.
76 * sha, sha256, sha512: Restructure compression function to improve
77 performance and use less memory.
78 * rijndael: Include enough round constants to make very tiny keys work
79 correctly.
80
81 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jun 2018 01:15:59 +0100
82
83 catacomb (2.4.1) experimental; urgency=low
84
85 * catacomb2: Two's-complement fix from 2.3.x release branch.
86
87 -- Mark Wooding <mdw@distorted.org.uk> Thu, 22 Jun 2017 09:37:40 +0100
88
89 catacomb (2.4.0.1) experimental; urgency=low
90
91 * Fix build failure with later ARM assemblers.
92
93 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 21:05:35 +0100
94
95 catacomb (2.4.0) experimental; urgency=low
96
97 * catacomb2: Implemented Bernstein's Poly1305 message-authentication
98 code.
99 * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
100 and Salsa20.
101 * catacomb2: Implement Bernstein's X25519.
102 * catacomb2: Implement Hamburg's X448 (RFC7748).
103 * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
104 as defined in RFC8032.
105 * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
106 RFC8032.
107 * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
108 * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
109 * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
110 * catacomb2: Allow RSA key generation with chosen public exponent.
111 * catacomb2: Optimize RSA public-key operations with common public
112 exponents.
113 * catacomb-bin: Support new algorithms in the provided tools.
114 * catacomb-bin: Allow parameters keys for all key types.
115
116 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 16:07:00 +0100
117
118 catacomb (2.3.2) experimental; urgency=low
119
120 * catacomb2: Fix bignum loading and storing in two's complement form.
121
122 -- Mark Wooding <mdw@distorted.org.uk> Thu, 22 Jun 2017 09:34:59 +0100
123
124 catacomb (2.3.1) experimental; urgency=low
125
126 * catacomb2: Fix memory corruption when allocating `salsa20' and
127 `chacha'-based RNGs.
128 * catacomb2: Fix segfault when opening read-only keyring with no
129 associated file.
130 * catacomb2: Return the correct stream offset in `chacha_tell*'.
131 * catacomb2: Produce correct keyring files when they contain empty
132 keys.
133 * catacomb2: Fix cross-compilation-unit type incompatibility in prime
134 and binary group implementations.
135 * catacomb-dev: Add missing licence notices to `salsa20.h'.
136 * catacomb-bin: Fix assertion failure in RSA-PSS signing.
137 * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
138 verifying.
139 * catacomb-bin: Compare MAC tags in constant time.
140 * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
141
142 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 04:05:00 +0100
143
144 catacomb (2.3.0.1) experimental; urgency=low
145
146 * catacomb2: Actually make the stack non-executable rather than just
147 pretending.
148
149 -- Mark Wooding <mdw@distorted.org.uk> Wed, 05 Apr 2017 09:00:55 +0100
150
151 catacomb (2.3.0) experimental; urgency=low
152
153 * catacomb2: Use the correct Oakley 2048 group. For a long time, this
154 was a duplicate of the Oakley 1536 group. There's a compatibility
155 break here, but it's for the best.
156 * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
157 so that the process stack doesn't get marked executable.
158 * catacomb2: New SSE2-based multipliers for i386 and AMD64.
159 * catacomb2: Lots of other improvements to the assembler code.
160
161 -- Mark Wooding <mdw@distorted.org.uk> Mon, 03 Apr 2017 10:24:17 +0100
162
163 catacomb (2.2.5) experimental; urgency=low
164
165 * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
166 is unaligned.
167 * build: Use less obsolete macro names in configure script.
168
169 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jul 2016 10:27:05 +0100
170
171 catacomb (2.2.4) experimental; urgency=low
172
173 * build: Fix build failures on post-wheezy Debian versions.
174 * catacomb2: Use ARM AES instructions if available. (But they can't be
175 assembled using wheezy's version of gas, so this doesn't work in the
176 binary package.)
177 * catacomb2: Fix poor performance (and wrong answers for very small
178 numbers) in prime generation.
179 * catacomb2: Return numbers of exactly the requested length in prime and
180 public-key generation. The `strongprime' and `limlee' algorithms have
181 changed as a result; previously verifiable parameters generated using
182 this algorithm won't be verifiable any more.
183 * catacomb-dev: Deprecate the old `dsa' functions. Use `gdsa' instead.
184
185 -- Mark Wooding <mdw@distorted.org.uk> Sun, 26 Jun 2016 14:18:14 +0100
186
187 catacomb (2.2.3) experimental; urgency=low
188
189 * rand: Make the main generator resiliant in the face of fork(2).
190 * rand: Introduce `rand_quick', which may also mix in CPU-level
191 randomness sources.
192 * rand: Use higher-resolution timer in the quick-win noise source.
193 * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
194 which got lost down the side of the sofas.
195
196 -- Mark Wooding <mdw@distorted.org.uk> Mon, 13 Jun 2016 22:22:33 +0100
197
198 catacomb (2.2.2) experimental; urgency=low
199
200 * build: Cope with newer Autotools and related equipment.
201 * Miscellaneous small fixes for Cygwin.
202 * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
203 particularly, this causes a segfault reading bit zero of a zero-length
204 integer.
205
206 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:12:01 +0100
207
208 catacomb (2.2.1.1) experimental; urgency=low
209
210 * Arrange that catacomb-dev Depends on correct version of mlib-dev. It
211 really won't work well without it.
212
213 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 09:04:50 +0000
214
215 catacomb (2.2.1) experimental; urgency=low
216
217 * Some internal improvements.
218 * Debian packaging cleanups (fix build-depends, update mLib dependency).
219
220 -- Mark Wooding <mdw@distorted.org.uk> Thu, 18 Feb 2016 16:43:09 +0000
221
222 catacomb (2.2.0) experimental; urgency=low
223
224 * catacomb2: Fix rsa_recover crash on even modulus.
225 * catacomb-bin: Report error taking factorial of negative input.
226 * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
227 * catacomb-dev: Support multiple flavours of EC point compression.
228 * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
229 out of prime numbers.
230 * catacomb2: Overhaul crypto primitives used in true-random generator.
231 * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
232 support.
233 * catacomb-dev: New conversions between MP integers and C integer types.
234 * catacomb2: Change gcipher for Seal incompatibly. The IV is now
235 big-endian bytes (rather than `uint32'), and the `block size' is 4.
236 * catacomb2: Mix a constant string into DSA nonce generation to improve
237 resistance to protocol interference.
238 * catacomb2: Fix the freewheel random source, which hasn't been enabled
239 for ages due to a configure-script bug.
240 * catacomb-bin: The key tool can now read and write multiple
241 presentations for key fingerprints.
242 * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
243 stream ciphers.
244
245 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 14:15:31 +0100
246
247 catacomb (2.1.7) experimental; urgency=low
248
249 * A number of entropy-source fixes.
250 * Internal tidying.
251 * Add more elliptic curves, from Brainpool and BADA55.
252 * hashsum: Fix hash file verification.
253
254 -- Mark Wooding <mdw@distorted.org.uk> Wed, 16 Jul 2014 10:21:23 +0100
255
256 catacomb (2.1.6.1) experimental; urgency=low
257
258 * Fix building from source tarball.
259 * Fix building with Python 2.5.
260
261 -- Mark Wooding <mdw@distorted.org.uk> Sat, 28 Dec 2013 14:21:36 +0000
262
263 catacomb (2.1.6) experimental; urgency=low
264
265 * mpreduce: Extend domain to all positive integers.
266 * gfreduce: Fix out-of-bounds memory access.
267 * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
268 * pixie: Don't replace existing pixie unless explicitly requested.
269
270 -- Mark Wooding <mdw@distorted.org.uk> Fri, 27 Dec 2013 14:28:57 +0000
271
272 catacomb (2.1.5) experimental; urgency=low
273
274 * New build system.
275
276 -- Mark Wooding <mdw@distorted.org.uk> Mon, 29 Jun 2013 00:38:58 +0100
277
278 catacomb (2.1.4) experimental; urgency=low
279
280 * Constant-time operations.
281 * Some minor fixes to header files.
282
283 -- Mark Wooding <mdw@distorted.org.uk> Mon, 27 May 2013 22:34:23 +0100
284
285 catacomb (2.1.3) experimental; urgency=low
286
287 * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
288 example program.
289 * Upper bounds on phrase entropy in mkphrase(1).
290 * Don't make the Pixie setuid-root by default. Make the documentation
291 less scary.
292
293 -- Mark Wooding <mdw@distorted.org.uk> Thu, 11 Apr 2013 12:06:28 +0100
294
295 catacomb (2.1.2.1) experimental; urgency=low
296
297 * hashsum: Document `--progress' option in `--help' output.
298
299 -- Mark Wooding <mdw@distorted.org.uk> Thu, 28 Feb 2013 17:35:49 +0000
300
301 catacomb (2.1.2) experimental; urgency=low
302
303 * hashsum: Correct return code when running in `-c' mode.
304 * dsig: Fix core dump on large-ish outputs.
305 * dsig: Fix repeat-close bug.
306 * dsig: Accept precomputed hashes when making signatures.
307 * Utilities: New `-p' option for progress bars.
308 * dsig, hashsum: New `-j' option checks for files not covered by
309 manifest.
310 * Various library improvements.
311
312 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 03:26:44 +0000
313
314 catacomb (2.1.1) experimental; urgency=low
315
316 * Do configuration through pkgconfig.
317
318 -- Mark Wooding <mdw@distorted.org.uk> Mon, 17 Mar 2008 18:36:30 +0000
319
320 catacomb (2.1.0) experimental; urgency=low
321
322 * Added support for elliptic curves, on both prime and binary fields
323 (polynomial basis only). No actual crypto, but there's enough already
324 to do ECDH and stuff on well-known curves Testing is currently a bit
325 patchy.
326
327 -- Mark Wooding <mdw@nsict.org> Sun, 21 Mar 2004 22:47:56 +0000
328
329 catacomb (2.0.1) experimental; urgency=low
330
331 * Debianization!
332 * (pixie): Don't report uninteresting errors when accepting connections.
333
334 -- Mark Wooding <mdw@nsict.org> Thu, 11 Dec 2003 10:47:59 +0000