rand/rand.c (rdrand_quick): Improve the loop.
[catacomb] / debian / changelog
1 catacomb (2.2.2) experimental; urgency=low
2
3 * build: Cope with newer Autotools and related equipment.
4 * Miscellaneous small fixes for Cygwin.
5 * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
6 particularly, this causes a segfault reading bit zero of a zero-length
7 integer.
8
9 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:12:01 +0100
10
11 catacomb (2.2.1) experimental; urgency=low
12
13 * Some internal improvements.
14 * Debian packaging cleanups (fix build-depends, update mLib dependency).
15
16 -- Mark Wooding <mdw@distorted.org.uk> Thu, 18 Feb 2016 16:43:09 +0000
17
18 catacomb (2.2.0) experimental; urgency=low
19
20 * catacomb2: Fix rsa_recover crash on even modulus.
21 * catacomb-bin: Report error taking factorial of negative input.
22 * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
23 * catacomb-dev: Support multiple flavours of EC point compression.
24 * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
25 out of prime numbers.
26 * catacomb2: Overhaul crypto primitives used in true-random generator.
27 * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
28 support.
29 * catacomb-dev: New conversions between MP integers and C integer types.
30 * catacomb2: Change gcipher for Seal incompatibly. The IV is now
31 big-endian bytes (rather than `uint32'), and the `block size' is 4.
32 * catacomb2: Mix a constant string into DSA nonce generation to improve
33 resistance to protocol interference.
34 * catacomb2: Fix the freewheel random source, which hasn't been enabled
35 for ages due to a configure-script bug.
36 * catacomb-bin: The key tool can now read and write multiple
37 presentations for key fingerprints.
38 * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
39 stream ciphers.
40
41 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 14:15:31 +0100
42
43 catacomb (2.1.7) experimental; urgency=low
44
45 * A number of entropy-source fixes.
46 * Internal tidying.
47 * Add more elliptic curves, from Brainpool and BADA55.
48 * hashsum: Fix hash file verification.
49
50 -- Mark Wooding <mdw@distorted.org.uk> Wed, 16 Jul 2014 10:21:23 +0100
51
52 catacomb (2.1.6.1) experimental; urgency=low
53
54 * Fix building from source tarball.
55 * Fix building with Python 2.5.
56
57 -- Mark Wooding <mdw@distorted.org.uk> Sat, 28 Dec 2013 14:21:36 +0000
58
59 catacomb (2.1.6) experimental; urgency=low
60
61 * mpreduce: Extend domain to all positive integers.
62 * gfreduce: Fix out-of-bounds memory access.
63 * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
64 * pixie: Don't replace existing pixie unless explicitly requested.
65
66 -- Mark Wooding <mdw@distorted.org.uk> Fri, 27 Dec 2013 14:28:57 +0000
67
68 catacomb (2.1.5) experimental; urgency=low
69
70 * New build system.
71
72 -- Mark Wooding <mdw@distorted.org.uk> Mon, 29 Jun 2013 00:38:58 +0100
73
74 catacomb (2.1.4) experimental; urgency=low
75
76 * Constant-time operations.
77 * Some minor fixes to header files.
78
79 -- Mark Wooding <mdw@distorted.org.uk> Mon, 27 May 2013 22:34:23 +0100
80
81 catacomb (2.1.3) experimental; urgency=low
82
83 * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
84 example program.
85 * Upper bounds on phrase entropy in mkphrase(1).
86 * Don't make the Pixie setuid-root by default. Make the documentation
87 less scary.
88
89 -- Mark Wooding <mdw@distorted.org.uk> Thu, 11 Apr 2013 12:06:28 +0100
90
91 catacomb (2.1.2.1) experimental; urgency=low
92
93 * hashsum: Document `--progress' option in `--help' output.
94
95 -- Mark Wooding <mdw@distorted.org.uk> Thu, 28 Feb 2013 17:35:49 +0000
96
97 catacomb (2.1.2) experimental; urgency=low
98
99 * hashsum: Correct return code when running in `-c' mode.
100 * dsig: Fix core dump on large-ish outputs.
101 * dsig: Fix repeat-close bug.
102 * dsig: Accept precomputed hashes when making signatures.
103 * Utilities: New `-p' option for progress bars.
104 * dsig, hashsum: New `-j' option checks for files not covered by
105 manifest.
106 * Various library improvements.
107
108 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 03:26:44 +0000
109
110 catacomb (2.1.1) experimental; urgency=low
111
112 * Do configuration through pkgconfig.
113
114 -- Mark Wooding <mdw@distorted.org.uk> Mon, 17 Mar 2008 18:36:30 +0000
115
116 catacomb (2.1.0) experimental; urgency=low
117
118 * Added support for elliptic curves, on both prime and binary fields
119 (polynomial basis only). No actual crypto, but there's enough already
120 to do ECDH and stuff on well-known curves Testing is currently a bit
121 patchy.
122
123 -- Mark Wooding <mdw@nsict.org> Sun, 21 Mar 2004 22:47:56 +0000
124
125 catacomb (2.0.1) experimental; urgency=low
126
127 * Debianization!
128 * (pixie): Don't report uninteresting errors when accepting connections.
129
130 -- Mark Wooding <mdw@nsict.org> Thu, 11 Dec 2003 10:47:59 +0000