progs/perftest.c: Use from Glibc syscall numbers.
[catacomb] / debian / rules
1 #! /usr/bin/make -f
2 DH_OPTIONS = --parallel --without=autoreconf -Bdebian/build
3 %:; dh $@ $(DH_OPTIONS)
4
5 ## Test both with and without CPU-specific optimizations.
6 override_dh_auto_test:
7 dh_auto_test $(addprefix -O, $(DH_OPTIONS))
8 CATACOMB_CPUFEAT="-*" dh_auto_test $(addprefix -O, $(DH_OPTIONS))
9
10 ## Check that the shared-library symbols are plausible.
11 override_dh_makeshlibs:
12 dh_makeshlibs -- -c4