Merge branch '2.5.x'
[catacomb] / debian / changelog
1 catacomb (2.5.1) experimental; urgency=medium
2
3 * Merge changes from 2.4.4.
4
5 -- Mark Wooding <mdw@distorted.org.uk> Sun, 29 Sep 2019 17:50:59 +0100
6
7 catacomb (2.5.0) experimental; urgency=medium
8
9 * catacomb: MACs based on blockciphers: PMAC1 and CMAC (also known as
10 OMAC).
11 * catacomb: Authenticated Encryption with Additional Data (AEAD)
12 schemes. Some based on blockciphers: CCM, EAX, GCM (with CPU-specific
13 acceleration), OCB1 and OCB3 (OCB2 is broken). Also Salsa20 and
14 ChaCha20 with Poly1305: the RFC7539 scheme, and the NaCl `secret_box'
15 transform.
16 * catacomb: Implement Grantham's Frobenius test. Combine it with
17 Rabin--Miller, as Baillie--PSW, for testing given primes.
18 * catacomb-bin (catcrypt): Support AEAD schemes for bulk crypto.
19 * catacomb-bin (perftest): Options for batching; report cycle counts
20 where available.
21 * Many internal improvements: better documentation, debugging, testing,
22 etc.
23
24 -- Mark Wooding <mdw@distorted.org.uk> Sat, 21 Sep 2019 21:26:44 +0100
25
26 catacomb (2.4.4) experimental; urgency=medium
27
28 * debian: Bump to Debhelper 10.
29 * debian: Ship a shared-library `symbols' file for more precise
30 dependencies.
31
32 -- Mark Wooding <mdw@distorted.org.uk> Sun, 29 Sep 2019 15:58:26 +0100
33
34 catacomb (2.4.3) experimental; urgency=medium
35
36 * catacomb (idea): Fix key-length descriptor.
37 * catacomb (xchachaNN): Fix nonce-size descriptor.
38 * catacomb (key-management): Fix incorrect handling of keyring
39 modifiability.
40 * catacomb-dev: Configure `pkg-config' correctly for static linking.
41 * catacomb, catacomb-bin (cookie, dsig): Fix hash-function length
42 padding on very long messages, and handling of large datestamps.
43 * catacomb-bin (catsign): Don't open temporary files unnecessarily.
44 * catacomb-bin (catcrypt): Fix key-attribute parsing.
45 * catacomb-bin (perftest): Add missing help-string text for `-n' used
46 with `enc' and `hash'
47
48 -- Mark Wooding <mdw@distorted.org.uk> Sat, 21 Sep 2019 17:43:59 +0100
49
50 catacomb (2.4.2) experimental; urgency=medium
51
52 * catacomb2: Support multi-arch at last.
53 * catacomb2: Fix mangled key-size data for HMAC.
54 * rspit: Support generating large files.
55 * pixie: Improve error-handling around dropping privilege.
56 * ed25519, ed448: Very minor performance improvement.
57 * salsa20, chacha: Fix crash if nonce is none, as it is when invoked by
58 `rspit'.
59 * salsa20, chacha: Fix declaration of cipher classes to prevent them
60 ending up as (useless) common symbols in client code.
61 * limlee: Improve the prime size heuristics.
62 * sha, sha256, sha512: Restructure compression function to improve
63 performance and use less memory.
64 * rijndael: Include enough round constants to make very tiny keys work
65 correctly.
66
67 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jun 2018 01:15:59 +0100
68
69 catacomb (2.4.1) experimental; urgency=low
70
71 * catacomb2: Two's-complement fix from 2.3.x release branch.
72
73 -- Mark Wooding <mdw@distorted.org.uk> Thu, 22 Jun 2017 09:37:40 +0100
74
75 catacomb (2.4.0.1) experimental; urgency=low
76
77 * Fix build failure with later ARM assemblers.
78
79 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 21:05:35 +0100
80
81 catacomb (2.4.0) experimental; urgency=low
82
83 * catacomb2: Implemented Bernstein's Poly1305 message-authentication
84 code.
85 * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
86 and Salsa20.
87 * catacomb2: Implement Bernstein's X25519.
88 * catacomb2: Implement Hamburg's X448 (RFC7748).
89 * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
90 as defined in RFC8032.
91 * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
92 RFC8032.
93 * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
94 * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
95 * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
96 * catacomb2: Allow RSA key generation with chosen public exponent.
97 * catacomb2: Optimize RSA public-key operations with common public
98 exponents.
99 * catacomb-bin: Support new algorithms in the provided tools.
100 * catacomb-bin: Allow parameters keys for all key types.
101
102 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 16:07:00 +0100
103
104 catacomb (2.3.2) experimental; urgency=low
105
106 * catacomb2: Fix bignum loading and storing in two's complement form.
107
108 -- Mark Wooding <mdw@distorted.org.uk> Thu, 22 Jun 2017 09:34:59 +0100
109
110 catacomb (2.3.1) experimental; urgency=low
111
112 * catacomb2: Fix memory corruption when allocating `salsa20' and
113 `chacha'-based RNGs.
114 * catacomb2: Fix segfault when opening read-only keyring with no
115 associated file.
116 * catacomb2: Return the correct stream offset in `chacha_tell*'.
117 * catacomb2: Produce correct keyring files when they contain empty
118 keys.
119 * catacomb2: Fix cross-compilation-unit type incompatibility in prime
120 and binary group implementations.
121 * catacomb-dev: Add missing licence notices to `salsa20.h'.
122 * catacomb-bin: Fix assertion failure in RSA-PSS signing.
123 * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
124 verifying.
125 * catacomb-bin: Compare MAC tags in constant time.
126 * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
127
128 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 04:05:00 +0100
129
130 catacomb (2.3.0.1) experimental; urgency=low
131
132 * catacomb2: Actually make the stack non-executable rather than just
133 pretending.
134
135 -- Mark Wooding <mdw@distorted.org.uk> Wed, 05 Apr 2017 09:00:55 +0100
136
137 catacomb (2.3.0) experimental; urgency=low
138
139 * catacomb2: Use the correct Oakley 2048 group. For a long time, this
140 was a duplicate of the Oakley 1536 group. There's a compatibility
141 break here, but it's for the best.
142 * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
143 so that the process stack doesn't get marked executable.
144 * catacomb2: New SSE2-based multipliers for i386 and AMD64.
145 * catacomb2: Lots of other improvements to the assembler code.
146
147 -- Mark Wooding <mdw@distorted.org.uk> Mon, 03 Apr 2017 10:24:17 +0100
148
149 catacomb (2.2.5) experimental; urgency=low
150
151 * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
152 is unaligned.
153 * build: Use less obsolete macro names in configure script.
154
155 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jul 2016 10:27:05 +0100
156
157 catacomb (2.2.4) experimental; urgency=low
158
159 * build: Fix build failures on post-wheezy Debian versions.
160 * catacomb2: Use ARM AES instructions if available. (But they can't be
161 assembled using wheezy's version of gas, so this doesn't work in the
162 binary package.)
163 * catacomb2: Fix poor performance (and wrong answers for very small
164 numbers) in prime generation.
165 * catacomb2: Return numbers of exactly the requested length in prime and
166 public-key generation. The `strongprime' and `limlee' algorithms have
167 changed as a result; previously verifiable parameters generated using
168 this algorithm won't be verifiable any more.
169 * catacomb-dev: Deprecate the old `dsa' functions. Use `gdsa' instead.
170
171 -- Mark Wooding <mdw@distorted.org.uk> Sun, 26 Jun 2016 14:18:14 +0100
172
173 catacomb (2.2.3) experimental; urgency=low
174
175 * rand: Make the main generator resiliant in the face of fork(2).
176 * rand: Introduce `rand_quick', which may also mix in CPU-level
177 randomness sources.
178 * rand: Use higher-resolution timer in the quick-win noise source.
179 * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
180 which got lost down the side of the sofas.
181
182 -- Mark Wooding <mdw@distorted.org.uk> Mon, 13 Jun 2016 22:22:33 +0100
183
184 catacomb (2.2.2) experimental; urgency=low
185
186 * build: Cope with newer Autotools and related equipment.
187 * Miscellaneous small fixes for Cygwin.
188 * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
189 particularly, this causes a segfault reading bit zero of a zero-length
190 integer.
191
192 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:12:01 +0100
193
194 catacomb (2.2.1.1) experimental; urgency=low
195
196 * Arrange that catacomb-dev Depends on correct version of mlib-dev. It
197 really won't work well without it.
198
199 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 09:04:50 +0000
200
201 catacomb (2.2.1) experimental; urgency=low
202
203 * Some internal improvements.
204 * Debian packaging cleanups (fix build-depends, update mLib dependency).
205
206 -- Mark Wooding <mdw@distorted.org.uk> Thu, 18 Feb 2016 16:43:09 +0000
207
208 catacomb (2.2.0) experimental; urgency=low
209
210 * catacomb2: Fix rsa_recover crash on even modulus.
211 * catacomb-bin: Report error taking factorial of negative input.
212 * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
213 * catacomb-dev: Support multiple flavours of EC point compression.
214 * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
215 out of prime numbers.
216 * catacomb2: Overhaul crypto primitives used in true-random generator.
217 * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
218 support.
219 * catacomb-dev: New conversions between MP integers and C integer types.
220 * catacomb2: Change gcipher for Seal incompatibly. The IV is now
221 big-endian bytes (rather than `uint32'), and the `block size' is 4.
222 * catacomb2: Mix a constant string into DSA nonce generation to improve
223 resistance to protocol interference.
224 * catacomb2: Fix the freewheel random source, which hasn't been enabled
225 for ages due to a configure-script bug.
226 * catacomb-bin: The key tool can now read and write multiple
227 presentations for key fingerprints.
228 * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
229 stream ciphers.
230
231 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 14:15:31 +0100
232
233 catacomb (2.1.7) experimental; urgency=low
234
235 * A number of entropy-source fixes.
236 * Internal tidying.
237 * Add more elliptic curves, from Brainpool and BADA55.
238 * hashsum: Fix hash file verification.
239
240 -- Mark Wooding <mdw@distorted.org.uk> Wed, 16 Jul 2014 10:21:23 +0100
241
242 catacomb (2.1.6.1) experimental; urgency=low
243
244 * Fix building from source tarball.
245 * Fix building with Python 2.5.
246
247 -- Mark Wooding <mdw@distorted.org.uk> Sat, 28 Dec 2013 14:21:36 +0000
248
249 catacomb (2.1.6) experimental; urgency=low
250
251 * mpreduce: Extend domain to all positive integers.
252 * gfreduce: Fix out-of-bounds memory access.
253 * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
254 * pixie: Don't replace existing pixie unless explicitly requested.
255
256 -- Mark Wooding <mdw@distorted.org.uk> Fri, 27 Dec 2013 14:28:57 +0000
257
258 catacomb (2.1.5) experimental; urgency=low
259
260 * New build system.
261
262 -- Mark Wooding <mdw@distorted.org.uk> Mon, 29 Jun 2013 00:38:58 +0100
263
264 catacomb (2.1.4) experimental; urgency=low
265
266 * Constant-time operations.
267 * Some minor fixes to header files.
268
269 -- Mark Wooding <mdw@distorted.org.uk> Mon, 27 May 2013 22:34:23 +0100
270
271 catacomb (2.1.3) experimental; urgency=low
272
273 * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
274 example program.
275 * Upper bounds on phrase entropy in mkphrase(1).
276 * Don't make the Pixie setuid-root by default. Make the documentation
277 less scary.
278
279 -- Mark Wooding <mdw@distorted.org.uk> Thu, 11 Apr 2013 12:06:28 +0100
280
281 catacomb (2.1.2.1) experimental; urgency=low
282
283 * hashsum: Document `--progress' option in `--help' output.
284
285 -- Mark Wooding <mdw@distorted.org.uk> Thu, 28 Feb 2013 17:35:49 +0000
286
287 catacomb (2.1.2) experimental; urgency=low
288
289 * hashsum: Correct return code when running in `-c' mode.
290 * dsig: Fix core dump on large-ish outputs.
291 * dsig: Fix repeat-close bug.
292 * dsig: Accept precomputed hashes when making signatures.
293 * Utilities: New `-p' option for progress bars.
294 * dsig, hashsum: New `-j' option checks for files not covered by
295 manifest.
296 * Various library improvements.
297
298 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 03:26:44 +0000
299
300 catacomb (2.1.1) experimental; urgency=low
301
302 * Do configuration through pkgconfig.
303
304 -- Mark Wooding <mdw@distorted.org.uk> Mon, 17 Mar 2008 18:36:30 +0000
305
306 catacomb (2.1.0) experimental; urgency=low
307
308 * Added support for elliptic curves, on both prime and binary fields
309 (polynomial basis only). No actual crypto, but there's enough already
310 to do ECDH and stuff on well-known curves Testing is currently a bit
311 patchy.
312
313 -- Mark Wooding <mdw@nsict.org> Sun, 21 Mar 2004 22:47:56 +0000
314
315 catacomb (2.0.1) experimental; urgency=low
316
317 * Debianization!
318 * (pixie): Don't report uninteresting errors when accepting connections.
319
320 -- Mark Wooding <mdw@nsict.org> Thu, 11 Dec 2003 10:47:59 +0000