Merge branch '2.5.x'
[catacomb] / debian / changelog
1 catacomb (2.5.99~) experimental; urgency=medium
2
3 * (placeholder for next minor release)
4
5 -- Mark Wooding <mdw@distorted.org.uk> Mon, 30 Sep 2019 02:15:20 +0100
6
7 catacomb (2.5.1) experimental; urgency=medium
8
9 * Merge changes from 2.4.4.
10
11 -- Mark Wooding <mdw@distorted.org.uk> Sun, 29 Sep 2019 17:50:59 +0100
12
13 catacomb (2.5.0) experimental; urgency=medium
14
15 * catacomb: MACs based on blockciphers: PMAC1 and CMAC (also known as
16 OMAC).
17 * catacomb: Authenticated Encryption with Additional Data (AEAD)
18 schemes. Some based on blockciphers: CCM, EAX, GCM (with CPU-specific
19 acceleration), OCB1 and OCB3 (OCB2 is broken). Also Salsa20 and
20 ChaCha20 with Poly1305: the RFC7539 scheme, and the NaCl `secret_box'
21 transform.
22 * catacomb: Implement Grantham's Frobenius test. Combine it with
23 Rabin--Miller, as Baillie--PSW, for testing given primes.
24 * catacomb-bin (catcrypt): Support AEAD schemes for bulk crypto.
25 * catacomb-bin (perftest): Options for batching; report cycle counts
26 where available.
27 * Many internal improvements: better documentation, debugging, testing,
28 etc.
29
30 -- Mark Wooding <mdw@distorted.org.uk> Sat, 21 Sep 2019 21:26:44 +0100
31
32 catacomb (2.4.4) experimental; urgency=medium
33
34 * debian: Bump to Debhelper 10.
35 * debian: Ship a shared-library `symbols' file for more precise
36 dependencies.
37
38 -- Mark Wooding <mdw@distorted.org.uk> Sun, 29 Sep 2019 15:58:26 +0100
39
40 catacomb (2.4.3) experimental; urgency=medium
41
42 * catacomb (idea): Fix key-length descriptor.
43 * catacomb (xchachaNN): Fix nonce-size descriptor.
44 * catacomb (key-management): Fix incorrect handling of keyring
45 modifiability.
46 * catacomb-dev: Configure `pkg-config' correctly for static linking.
47 * catacomb, catacomb-bin (cookie, dsig): Fix hash-function length
48 padding on very long messages, and handling of large datestamps.
49 * catacomb-bin (catsign): Don't open temporary files unnecessarily.
50 * catacomb-bin (catcrypt): Fix key-attribute parsing.
51 * catacomb-bin (perftest): Add missing help-string text for `-n' used
52 with `enc' and `hash'
53
54 -- Mark Wooding <mdw@distorted.org.uk> Sat, 21 Sep 2019 17:43:59 +0100
55
56 catacomb (2.4.2) experimental; urgency=medium
57
58 * catacomb2: Support multi-arch at last.
59 * catacomb2: Fix mangled key-size data for HMAC.
60 * rspit: Support generating large files.
61 * pixie: Improve error-handling around dropping privilege.
62 * ed25519, ed448: Very minor performance improvement.
63 * salsa20, chacha: Fix crash if nonce is none, as it is when invoked by
64 `rspit'.
65 * salsa20, chacha: Fix declaration of cipher classes to prevent them
66 ending up as (useless) common symbols in client code.
67 * limlee: Improve the prime size heuristics.
68 * sha, sha256, sha512: Restructure compression function to improve
69 performance and use less memory.
70 * rijndael: Include enough round constants to make very tiny keys work
71 correctly.
72
73 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jun 2018 01:15:59 +0100
74
75 catacomb (2.4.1) experimental; urgency=low
76
77 * catacomb2: Two's-complement fix from 2.3.x release branch.
78
79 -- Mark Wooding <mdw@distorted.org.uk> Thu, 22 Jun 2017 09:37:40 +0100
80
81 catacomb (2.4.0.1) experimental; urgency=low
82
83 * Fix build failure with later ARM assemblers.
84
85 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 21:05:35 +0100
86
87 catacomb (2.4.0) experimental; urgency=low
88
89 * catacomb2: Implemented Bernstein's Poly1305 message-authentication
90 code.
91 * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
92 and Salsa20.
93 * catacomb2: Implement Bernstein's X25519.
94 * catacomb2: Implement Hamburg's X448 (RFC7748).
95 * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
96 as defined in RFC8032.
97 * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
98 RFC8032.
99 * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
100 * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
101 * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
102 * catacomb2: Allow RSA key generation with chosen public exponent.
103 * catacomb2: Optimize RSA public-key operations with common public
104 exponents.
105 * catacomb-bin: Support new algorithms in the provided tools.
106 * catacomb-bin: Allow parameters keys for all key types.
107
108 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 16:07:00 +0100
109
110 catacomb (2.3.2) experimental; urgency=low
111
112 * catacomb2: Fix bignum loading and storing in two's complement form.
113
114 -- Mark Wooding <mdw@distorted.org.uk> Thu, 22 Jun 2017 09:34:59 +0100
115
116 catacomb (2.3.1) experimental; urgency=low
117
118 * catacomb2: Fix memory corruption when allocating `salsa20' and
119 `chacha'-based RNGs.
120 * catacomb2: Fix segfault when opening read-only keyring with no
121 associated file.
122 * catacomb2: Return the correct stream offset in `chacha_tell*'.
123 * catacomb2: Produce correct keyring files when they contain empty
124 keys.
125 * catacomb2: Fix cross-compilation-unit type incompatibility in prime
126 and binary group implementations.
127 * catacomb-dev: Add missing licence notices to `salsa20.h'.
128 * catacomb-bin: Fix assertion failure in RSA-PSS signing.
129 * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
130 verifying.
131 * catacomb-bin: Compare MAC tags in constant time.
132 * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
133
134 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 04:05:00 +0100
135
136 catacomb (2.3.0.1) experimental; urgency=low
137
138 * catacomb2: Actually make the stack non-executable rather than just
139 pretending.
140
141 -- Mark Wooding <mdw@distorted.org.uk> Wed, 05 Apr 2017 09:00:55 +0100
142
143 catacomb (2.3.0) experimental; urgency=low
144
145 * catacomb2: Use the correct Oakley 2048 group. For a long time, this
146 was a duplicate of the Oakley 1536 group. There's a compatibility
147 break here, but it's for the best.
148 * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
149 so that the process stack doesn't get marked executable.
150 * catacomb2: New SSE2-based multipliers for i386 and AMD64.
151 * catacomb2: Lots of other improvements to the assembler code.
152
153 -- Mark Wooding <mdw@distorted.org.uk> Mon, 03 Apr 2017 10:24:17 +0100
154
155 catacomb (2.2.5) experimental; urgency=low
156
157 * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
158 is unaligned.
159 * build: Use less obsolete macro names in configure script.
160
161 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jul 2016 10:27:05 +0100
162
163 catacomb (2.2.4) experimental; urgency=low
164
165 * build: Fix build failures on post-wheezy Debian versions.
166 * catacomb2: Use ARM AES instructions if available. (But they can't be
167 assembled using wheezy's version of gas, so this doesn't work in the
168 binary package.)
169 * catacomb2: Fix poor performance (and wrong answers for very small
170 numbers) in prime generation.
171 * catacomb2: Return numbers of exactly the requested length in prime and
172 public-key generation. The `strongprime' and `limlee' algorithms have
173 changed as a result; previously verifiable parameters generated using
174 this algorithm won't be verifiable any more.
175 * catacomb-dev: Deprecate the old `dsa' functions. Use `gdsa' instead.
176
177 -- Mark Wooding <mdw@distorted.org.uk> Sun, 26 Jun 2016 14:18:14 +0100
178
179 catacomb (2.2.3) experimental; urgency=low
180
181 * rand: Make the main generator resiliant in the face of fork(2).
182 * rand: Introduce `rand_quick', which may also mix in CPU-level
183 randomness sources.
184 * rand: Use higher-resolution timer in the quick-win noise source.
185 * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
186 which got lost down the side of the sofas.
187
188 -- Mark Wooding <mdw@distorted.org.uk> Mon, 13 Jun 2016 22:22:33 +0100
189
190 catacomb (2.2.2) experimental; urgency=low
191
192 * build: Cope with newer Autotools and related equipment.
193 * Miscellaneous small fixes for Cygwin.
194 * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
195 particularly, this causes a segfault reading bit zero of a zero-length
196 integer.
197
198 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:12:01 +0100
199
200 catacomb (2.2.1.1) experimental; urgency=low
201
202 * Arrange that catacomb-dev Depends on correct version of mlib-dev. It
203 really won't work well without it.
204
205 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 09:04:50 +0000
206
207 catacomb (2.2.1) experimental; urgency=low
208
209 * Some internal improvements.
210 * Debian packaging cleanups (fix build-depends, update mLib dependency).
211
212 -- Mark Wooding <mdw@distorted.org.uk> Thu, 18 Feb 2016 16:43:09 +0000
213
214 catacomb (2.2.0) experimental; urgency=low
215
216 * catacomb2: Fix rsa_recover crash on even modulus.
217 * catacomb-bin: Report error taking factorial of negative input.
218 * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
219 * catacomb-dev: Support multiple flavours of EC point compression.
220 * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
221 out of prime numbers.
222 * catacomb2: Overhaul crypto primitives used in true-random generator.
223 * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
224 support.
225 * catacomb-dev: New conversions between MP integers and C integer types.
226 * catacomb2: Change gcipher for Seal incompatibly. The IV is now
227 big-endian bytes (rather than `uint32'), and the `block size' is 4.
228 * catacomb2: Mix a constant string into DSA nonce generation to improve
229 resistance to protocol interference.
230 * catacomb2: Fix the freewheel random source, which hasn't been enabled
231 for ages due to a configure-script bug.
232 * catacomb-bin: The key tool can now read and write multiple
233 presentations for key fingerprints.
234 * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
235 stream ciphers.
236
237 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 14:15:31 +0100
238
239 catacomb (2.1.7) experimental; urgency=low
240
241 * A number of entropy-source fixes.
242 * Internal tidying.
243 * Add more elliptic curves, from Brainpool and BADA55.
244 * hashsum: Fix hash file verification.
245
246 -- Mark Wooding <mdw@distorted.org.uk> Wed, 16 Jul 2014 10:21:23 +0100
247
248 catacomb (2.1.6.1) experimental; urgency=low
249
250 * Fix building from source tarball.
251 * Fix building with Python 2.5.
252
253 -- Mark Wooding <mdw@distorted.org.uk> Sat, 28 Dec 2013 14:21:36 +0000
254
255 catacomb (2.1.6) experimental; urgency=low
256
257 * mpreduce: Extend domain to all positive integers.
258 * gfreduce: Fix out-of-bounds memory access.
259 * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
260 * pixie: Don't replace existing pixie unless explicitly requested.
261
262 -- Mark Wooding <mdw@distorted.org.uk> Fri, 27 Dec 2013 14:28:57 +0000
263
264 catacomb (2.1.5) experimental; urgency=low
265
266 * New build system.
267
268 -- Mark Wooding <mdw@distorted.org.uk> Mon, 29 Jun 2013 00:38:58 +0100
269
270 catacomb (2.1.4) experimental; urgency=low
271
272 * Constant-time operations.
273 * Some minor fixes to header files.
274
275 -- Mark Wooding <mdw@distorted.org.uk> Mon, 27 May 2013 22:34:23 +0100
276
277 catacomb (2.1.3) experimental; urgency=low
278
279 * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
280 example program.
281 * Upper bounds on phrase entropy in mkphrase(1).
282 * Don't make the Pixie setuid-root by default. Make the documentation
283 less scary.
284
285 -- Mark Wooding <mdw@distorted.org.uk> Thu, 11 Apr 2013 12:06:28 +0100
286
287 catacomb (2.1.2.1) experimental; urgency=low
288
289 * hashsum: Document `--progress' option in `--help' output.
290
291 -- Mark Wooding <mdw@distorted.org.uk> Thu, 28 Feb 2013 17:35:49 +0000
292
293 catacomb (2.1.2) experimental; urgency=low
294
295 * hashsum: Correct return code when running in `-c' mode.
296 * dsig: Fix core dump on large-ish outputs.
297 * dsig: Fix repeat-close bug.
298 * dsig: Accept precomputed hashes when making signatures.
299 * Utilities: New `-p' option for progress bars.
300 * dsig, hashsum: New `-j' option checks for files not covered by
301 manifest.
302 * Various library improvements.
303
304 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 03:26:44 +0000
305
306 catacomb (2.1.1) experimental; urgency=low
307
308 * Do configuration through pkgconfig.
309
310 -- Mark Wooding <mdw@distorted.org.uk> Mon, 17 Mar 2008 18:36:30 +0000
311
312 catacomb (2.1.0) experimental; urgency=low
313
314 * Added support for elliptic curves, on both prime and binary fields
315 (polynomial basis only). No actual crypto, but there's enough already
316 to do ECDH and stuff on well-known curves Testing is currently a bit
317 patchy.
318
319 -- Mark Wooding <mdw@nsict.org> Sun, 21 Mar 2004 22:47:56 +0000
320
321 catacomb (2.0.1) experimental; urgency=low
322
323 * Debianization!
324 * (pixie): Don't report uninteresting errors when accepting connections.
325
326 -- Mark Wooding <mdw@nsict.org> Thu, 11 Dec 2003 10:47:59 +0000