Merge branch '2.4.x'
[catacomb] / debian / changelog
1 catacomb (2.4.3) experimental; urgency=medium
2
3 * catacomb (idea): Fix key-length descriptor.
4 * catacomb (xchachaNN): Fix nonce-size descriptor.
5 * catacomb (key-management): Fix incorrect handling of keyring
6 modifiability.
7 * catacomb-dev: Configure `pkg-config' correctly for static linking.
8 * catacomb, catacomb-bin (cookie, dsig): Fix hash-function length
9 padding on very long messages, and handling of large datestamps.
10 * catacomb-bin (catsign): Don't open temporary files unnecessarily.
11 * catacomb-bin (catcrypt): Fix key-attribute parsing.
12 * catacomb-bin (perftest): Add missing help-string text for `-n' used
13 with `enc' and `hash'
14
15 -- Mark Wooding <mdw@distorted.org.uk> Sat, 21 Sep 2019 17:43:59 +0100
16
17 catacomb (2.4.2) experimental; urgency=medium
18
19 * catacomb2: Support multi-arch at last.
20 * catacomb2: Fix mangled key-size data for HMAC.
21 * rspit: Support generating large files.
22 * pixie: Improve error-handling around dropping privilege.
23 * ed25519, ed448: Very minor performance improvement.
24 * salsa20, chacha: Fix crash if nonce is none, as it is when invoked by
25 `rspit'.
26 * salsa20, chacha: Fix declaration of cipher classes to prevent them
27 ending up as (useless) common symbols in client code.
28 * limlee: Improve the prime size heuristics.
29 * sha, sha256, sha512: Restructure compression function to improve
30 performance and use less memory.
31 * rijndael: Include enough round constants to make very tiny keys work
32 correctly.
33
34 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jun 2018 01:15:59 +0100
35
36 catacomb (2.4.1) experimental; urgency=low
37
38 * catacomb2: Two's-complement fix from 2.3.x release branch.
39
40 -- Mark Wooding <mdw@distorted.org.uk> Thu, 22 Jun 2017 09:37:40 +0100
41
42 catacomb (2.4.0.1) experimental; urgency=low
43
44 * Fix build failure with later ARM assemblers.
45
46 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 21:05:35 +0100
47
48 catacomb (2.4.0) experimental; urgency=low
49
50 * catacomb2: Implemented Bernstein's Poly1305 message-authentication
51 code.
52 * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
53 and Salsa20.
54 * catacomb2: Implement Bernstein's X25519.
55 * catacomb2: Implement Hamburg's X448 (RFC7748).
56 * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
57 as defined in RFC8032.
58 * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
59 RFC8032.
60 * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
61 * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
62 * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
63 * catacomb2: Allow RSA key generation with chosen public exponent.
64 * catacomb2: Optimize RSA public-key operations with common public
65 exponents.
66 * catacomb-bin: Support new algorithms in the provided tools.
67 * catacomb-bin: Allow parameters keys for all key types.
68
69 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 16:07:00 +0100
70
71 catacomb (2.3.2) experimental; urgency=low
72
73 * catacomb2: Fix bignum loading and storing in two's complement form.
74
75 -- Mark Wooding <mdw@distorted.org.uk> Thu, 22 Jun 2017 09:34:59 +0100
76
77 catacomb (2.3.1) experimental; urgency=low
78
79 * catacomb2: Fix memory corruption when allocating `salsa20' and
80 `chacha'-based RNGs.
81 * catacomb2: Fix segfault when opening read-only keyring with no
82 associated file.
83 * catacomb2: Return the correct stream offset in `chacha_tell*'.
84 * catacomb2: Produce correct keyring files when they contain empty
85 keys.
86 * catacomb2: Fix cross-compilation-unit type incompatibility in prime
87 and binary group implementations.
88 * catacomb-dev: Add missing licence notices to `salsa20.h'.
89 * catacomb-bin: Fix assertion failure in RSA-PSS signing.
90 * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
91 verifying.
92 * catacomb-bin: Compare MAC tags in constant time.
93 * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
94
95 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 04:05:00 +0100
96
97 catacomb (2.3.0.1) experimental; urgency=low
98
99 * catacomb2: Actually make the stack non-executable rather than just
100 pretending.
101
102 -- Mark Wooding <mdw@distorted.org.uk> Wed, 05 Apr 2017 09:00:55 +0100
103
104 catacomb (2.3.0) experimental; urgency=low
105
106 * catacomb2: Use the correct Oakley 2048 group. For a long time, this
107 was a duplicate of the Oakley 1536 group. There's a compatibility
108 break here, but it's for the best.
109 * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
110 so that the process stack doesn't get marked executable.
111 * catacomb2: New SSE2-based multipliers for i386 and AMD64.
112 * catacomb2: Lots of other improvements to the assembler code.
113
114 -- Mark Wooding <mdw@distorted.org.uk> Mon, 03 Apr 2017 10:24:17 +0100
115
116 catacomb (2.2.5) experimental; urgency=low
117
118 * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
119 is unaligned.
120 * build: Use less obsolete macro names in configure script.
121
122 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jul 2016 10:27:05 +0100
123
124 catacomb (2.2.4) experimental; urgency=low
125
126 * build: Fix build failures on post-wheezy Debian versions.
127 * catacomb2: Use ARM AES instructions if available. (But they can't be
128 assembled using wheezy's version of gas, so this doesn't work in the
129 binary package.)
130 * catacomb2: Fix poor performance (and wrong answers for very small
131 numbers) in prime generation.
132 * catacomb2: Return numbers of exactly the requested length in prime and
133 public-key generation. The `strongprime' and `limlee' algorithms have
134 changed as a result; previously verifiable parameters generated using
135 this algorithm won't be verifiable any more.
136 * catacomb-dev: Deprecate the old `dsa' functions. Use `gdsa' instead.
137
138 -- Mark Wooding <mdw@distorted.org.uk> Sun, 26 Jun 2016 14:18:14 +0100
139
140 catacomb (2.2.3) experimental; urgency=low
141
142 * rand: Make the main generator resiliant in the face of fork(2).
143 * rand: Introduce `rand_quick', which may also mix in CPU-level
144 randomness sources.
145 * rand: Use higher-resolution timer in the quick-win noise source.
146 * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
147 which got lost down the side of the sofas.
148
149 -- Mark Wooding <mdw@distorted.org.uk> Mon, 13 Jun 2016 22:22:33 +0100
150
151 catacomb (2.2.2) experimental; urgency=low
152
153 * build: Cope with newer Autotools and related equipment.
154 * Miscellaneous small fixes for Cygwin.
155 * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
156 particularly, this causes a segfault reading bit zero of a zero-length
157 integer.
158
159 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:12:01 +0100
160
161 catacomb (2.2.1.1) experimental; urgency=low
162
163 * Arrange that catacomb-dev Depends on correct version of mlib-dev. It
164 really won't work well without it.
165
166 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 09:04:50 +0000
167
168 catacomb (2.2.1) experimental; urgency=low
169
170 * Some internal improvements.
171 * Debian packaging cleanups (fix build-depends, update mLib dependency).
172
173 -- Mark Wooding <mdw@distorted.org.uk> Thu, 18 Feb 2016 16:43:09 +0000
174
175 catacomb (2.2.0) experimental; urgency=low
176
177 * catacomb2: Fix rsa_recover crash on even modulus.
178 * catacomb-bin: Report error taking factorial of negative input.
179 * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
180 * catacomb-dev: Support multiple flavours of EC point compression.
181 * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
182 out of prime numbers.
183 * catacomb2: Overhaul crypto primitives used in true-random generator.
184 * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
185 support.
186 * catacomb-dev: New conversions between MP integers and C integer types.
187 * catacomb2: Change gcipher for Seal incompatibly. The IV is now
188 big-endian bytes (rather than `uint32'), and the `block size' is 4.
189 * catacomb2: Mix a constant string into DSA nonce generation to improve
190 resistance to protocol interference.
191 * catacomb2: Fix the freewheel random source, which hasn't been enabled
192 for ages due to a configure-script bug.
193 * catacomb-bin: The key tool can now read and write multiple
194 presentations for key fingerprints.
195 * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
196 stream ciphers.
197
198 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 14:15:31 +0100
199
200 catacomb (2.1.7) experimental; urgency=low
201
202 * A number of entropy-source fixes.
203 * Internal tidying.
204 * Add more elliptic curves, from Brainpool and BADA55.
205 * hashsum: Fix hash file verification.
206
207 -- Mark Wooding <mdw@distorted.org.uk> Wed, 16 Jul 2014 10:21:23 +0100
208
209 catacomb (2.1.6.1) experimental; urgency=low
210
211 * Fix building from source tarball.
212 * Fix building with Python 2.5.
213
214 -- Mark Wooding <mdw@distorted.org.uk> Sat, 28 Dec 2013 14:21:36 +0000
215
216 catacomb (2.1.6) experimental; urgency=low
217
218 * mpreduce: Extend domain to all positive integers.
219 * gfreduce: Fix out-of-bounds memory access.
220 * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
221 * pixie: Don't replace existing pixie unless explicitly requested.
222
223 -- Mark Wooding <mdw@distorted.org.uk> Fri, 27 Dec 2013 14:28:57 +0000
224
225 catacomb (2.1.5) experimental; urgency=low
226
227 * New build system.
228
229 -- Mark Wooding <mdw@distorted.org.uk> Mon, 29 Jun 2013 00:38:58 +0100
230
231 catacomb (2.1.4) experimental; urgency=low
232
233 * Constant-time operations.
234 * Some minor fixes to header files.
235
236 -- Mark Wooding <mdw@distorted.org.uk> Mon, 27 May 2013 22:34:23 +0100
237
238 catacomb (2.1.3) experimental; urgency=low
239
240 * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
241 example program.
242 * Upper bounds on phrase entropy in mkphrase(1).
243 * Don't make the Pixie setuid-root by default. Make the documentation
244 less scary.
245
246 -- Mark Wooding <mdw@distorted.org.uk> Thu, 11 Apr 2013 12:06:28 +0100
247
248 catacomb (2.1.2.1) experimental; urgency=low
249
250 * hashsum: Document `--progress' option in `--help' output.
251
252 -- Mark Wooding <mdw@distorted.org.uk> Thu, 28 Feb 2013 17:35:49 +0000
253
254 catacomb (2.1.2) experimental; urgency=low
255
256 * hashsum: Correct return code when running in `-c' mode.
257 * dsig: Fix core dump on large-ish outputs.
258 * dsig: Fix repeat-close bug.
259 * dsig: Accept precomputed hashes when making signatures.
260 * Utilities: New `-p' option for progress bars.
261 * dsig, hashsum: New `-j' option checks for files not covered by
262 manifest.
263 * Various library improvements.
264
265 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 03:26:44 +0000
266
267 catacomb (2.1.1) experimental; urgency=low
268
269 * Do configuration through pkgconfig.
270
271 -- Mark Wooding <mdw@distorted.org.uk> Mon, 17 Mar 2008 18:36:30 +0000
272
273 catacomb (2.1.0) experimental; urgency=low
274
275 * Added support for elliptic curves, on both prime and binary fields
276 (polynomial basis only). No actual crypto, but there's enough already
277 to do ECDH and stuff on well-known curves Testing is currently a bit
278 patchy.
279
280 -- Mark Wooding <mdw@nsict.org> Sun, 21 Mar 2004 22:47:56 +0000
281
282 catacomb (2.0.1) experimental; urgency=low
283
284 * Debianization!
285 * (pixie): Don't report uninteresting errors when accepting connections.
286
287 -- Mark Wooding <mdw@nsict.org> Thu, 11 Dec 2003 10:47:59 +0000