Release 2.2.5.
[catacomb] / debian / changelog
1 catacomb (2.2.5) experimental; urgency=low
2
3 * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
4 is unaligned.
5 * build: Use less obsolete macro names in configure script.
6
7 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jul 2016 10:27:05 +0100
8
9 catacomb (2.2.4) experimental; urgency=low
10
11 * build: Fix build failures on post-wheezy Debian versions.
12 * catacomb2: Use ARM AES instructions if available. (But they can't be
13 assembled using wheezy's version of gas, so this doesn't work in the
14 binary package.)
15 * catacomb2: Fix poor performance (and wrong answers for very small
16 numbers) in prime generation.
17 * catacomb2: Return numbers of exactly the requested length in prime and
18 public-key generation. The `strongprime' and `limlee' algorithms have
19 changed as a result; previously verifiable parameters generated using
20 this algorithm won't be verifiable any more.
21 * catacomb-dev: Deprecate the old `dsa' functions. Use `gdsa' instead.
22
23 -- Mark Wooding <mdw@distorted.org.uk> Sun, 26 Jun 2016 14:18:14 +0100
24
25 catacomb (2.2.3) experimental; urgency=low
26
27 * rand: Make the main generator resiliant in the face of fork(2).
28 * rand: Introduce `rand_quick', which may also mix in CPU-level
29 randomness sources.
30 * rand: Use higher-resolution timer in the quick-win noise source.
31 * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
32 which got lost down the side of the sofas.
33
34 -- Mark Wooding <mdw@distorted.org.uk> Mon, 13 Jun 2016 22:22:33 +0100
35
36 catacomb (2.2.2) experimental; urgency=low
37
38 * build: Cope with newer Autotools and related equipment.
39 * Miscellaneous small fixes for Cygwin.
40 * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
41 particularly, this causes a segfault reading bit zero of a zero-length
42 integer.
43
44 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:12:01 +0100
45
46 catacomb (2.2.1.1) experimental; urgency=low
47
48 * Arrange that catacomb-dev Depends on correct version of mlib-dev. It
49 really won't work well without it.
50
51 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 09:04:50 +0000
52
53 catacomb (2.2.1) experimental; urgency=low
54
55 * Some internal improvements.
56 * Debian packaging cleanups (fix build-depends, update mLib dependency).
57
58 -- Mark Wooding <mdw@distorted.org.uk> Thu, 18 Feb 2016 16:43:09 +0000
59
60 catacomb (2.2.0) experimental; urgency=low
61
62 * catacomb2: Fix rsa_recover crash on even modulus.
63 * catacomb-bin: Report error taking factorial of negative input.
64 * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
65 * catacomb-dev: Support multiple flavours of EC point compression.
66 * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
67 out of prime numbers.
68 * catacomb2: Overhaul crypto primitives used in true-random generator.
69 * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
70 support.
71 * catacomb-dev: New conversions between MP integers and C integer types.
72 * catacomb2: Change gcipher for Seal incompatibly. The IV is now
73 big-endian bytes (rather than `uint32'), and the `block size' is 4.
74 * catacomb2: Mix a constant string into DSA nonce generation to improve
75 resistance to protocol interference.
76 * catacomb2: Fix the freewheel random source, which hasn't been enabled
77 for ages due to a configure-script bug.
78 * catacomb-bin: The key tool can now read and write multiple
79 presentations for key fingerprints.
80 * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
81 stream ciphers.
82
83 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 14:15:31 +0100
84
85 catacomb (2.1.7) experimental; urgency=low
86
87 * A number of entropy-source fixes.
88 * Internal tidying.
89 * Add more elliptic curves, from Brainpool and BADA55.
90 * hashsum: Fix hash file verification.
91
92 -- Mark Wooding <mdw@distorted.org.uk> Wed, 16 Jul 2014 10:21:23 +0100
93
94 catacomb (2.1.6.1) experimental; urgency=low
95
96 * Fix building from source tarball.
97 * Fix building with Python 2.5.
98
99 -- Mark Wooding <mdw@distorted.org.uk> Sat, 28 Dec 2013 14:21:36 +0000
100
101 catacomb (2.1.6) experimental; urgency=low
102
103 * mpreduce: Extend domain to all positive integers.
104 * gfreduce: Fix out-of-bounds memory access.
105 * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
106 * pixie: Don't replace existing pixie unless explicitly requested.
107
108 -- Mark Wooding <mdw@distorted.org.uk> Fri, 27 Dec 2013 14:28:57 +0000
109
110 catacomb (2.1.5) experimental; urgency=low
111
112 * New build system.
113
114 -- Mark Wooding <mdw@distorted.org.uk> Mon, 29 Jun 2013 00:38:58 +0100
115
116 catacomb (2.1.4) experimental; urgency=low
117
118 * Constant-time operations.
119 * Some minor fixes to header files.
120
121 -- Mark Wooding <mdw@distorted.org.uk> Mon, 27 May 2013 22:34:23 +0100
122
123 catacomb (2.1.3) experimental; urgency=low
124
125 * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
126 example program.
127 * Upper bounds on phrase entropy in mkphrase(1).
128 * Don't make the Pixie setuid-root by default. Make the documentation
129 less scary.
130
131 -- Mark Wooding <mdw@distorted.org.uk> Thu, 11 Apr 2013 12:06:28 +0100
132
133 catacomb (2.1.2.1) experimental; urgency=low
134
135 * hashsum: Document `--progress' option in `--help' output.
136
137 -- Mark Wooding <mdw@distorted.org.uk> Thu, 28 Feb 2013 17:35:49 +0000
138
139 catacomb (2.1.2) experimental; urgency=low
140
141 * hashsum: Correct return code when running in `-c' mode.
142 * dsig: Fix core dump on large-ish outputs.
143 * dsig: Fix repeat-close bug.
144 * dsig: Accept precomputed hashes when making signatures.
145 * Utilities: New `-p' option for progress bars.
146 * dsig, hashsum: New `-j' option checks for files not covered by
147 manifest.
148 * Various library improvements.
149
150 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 03:26:44 +0000
151
152 catacomb (2.1.1) experimental; urgency=low
153
154 * Do configuration through pkgconfig.
155
156 -- Mark Wooding <mdw@distorted.org.uk> Mon, 17 Mar 2008 18:36:30 +0000
157
158 catacomb (2.1.0) experimental; urgency=low
159
160 * Added support for elliptic curves, on both prime and binary fields
161 (polynomial basis only). No actual crypto, but there's enough already
162 to do ECDH and stuff on well-known curves Testing is currently a bit
163 patchy.
164
165 -- Mark Wooding <mdw@nsict.org> Sun, 21 Mar 2004 22:47:56 +0000
166
167 catacomb (2.0.1) experimental; urgency=low
168
169 * Debianization!
170 * (pixie): Don't report uninteresting errors when accepting connections.
171
172 -- Mark Wooding <mdw@nsict.org> Thu, 11 Dec 2003 10:47:59 +0000