Merge branch '2.3.x'
[catacomb] / debian / changelog
1 catacomb (2.3.1) experimental; urgency=low
2
3 * catacomb2: Fix memory corruption when allocating `salsa20' and
4 `chacha'-based RNGs.
5 * catacomb2: Fix segfault when opening read-only keyring with no
6 associated file.
7 * catacomb2: Return the correct stream offset in `chacha_tell*'.
8 * catacomb2: Produce correct keyring files when they contain empty
9 keys.
10 * catacomb2: Fix cross-compilation-unit type incompatibility in prime
11 and binary group implementations.
12 * catacomb-dev: Add missing licence notices to `salsa20.h'.
13 * catacomb-bin: Fix assertion failure in RSA-PSS signing.
14 * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
15 verifying.
16 * catacomb-bin: Compare MAC tags in constant time.
17 * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
18
19 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 04:05:00 +0100
20
21 catacomb (2.3.0.1) experimental; urgency=low
22
23 * catacomb2: Actually make the stack non-executable rather than just
24 pretending.
25
26 -- Mark Wooding <mdw@distorted.org.uk> Wed, 05 Apr 2017 09:00:55 +0100
27
28 catacomb (2.3.0) experimental; urgency=low
29
30 * catacomb2: Use the correct Oakley 2048 group. For a long time, this
31 was a duplicate of the Oakley 1536 group. There's a compatibility
32 break here, but it's for the best.
33 * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
34 so that the process stack doesn't get marked executable.
35 * catacomb2: New SSE2-based multipliers for i386 and AMD64.
36 * catacomb2: Lots of other improvements to the assembler code.
37
38 -- Mark Wooding <mdw@distorted.org.uk> Mon, 03 Apr 2017 10:24:17 +0100
39
40 catacomb (2.2.5) experimental; urgency=low
41
42 * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
43 is unaligned.
44 * build: Use less obsolete macro names in configure script.
45
46 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jul 2016 10:27:05 +0100
47
48 catacomb (2.2.4) experimental; urgency=low
49
50 * build: Fix build failures on post-wheezy Debian versions.
51 * catacomb2: Use ARM AES instructions if available. (But they can't be
52 assembled using wheezy's version of gas, so this doesn't work in the
53 binary package.)
54 * catacomb2: Fix poor performance (and wrong answers for very small
55 numbers) in prime generation.
56 * catacomb2: Return numbers of exactly the requested length in prime and
57 public-key generation. The `strongprime' and `limlee' algorithms have
58 changed as a result; previously verifiable parameters generated using
59 this algorithm won't be verifiable any more.
60 * catacomb-dev: Deprecate the old `dsa' functions. Use `gdsa' instead.
61
62 -- Mark Wooding <mdw@distorted.org.uk> Sun, 26 Jun 2016 14:18:14 +0100
63
64 catacomb (2.2.3) experimental; urgency=low
65
66 * rand: Make the main generator resiliant in the face of fork(2).
67 * rand: Introduce `rand_quick', which may also mix in CPU-level
68 randomness sources.
69 * rand: Use higher-resolution timer in the quick-win noise source.
70 * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
71 which got lost down the side of the sofas.
72
73 -- Mark Wooding <mdw@distorted.org.uk> Mon, 13 Jun 2016 22:22:33 +0100
74
75 catacomb (2.2.2) experimental; urgency=low
76
77 * build: Cope with newer Autotools and related equipment.
78 * Miscellaneous small fixes for Cygwin.
79 * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
80 particularly, this causes a segfault reading bit zero of a zero-length
81 integer.
82
83 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:12:01 +0100
84
85 catacomb (2.2.1.1) experimental; urgency=low
86
87 * Arrange that catacomb-dev Depends on correct version of mlib-dev. It
88 really won't work well without it.
89
90 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 09:04:50 +0000
91
92 catacomb (2.2.1) experimental; urgency=low
93
94 * Some internal improvements.
95 * Debian packaging cleanups (fix build-depends, update mLib dependency).
96
97 -- Mark Wooding <mdw@distorted.org.uk> Thu, 18 Feb 2016 16:43:09 +0000
98
99 catacomb (2.2.0) experimental; urgency=low
100
101 * catacomb2: Fix rsa_recover crash on even modulus.
102 * catacomb-bin: Report error taking factorial of negative input.
103 * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
104 * catacomb-dev: Support multiple flavours of EC point compression.
105 * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
106 out of prime numbers.
107 * catacomb2: Overhaul crypto primitives used in true-random generator.
108 * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
109 support.
110 * catacomb-dev: New conversions between MP integers and C integer types.
111 * catacomb2: Change gcipher for Seal incompatibly. The IV is now
112 big-endian bytes (rather than `uint32'), and the `block size' is 4.
113 * catacomb2: Mix a constant string into DSA nonce generation to improve
114 resistance to protocol interference.
115 * catacomb2: Fix the freewheel random source, which hasn't been enabled
116 for ages due to a configure-script bug.
117 * catacomb-bin: The key tool can now read and write multiple
118 presentations for key fingerprints.
119 * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
120 stream ciphers.
121
122 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 14:15:31 +0100
123
124 catacomb (2.1.7) experimental; urgency=low
125
126 * A number of entropy-source fixes.
127 * Internal tidying.
128 * Add more elliptic curves, from Brainpool and BADA55.
129 * hashsum: Fix hash file verification.
130
131 -- Mark Wooding <mdw@distorted.org.uk> Wed, 16 Jul 2014 10:21:23 +0100
132
133 catacomb (2.1.6.1) experimental; urgency=low
134
135 * Fix building from source tarball.
136 * Fix building with Python 2.5.
137
138 -- Mark Wooding <mdw@distorted.org.uk> Sat, 28 Dec 2013 14:21:36 +0000
139
140 catacomb (2.1.6) experimental; urgency=low
141
142 * mpreduce: Extend domain to all positive integers.
143 * gfreduce: Fix out-of-bounds memory access.
144 * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
145 * pixie: Don't replace existing pixie unless explicitly requested.
146
147 -- Mark Wooding <mdw@distorted.org.uk> Fri, 27 Dec 2013 14:28:57 +0000
148
149 catacomb (2.1.5) experimental; urgency=low
150
151 * New build system.
152
153 -- Mark Wooding <mdw@distorted.org.uk> Mon, 29 Jun 2013 00:38:58 +0100
154
155 catacomb (2.1.4) experimental; urgency=low
156
157 * Constant-time operations.
158 * Some minor fixes to header files.
159
160 -- Mark Wooding <mdw@distorted.org.uk> Mon, 27 May 2013 22:34:23 +0100
161
162 catacomb (2.1.3) experimental; urgency=low
163
164 * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
165 example program.
166 * Upper bounds on phrase entropy in mkphrase(1).
167 * Don't make the Pixie setuid-root by default. Make the documentation
168 less scary.
169
170 -- Mark Wooding <mdw@distorted.org.uk> Thu, 11 Apr 2013 12:06:28 +0100
171
172 catacomb (2.1.2.1) experimental; urgency=low
173
174 * hashsum: Document `--progress' option in `--help' output.
175
176 -- Mark Wooding <mdw@distorted.org.uk> Thu, 28 Feb 2013 17:35:49 +0000
177
178 catacomb (2.1.2) experimental; urgency=low
179
180 * hashsum: Correct return code when running in `-c' mode.
181 * dsig: Fix core dump on large-ish outputs.
182 * dsig: Fix repeat-close bug.
183 * dsig: Accept precomputed hashes when making signatures.
184 * Utilities: New `-p' option for progress bars.
185 * dsig, hashsum: New `-j' option checks for files not covered by
186 manifest.
187 * Various library improvements.
188
189 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 03:26:44 +0000
190
191 catacomb (2.1.1) experimental; urgency=low
192
193 * Do configuration through pkgconfig.
194
195 -- Mark Wooding <mdw@distorted.org.uk> Mon, 17 Mar 2008 18:36:30 +0000
196
197 catacomb (2.1.0) experimental; urgency=low
198
199 * Added support for elliptic curves, on both prime and binary fields
200 (polynomial basis only). No actual crypto, but there's enough already
201 to do ECDH and stuff on well-known curves Testing is currently a bit
202 patchy.
203
204 -- Mark Wooding <mdw@nsict.org> Sun, 21 Mar 2004 22:47:56 +0000
205
206 catacomb (2.0.1) experimental; urgency=low
207
208 * Debianization!
209 * (pixie): Don't report uninteresting errors when accepting connections.
210
211 -- Mark Wooding <mdw@nsict.org> Thu, 11 Dec 2003 10:47:59 +0000