Release 2.3.2.
[catacomb] / debian / changelog
1 catacomb (2.3.2) experimental; urgency=low
2
3 * catacomb2: Fix bignum loading and storing in two's complement form.
4
5 -- Mark Wooding <mdw@distorted.org.uk> Thu, 22 Jun 2017 09:34:59 +0100
6
7 catacomb (2.3.1) experimental; urgency=low
8
9 * catacomb2: Fix memory corruption when allocating `salsa20' and
10 `chacha'-based RNGs.
11 * catacomb2: Fix segfault when opening read-only keyring with no
12 associated file.
13 * catacomb2: Return the correct stream offset in `chacha_tell*'.
14 * catacomb2: Produce correct keyring files when they contain empty
15 keys.
16 * catacomb2: Fix cross-compilation-unit type incompatibility in prime
17 and binary group implementations.
18 * catacomb-dev: Add missing licence notices to `salsa20.h'.
19 * catacomb-bin: Fix assertion failure in RSA-PSS signing.
20 * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
21 verifying.
22 * catacomb-bin: Compare MAC tags in constant time.
23 * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
24
25 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 04:05:00 +0100
26
27 catacomb (2.3.0.1) experimental; urgency=low
28
29 * catacomb2: Actually make the stack non-executable rather than just
30 pretending.
31
32 -- Mark Wooding <mdw@distorted.org.uk> Wed, 05 Apr 2017 09:00:55 +0100
33
34 catacomb (2.3.0) experimental; urgency=low
35
36 * catacomb2: Use the correct Oakley 2048 group. For a long time, this
37 was a duplicate of the Oakley 1536 group. There's a compatibility
38 break here, but it's for the best.
39 * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
40 so that the process stack doesn't get marked executable.
41 * catacomb2: New SSE2-based multipliers for i386 and AMD64.
42 * catacomb2: Lots of other improvements to the assembler code.
43
44 -- Mark Wooding <mdw@distorted.org.uk> Mon, 03 Apr 2017 10:24:17 +0100
45
46 catacomb (2.2.5) experimental; urgency=low
47
48 * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
49 is unaligned.
50 * build: Use less obsolete macro names in configure script.
51
52 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jul 2016 10:27:05 +0100
53
54 catacomb (2.2.4) experimental; urgency=low
55
56 * build: Fix build failures on post-wheezy Debian versions.
57 * catacomb2: Use ARM AES instructions if available. (But they can't be
58 assembled using wheezy's version of gas, so this doesn't work in the
59 binary package.)
60 * catacomb2: Fix poor performance (and wrong answers for very small
61 numbers) in prime generation.
62 * catacomb2: Return numbers of exactly the requested length in prime and
63 public-key generation. The `strongprime' and `limlee' algorithms have
64 changed as a result; previously verifiable parameters generated using
65 this algorithm won't be verifiable any more.
66 * catacomb-dev: Deprecate the old `dsa' functions. Use `gdsa' instead.
67
68 -- Mark Wooding <mdw@distorted.org.uk> Sun, 26 Jun 2016 14:18:14 +0100
69
70 catacomb (2.2.3) experimental; urgency=low
71
72 * rand: Make the main generator resiliant in the face of fork(2).
73 * rand: Introduce `rand_quick', which may also mix in CPU-level
74 randomness sources.
75 * rand: Use higher-resolution timer in the quick-win noise source.
76 * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
77 which got lost down the side of the sofas.
78
79 -- Mark Wooding <mdw@distorted.org.uk> Mon, 13 Jun 2016 22:22:33 +0100
80
81 catacomb (2.2.2) experimental; urgency=low
82
83 * build: Cope with newer Autotools and related equipment.
84 * Miscellaneous small fixes for Cygwin.
85 * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
86 particularly, this causes a segfault reading bit zero of a zero-length
87 integer.
88
89 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:12:01 +0100
90
91 catacomb (2.2.1.1) experimental; urgency=low
92
93 * Arrange that catacomb-dev Depends on correct version of mlib-dev. It
94 really won't work well without it.
95
96 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 09:04:50 +0000
97
98 catacomb (2.2.1) experimental; urgency=low
99
100 * Some internal improvements.
101 * Debian packaging cleanups (fix build-depends, update mLib dependency).
102
103 -- Mark Wooding <mdw@distorted.org.uk> Thu, 18 Feb 2016 16:43:09 +0000
104
105 catacomb (2.2.0) experimental; urgency=low
106
107 * catacomb2: Fix rsa_recover crash on even modulus.
108 * catacomb-bin: Report error taking factorial of negative input.
109 * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
110 * catacomb-dev: Support multiple flavours of EC point compression.
111 * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
112 out of prime numbers.
113 * catacomb2: Overhaul crypto primitives used in true-random generator.
114 * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
115 support.
116 * catacomb-dev: New conversions between MP integers and C integer types.
117 * catacomb2: Change gcipher for Seal incompatibly. The IV is now
118 big-endian bytes (rather than `uint32'), and the `block size' is 4.
119 * catacomb2: Mix a constant string into DSA nonce generation to improve
120 resistance to protocol interference.
121 * catacomb2: Fix the freewheel random source, which hasn't been enabled
122 for ages due to a configure-script bug.
123 * catacomb-bin: The key tool can now read and write multiple
124 presentations for key fingerprints.
125 * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
126 stream ciphers.
127
128 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 14:15:31 +0100
129
130 catacomb (2.1.7) experimental; urgency=low
131
132 * A number of entropy-source fixes.
133 * Internal tidying.
134 * Add more elliptic curves, from Brainpool and BADA55.
135 * hashsum: Fix hash file verification.
136
137 -- Mark Wooding <mdw@distorted.org.uk> Wed, 16 Jul 2014 10:21:23 +0100
138
139 catacomb (2.1.6.1) experimental; urgency=low
140
141 * Fix building from source tarball.
142 * Fix building with Python 2.5.
143
144 -- Mark Wooding <mdw@distorted.org.uk> Sat, 28 Dec 2013 14:21:36 +0000
145
146 catacomb (2.1.6) experimental; urgency=low
147
148 * mpreduce: Extend domain to all positive integers.
149 * gfreduce: Fix out-of-bounds memory access.
150 * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
151 * pixie: Don't replace existing pixie unless explicitly requested.
152
153 -- Mark Wooding <mdw@distorted.org.uk> Fri, 27 Dec 2013 14:28:57 +0000
154
155 catacomb (2.1.5) experimental; urgency=low
156
157 * New build system.
158
159 -- Mark Wooding <mdw@distorted.org.uk> Mon, 29 Jun 2013 00:38:58 +0100
160
161 catacomb (2.1.4) experimental; urgency=low
162
163 * Constant-time operations.
164 * Some minor fixes to header files.
165
166 -- Mark Wooding <mdw@distorted.org.uk> Mon, 27 May 2013 22:34:23 +0100
167
168 catacomb (2.1.3) experimental; urgency=low
169
170 * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
171 example program.
172 * Upper bounds on phrase entropy in mkphrase(1).
173 * Don't make the Pixie setuid-root by default. Make the documentation
174 less scary.
175
176 -- Mark Wooding <mdw@distorted.org.uk> Thu, 11 Apr 2013 12:06:28 +0100
177
178 catacomb (2.1.2.1) experimental; urgency=low
179
180 * hashsum: Document `--progress' option in `--help' output.
181
182 -- Mark Wooding <mdw@distorted.org.uk> Thu, 28 Feb 2013 17:35:49 +0000
183
184 catacomb (2.1.2) experimental; urgency=low
185
186 * hashsum: Correct return code when running in `-c' mode.
187 * dsig: Fix core dump on large-ish outputs.
188 * dsig: Fix repeat-close bug.
189 * dsig: Accept precomputed hashes when making signatures.
190 * Utilities: New `-p' option for progress bars.
191 * dsig, hashsum: New `-j' option checks for files not covered by
192 manifest.
193 * Various library improvements.
194
195 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 03:26:44 +0000
196
197 catacomb (2.1.1) experimental; urgency=low
198
199 * Do configuration through pkgconfig.
200
201 -- Mark Wooding <mdw@distorted.org.uk> Mon, 17 Mar 2008 18:36:30 +0000
202
203 catacomb (2.1.0) experimental; urgency=low
204
205 * Added support for elliptic curves, on both prime and binary fields
206 (polynomial basis only). No actual crypto, but there's enough already
207 to do ECDH and stuff on well-known curves Testing is currently a bit
208 patchy.
209
210 -- Mark Wooding <mdw@nsict.org> Sun, 21 Mar 2004 22:47:56 +0000
211
212 catacomb (2.0.1) experimental; urgency=low
213
214 * Debianization!
215 * (pixie): Don't report uninteresting errors when accepting connections.
216
217 -- Mark Wooding <mdw@nsict.org> Thu, 11 Dec 2003 10:47:59 +0000