Release 2.3.0.1.
[catacomb] / debian / changelog
1 catacomb (2.3.0.1) experimental; urgency=low
2
3 * catacomb2: Actually make the stack non-executable rather than just
4 pretending.
5
6 -- Mark Wooding <mdw@distorted.org.uk> Wed, 05 Apr 2017 09:00:55 +0100
7
8 catacomb (2.3.0) experimental; urgency=low
9
10 * catacomb2: Use the correct Oakley 2048 group. For a long time, this
11 was a duplicate of the Oakley 1536 group. There's a compatibility
12 break here, but it's for the best.
13 * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
14 so that the process stack doesn't get marked executable.
15 * catacomb2: New SSE2-based multipliers for i386 and AMD64.
16 * catacomb2: Lots of other improvements to the assembler code.
17
18 -- Mark Wooding <mdw@distorted.org.uk> Mon, 03 Apr 2017 10:24:17 +0100
19
20 catacomb (2.2.5) experimental; urgency=low
21
22 * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
23 is unaligned.
24 * build: Use less obsolete macro names in configure script.
25
26 -- Mark Wooding <mdw@distorted.org.uk> Tue, 12 Jul 2016 10:27:05 +0100
27
28 catacomb (2.2.4) experimental; urgency=low
29
30 * build: Fix build failures on post-wheezy Debian versions.
31 * catacomb2: Use ARM AES instructions if available. (But they can't be
32 assembled using wheezy's version of gas, so this doesn't work in the
33 binary package.)
34 * catacomb2: Fix poor performance (and wrong answers for very small
35 numbers) in prime generation.
36 * catacomb2: Return numbers of exactly the requested length in prime and
37 public-key generation. The `strongprime' and `limlee' algorithms have
38 changed as a result; previously verifiable parameters generated using
39 this algorithm won't be verifiable any more.
40 * catacomb-dev: Deprecate the old `dsa' functions. Use `gdsa' instead.
41
42 -- Mark Wooding <mdw@distorted.org.uk> Sun, 26 Jun 2016 14:18:14 +0100
43
44 catacomb (2.2.3) experimental; urgency=low
45
46 * rand: Make the main generator resiliant in the face of fork(2).
47 * rand: Introduce `rand_quick', which may also mix in CPU-level
48 randomness sources.
49 * rand: Use higher-resolution timer in the quick-win noise source.
50 * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
51 which got lost down the side of the sofas.
52
53 -- Mark Wooding <mdw@distorted.org.uk> Mon, 13 Jun 2016 22:22:33 +0100
54
55 catacomb (2.2.2) experimental; urgency=low
56
57 * build: Cope with newer Autotools and related equipment.
58 * Miscellaneous small fixes for Cygwin.
59 * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
60 particularly, this causes a segfault reading bit zero of a zero-length
61 integer.
62
63 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:12:01 +0100
64
65 catacomb (2.2.1.1) experimental; urgency=low
66
67 * Arrange that catacomb-dev Depends on correct version of mlib-dev. It
68 really won't work well without it.
69
70 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 09:04:50 +0000
71
72 catacomb (2.2.1) experimental; urgency=low
73
74 * Some internal improvements.
75 * Debian packaging cleanups (fix build-depends, update mLib dependency).
76
77 -- Mark Wooding <mdw@distorted.org.uk> Thu, 18 Feb 2016 16:43:09 +0000
78
79 catacomb (2.2.0) experimental; urgency=low
80
81 * catacomb2: Fix rsa_recover crash on even modulus.
82 * catacomb-bin: Report error taking factorial of negative input.
83 * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
84 * catacomb-dev: Support multiple flavours of EC point compression.
85 * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
86 out of prime numbers.
87 * catacomb2: Overhaul crypto primitives used in true-random generator.
88 * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
89 support.
90 * catacomb-dev: New conversions between MP integers and C integer types.
91 * catacomb2: Change gcipher for Seal incompatibly. The IV is now
92 big-endian bytes (rather than `uint32'), and the `block size' is 4.
93 * catacomb2: Mix a constant string into DSA nonce generation to improve
94 resistance to protocol interference.
95 * catacomb2: Fix the freewheel random source, which hasn't been enabled
96 for ages due to a configure-script bug.
97 * catacomb-bin: The key tool can now read and write multiple
98 presentations for key fingerprints.
99 * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
100 stream ciphers.
101
102 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 14:15:31 +0100
103
104 catacomb (2.1.7) experimental; urgency=low
105
106 * A number of entropy-source fixes.
107 * Internal tidying.
108 * Add more elliptic curves, from Brainpool and BADA55.
109 * hashsum: Fix hash file verification.
110
111 -- Mark Wooding <mdw@distorted.org.uk> Wed, 16 Jul 2014 10:21:23 +0100
112
113 catacomb (2.1.6.1) experimental; urgency=low
114
115 * Fix building from source tarball.
116 * Fix building with Python 2.5.
117
118 -- Mark Wooding <mdw@distorted.org.uk> Sat, 28 Dec 2013 14:21:36 +0000
119
120 catacomb (2.1.6) experimental; urgency=low
121
122 * mpreduce: Extend domain to all positive integers.
123 * gfreduce: Fix out-of-bounds memory access.
124 * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
125 * pixie: Don't replace existing pixie unless explicitly requested.
126
127 -- Mark Wooding <mdw@distorted.org.uk> Fri, 27 Dec 2013 14:28:57 +0000
128
129 catacomb (2.1.5) experimental; urgency=low
130
131 * New build system.
132
133 -- Mark Wooding <mdw@distorted.org.uk> Mon, 29 Jun 2013 00:38:58 +0100
134
135 catacomb (2.1.4) experimental; urgency=low
136
137 * Constant-time operations.
138 * Some minor fixes to header files.
139
140 -- Mark Wooding <mdw@distorted.org.uk> Mon, 27 May 2013 22:34:23 +0100
141
142 catacomb (2.1.3) experimental; urgency=low
143
144 * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
145 example program.
146 * Upper bounds on phrase entropy in mkphrase(1).
147 * Don't make the Pixie setuid-root by default. Make the documentation
148 less scary.
149
150 -- Mark Wooding <mdw@distorted.org.uk> Thu, 11 Apr 2013 12:06:28 +0100
151
152 catacomb (2.1.2.1) experimental; urgency=low
153
154 * hashsum: Document `--progress' option in `--help' output.
155
156 -- Mark Wooding <mdw@distorted.org.uk> Thu, 28 Feb 2013 17:35:49 +0000
157
158 catacomb (2.1.2) experimental; urgency=low
159
160 * hashsum: Correct return code when running in `-c' mode.
161 * dsig: Fix core dump on large-ish outputs.
162 * dsig: Fix repeat-close bug.
163 * dsig: Accept precomputed hashes when making signatures.
164 * Utilities: New `-p' option for progress bars.
165 * dsig, hashsum: New `-j' option checks for files not covered by
166 manifest.
167 * Various library improvements.
168
169 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 03:26:44 +0000
170
171 catacomb (2.1.1) experimental; urgency=low
172
173 * Do configuration through pkgconfig.
174
175 -- Mark Wooding <mdw@distorted.org.uk> Mon, 17 Mar 2008 18:36:30 +0000
176
177 catacomb (2.1.0) experimental; urgency=low
178
179 * Added support for elliptic curves, on both prime and binary fields
180 (polynomial basis only). No actual crypto, but there's enough already
181 to do ECDH and stuff on well-known curves Testing is currently a bit
182 patchy.
183
184 -- Mark Wooding <mdw@nsict.org> Sun, 21 Mar 2004 22:47:56 +0000
185
186 catacomb (2.0.1) experimental; urgency=low
187
188 * Debianization!
189 * (pixie): Don't report uninteresting errors when accepting connections.
190
191 -- Mark Wooding <mdw@nsict.org> Thu, 11 Dec 2003 10:47:59 +0000