Port to Python 3.
[catacomb-python] / debian / rules
1 #! /usr/bin/make -f
2 %:; dh $@ --parallel --with python2,python3
3
4 export PYTHON := $(shell pyversions -d)
5 export PYTHONS := $(shell pyversions -r && py3versions -r)
6
7 override_dh_auto_test:
8 dh_auto_test -- OPTS-check=-V
9
10 override_dh_auto_install:
11 dh_auto_install -- prefix=/usr \
12 $(foreach p,$(filter-out $(PYTHON),$(PYTHONS)), \
13 OPTS-install/$p="--install-scripts=/usr/bin-$p")