Release 1.1.0.
[catacomb-python] / debian / changelog
1 catacomb-python (1.1.0) experimental; urgency=low
2
3 * Fix crash on trying to import RSA public and private keys with even
4 modulus.
5 * Add bindings for key-strength conversion functions.
6 * Add bindings for factorial and Fibonacci calculations.
7 * Implement exact field-of-fractions arithmetic for integers and binary
8 polynomials.
9 * Set module nameson types properly, so that IPython doesn't choke on
10 printing them.
11 * Implement hashing for comparable types. Again, this makes IPython
12 work better.
13 * Support Daniel Bernstein's Salsa20 and ChaCha stream ciphers.
14 * Stop abusing SyntaxError.
15 * Support elliptic curve point compression formats.
16 * Major overhaul of the `pwsafe' utility: multiple storage backends, so
17 (a) we no longer require GDBM, and (b) we can use a Git-friendly
18 directory-based format. Or SQLite.
19
20 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 16:07:51 +0100
21
22 catacomb-python (1.0.6) experimental; urgency=low
23
24 * Fix stupid bug in WriteBuffer resizing.
25
26 -- Mark Wooding <mdw@distorted.org.uk> Sun, 21 Jul 2013 15:57:06 +0100
27
28 catacomb-python (1.0.5) experimental; urgency=low
29
30 * Make Key constructor actually work.
31 * Include human-readable text in KeyError exceptions.
32
33 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jan 2014 01:38:26 +0000
34
35 catacomb-python (1.0.4) experimental; urgency=low
36
37 * Build against Python 2.7.
38
39 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 02:47:59 +0000
40
41 catacomb-python (1.0.3) experimental; urgency=low
42
43 * Remove catacomb-python-bin package, because it made building hard and
44 didn't provide any noticeable benefits.
45
46 -- Mark Wooding <mdw@distorted.org.uk> Fri, 05 Nov 2010 15:12:35 +0000
47
48 catacomb-python (1.0.2) experimental; urgency=low
49
50 * Overhaul build system with new support module.
51
52 -- Mark Wooding <mdw@distorted.org.uk> Sun, 04 Oct 2009 14:17:20 +0100
53
54 catacomb-python (1.0.1) experimental; urgency=low
55
56 * Make it work with Python 2.6. Also switched over to the (increasingly
57 winning) CDBS.
58
59 -- Mark Wooding <mdw@distorted.org.uk> Sat, 03 Oct 2009 23:06:29 +0100
60
61 catacomb-python (1.0.0) experimental; urgency=low
62
63 * Debianization!
64
65 -- Mark Wooding <mdw@distorted.org.uk> Mon, 26 Sep 2005 11:27:00 +0100