t/: Add a test suite.
[catacomb-python] / debian / changelog
1 catacomb-python (1.2.1.1) experimental; urgency=medium
2
3 * Fixing to build against Debian `stretch'.
4
5 -- Mark Wooding <mdw@distorted.org.uk> Mon, 24 Dec 2018 15:21:08 +0000
6
7 catacomb-python (1.2.1) experimental; urgency=low
8
9 * Fix use-after-free bug in ECPt hashing causing hash instability.
10 * Fix keywrd argument mismatch in ECDSAPriv.
11 * Coerce DSA private key values to `MP'.
12
13 -- Mark Wooding <mdw@distorted.org.uk> Fri, 16 Jun 2017 01:01:05 +0100
14
15 catacomb-python (1.2.0) experimental; urgency=low
16
17 * Bindings for HSalsa20 and HChaCha PRFs.
18 * Bindings for Poly1305.
19 * Bindings for X25519.
20 * Bindings for X448.
21 * Bindings for Ed25519.
22 * Bindings for Ed448.
23 * Bindings for Keccak[1600, n].
24 * Bindings for cSHAKE; Python implementation of KMAC.
25 * Improved pretty-printing for IPython.
26 * Allow selection of public exponent when generating RSA keys.
27
28 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 17:29:53 +0100
29
30 catacomb-python (1.1.2) experimental; urgency=low
31
32 * Further 64-bit compatibility improvements.
33 * Fixed docstrings for a number of native methods.
34 * Fix range checking for `GRand' methods.
35 * Fix crash when deleting natively implemented object attributes.
36 * Fix bug which assigned the wrong hash to bytestrings.
37 * Fix `__int__' methods to return `long' objects when necessary.
38 Without this, there are unnecessary failures and bizarrely timed
39 exceptions.
40 * A couple of patches to provide forward compatibility with upstream
41 library changes.
42
43 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 04:25:35 +0100
44
45 catacomb-python (1.1.1) experimental; urgency=low
46
47 * ByteString operators: fix crashes on 64-bit platforms resulting from
48 the use of the wrong length types.
49
50 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:17:14 +0100
51
52 catacomb-python (1.1.0.1) experimental; urgency=low
53
54 * Just Debian packaging fixes.
55
56 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 19:39:28 +0000
57
58 catacomb-python (1.1.0) experimental; urgency=low
59
60 * Fix crash on trying to import RSA public and private keys with even
61 modulus.
62 * Add bindings for key-strength conversion functions.
63 * Add bindings for factorial and Fibonacci calculations.
64 * Implement exact field-of-fractions arithmetic for integers and binary
65 polynomials.
66 * Set module nameson types properly, so that IPython doesn't choke on
67 printing them.
68 * Implement hashing for comparable types. Again, this makes IPython
69 work better.
70 * Support Daniel Bernstein's Salsa20 and ChaCha stream ciphers.
71 * Stop abusing SyntaxError.
72 * Support elliptic curve point compression formats.
73 * Major overhaul of the `pwsafe' utility: multiple storage backends, so
74 (a) we no longer require GDBM, and (b) we can use a Git-friendly
75 directory-based format. Or SQLite.
76
77 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 16:07:51 +0100
78
79 catacomb-python (1.0.6) experimental; urgency=low
80
81 * Fix stupid bug in WriteBuffer resizing.
82
83 -- Mark Wooding <mdw@distorted.org.uk> Sun, 21 Jul 2013 15:57:06 +0100
84
85 catacomb-python (1.0.5) experimental; urgency=low
86
87 * Make Key constructor actually work.
88 * Include human-readable text in KeyError exceptions.
89
90 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jan 2014 01:38:26 +0000
91
92 catacomb-python (1.0.4) experimental; urgency=low
93
94 * Build against Python 2.7.
95
96 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 02:47:59 +0000
97
98 catacomb-python (1.0.3) experimental; urgency=low
99
100 * Remove catacomb-python-bin package, because it made building hard and
101 didn't provide any noticeable benefits.
102
103 -- Mark Wooding <mdw@distorted.org.uk> Fri, 05 Nov 2010 15:12:35 +0000
104
105 catacomb-python (1.0.2) experimental; urgency=low
106
107 * Overhaul build system with new support module.
108
109 -- Mark Wooding <mdw@distorted.org.uk> Sun, 04 Oct 2009 14:17:20 +0100
110
111 catacomb-python (1.0.1) experimental; urgency=low
112
113 * Make it work with Python 2.6. Also switched over to the (increasingly
114 winning) CDBS.
115
116 -- Mark Wooding <mdw@distorted.org.uk> Sat, 03 Oct 2009 23:06:29 +0100
117
118 catacomb-python (1.0.0) experimental; urgency=low
119
120 * Debianization!
121
122 -- Mark Wooding <mdw@distorted.org.uk> Mon, 26 Sep 2005 11:27:00 +0100