Release 1.3.0.1.
[catacomb-python] / debian / changelog
1 catacomb-python (1.3.0.1) experimental; urgency=medium
2
3 * Fix required Catacomb version in `setup.py' script. Only affects the
4 source package.
5
6 -- Mark Wooding <mdw@distorted.org.uk> Sun, 22 Sep 2019 01:21:28 +0100
7
8 catacomb-python (1.3.0) experimental; urgency=medium
9
10 * catacomb: Bindings for new blockcipher-based MACs, and AEAD schemes.
11 * catacomb: Invalidate `grand' objects passed into Python through prime-
12 generation events.
13 * catacomb: Improve class docstrings. (They're still extremely terse.)
14 * catacomb: Add missing `copy' methods on hash and Keccak objects.
15 * catacomb: Add `WriteBuffer.contents' as a more convenient way to
16 extract the contents than coercing to `str' or `ByteString'.
17 * catacomb: Set `RTLD_DEEPBIND' while loading the native module to work
18 around #868366.
19 * pock: New program for generating efficiently verifiable prime numbers,
20 and for verifying their certificates.
21
22 -- Mark Wooding <mdw@distorted.org.uk> Sat, 21 Sep 2019 23:00:25 +0100
23
24 catacomb-python (1.2.1) experimental; urgency=low
25
26 * Fix use-after-free bug in ECPt hashing causing hash instability.
27 * Fix keywrd argument mismatch in ECDSAPriv.
28 * Coerce DSA private key values to `MP'.
29
30 -- Mark Wooding <mdw@distorted.org.uk> Fri, 16 Jun 2017 01:01:05 +0100
31
32 catacomb-python (1.2.0) experimental; urgency=low
33
34 * Bindings for HSalsa20 and HChaCha PRFs.
35 * Bindings for Poly1305.
36 * Bindings for X25519.
37 * Bindings for X448.
38 * Bindings for Ed25519.
39 * Bindings for Ed448.
40 * Bindings for Keccak[1600, n].
41 * Bindings for cSHAKE; Python implementation of KMAC.
42 * Improved pretty-printing for IPython.
43 * Allow selection of public exponent when generating RSA keys.
44
45 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 17:29:53 +0100
46
47 catacomb-python (1.1.2) experimental; urgency=low
48
49 * Further 64-bit compatibility improvements.
50 * Fixed docstrings for a number of native methods.
51 * Fix range checking for `GRand' methods.
52 * Fix crash when deleting natively implemented object attributes.
53 * Fix bug which assigned the wrong hash to bytestrings.
54 * Fix `__int__' methods to return `long' objects when necessary.
55 Without this, there are unnecessary failures and bizarrely timed
56 exceptions.
57 * A couple of patches to provide forward compatibility with upstream
58 library changes.
59
60 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 04:25:35 +0100
61
62 catacomb-python (1.1.1) experimental; urgency=low
63
64 * ByteString operators: fix crashes on 64-bit platforms resulting from
65 the use of the wrong length types.
66
67 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:17:14 +0100
68
69 catacomb-python (1.1.0.1) experimental; urgency=low
70
71 * Just Debian packaging fixes.
72
73 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 19:39:28 +0000
74
75 catacomb-python (1.1.0) experimental; urgency=low
76
77 * Fix crash on trying to import RSA public and private keys with even
78 modulus.
79 * Add bindings for key-strength conversion functions.
80 * Add bindings for factorial and Fibonacci calculations.
81 * Implement exact field-of-fractions arithmetic for integers and binary
82 polynomials.
83 * Set module nameson types properly, so that IPython doesn't choke on
84 printing them.
85 * Implement hashing for comparable types. Again, this makes IPython
86 work better.
87 * Support Daniel Bernstein's Salsa20 and ChaCha stream ciphers.
88 * Stop abusing SyntaxError.
89 * Support elliptic curve point compression formats.
90 * Major overhaul of the `pwsafe' utility: multiple storage backends, so
91 (a) we no longer require GDBM, and (b) we can use a Git-friendly
92 directory-based format. Or SQLite.
93
94 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 16:07:51 +0100
95
96 catacomb-python (1.0.6) experimental; urgency=low
97
98 * Fix stupid bug in WriteBuffer resizing.
99
100 -- Mark Wooding <mdw@distorted.org.uk> Sun, 21 Jul 2013 15:57:06 +0100
101
102 catacomb-python (1.0.5) experimental; urgency=low
103
104 * Make Key constructor actually work.
105 * Include human-readable text in KeyError exceptions.
106
107 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jan 2014 01:38:26 +0000
108
109 catacomb-python (1.0.4) experimental; urgency=low
110
111 * Build against Python 2.7.
112
113 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 02:47:59 +0000
114
115 catacomb-python (1.0.3) experimental; urgency=low
116
117 * Remove catacomb-python-bin package, because it made building hard and
118 didn't provide any noticeable benefits.
119
120 -- Mark Wooding <mdw@distorted.org.uk> Fri, 05 Nov 2010 15:12:35 +0000
121
122 catacomb-python (1.0.2) experimental; urgency=low
123
124 * Overhaul build system with new support module.
125
126 -- Mark Wooding <mdw@distorted.org.uk> Sun, 04 Oct 2009 14:17:20 +0100
127
128 catacomb-python (1.0.1) experimental; urgency=low
129
130 * Make it work with Python 2.6. Also switched over to the (increasingly
131 winning) CDBS.
132
133 -- Mark Wooding <mdw@distorted.org.uk> Sat, 03 Oct 2009 23:06:29 +0100
134
135 catacomb-python (1.0.0) experimental; urgency=low
136
137 * Debianization!
138
139 -- Mark Wooding <mdw@distorted.org.uk> Mon, 26 Sep 2005 11:27:00 +0100