Deploy the new <ctype.h> and `foocmp' macros from mLib.
[catacomb-python] / debian / changelog
1 catacomb-python (1.3.99~) experimental; urgency=medium
2
3 * (placeholder for next release)
4
5 -- Mark Wooding <mdw@distorted.org.uk> Tue, 01 Oct 2019 12:57:58 +0100
6
7 catacomb-python (1.3.0.1) experimental; urgency=medium
8
9 * Fix required Catacomb version in `setup.py' script. Only affects the
10 source package.
11
12 -- Mark Wooding <mdw@distorted.org.uk> Sun, 22 Sep 2019 01:21:28 +0100
13
14 catacomb-python (1.3.0) experimental; urgency=medium
15
16 * catacomb: Bindings for new blockcipher-based MACs, and AEAD schemes.
17 * catacomb: Invalidate `grand' objects passed into Python through prime-
18 generation events.
19 * catacomb: Improve class docstrings. (They're still extremely terse.)
20 * catacomb: Add missing `copy' methods on hash and Keccak objects.
21 * catacomb: Add `WriteBuffer.contents' as a more convenient way to
22 extract the contents than coercing to `str' or `ByteString'.
23 * catacomb: Set `RTLD_DEEPBIND' while loading the native module to work
24 around #868366.
25 * pock: New program for generating efficiently verifiable prime numbers,
26 and for verifying their certificates.
27
28 -- Mark Wooding <mdw@distorted.org.uk> Sat, 21 Sep 2019 23:00:25 +0100
29
30 catacomb-python (1.2.1) experimental; urgency=low
31
32 * Fix use-after-free bug in ECPt hashing causing hash instability.
33 * Fix keywrd argument mismatch in ECDSAPriv.
34 * Coerce DSA private key values to `MP'.
35
36 -- Mark Wooding <mdw@distorted.org.uk> Fri, 16 Jun 2017 01:01:05 +0100
37
38 catacomb-python (1.2.0) experimental; urgency=low
39
40 * Bindings for HSalsa20 and HChaCha PRFs.
41 * Bindings for Poly1305.
42 * Bindings for X25519.
43 * Bindings for X448.
44 * Bindings for Ed25519.
45 * Bindings for Ed448.
46 * Bindings for Keccak[1600, n].
47 * Bindings for cSHAKE; Python implementation of KMAC.
48 * Improved pretty-printing for IPython.
49 * Allow selection of public exponent when generating RSA keys.
50
51 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 17:29:53 +0100
52
53 catacomb-python (1.1.2) experimental; urgency=low
54
55 * Further 64-bit compatibility improvements.
56 * Fixed docstrings for a number of native methods.
57 * Fix range checking for `GRand' methods.
58 * Fix crash when deleting natively implemented object attributes.
59 * Fix bug which assigned the wrong hash to bytestrings.
60 * Fix `__int__' methods to return `long' objects when necessary.
61 Without this, there are unnecessary failures and bizarrely timed
62 exceptions.
63 * A couple of patches to provide forward compatibility with upstream
64 library changes.
65
66 -- Mark Wooding <mdw@distorted.org.uk> Sun, 14 May 2017 04:25:35 +0100
67
68 catacomb-python (1.1.1) experimental; urgency=low
69
70 * ByteString operators: fix crashes on 64-bit platforms resulting from
71 the use of the wrong length types.
72
73 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jun 2016 01:17:14 +0100
74
75 catacomb-python (1.1.0.1) experimental; urgency=low
76
77 * Just Debian packaging fixes.
78
79 -- Mark Wooding <mdw@distorted.org.uk> Fri, 19 Feb 2016 19:39:28 +0000
80
81 catacomb-python (1.1.0) experimental; urgency=low
82
83 * Fix crash on trying to import RSA public and private keys with even
84 modulus.
85 * Add bindings for key-strength conversion functions.
86 * Add bindings for factorial and Fibonacci calculations.
87 * Implement exact field-of-fractions arithmetic for integers and binary
88 polynomials.
89 * Set module nameson types properly, so that IPython doesn't choke on
90 printing them.
91 * Implement hashing for comparable types. Again, this makes IPython
92 work better.
93 * Support Daniel Bernstein's Salsa20 and ChaCha stream ciphers.
94 * Stop abusing SyntaxError.
95 * Support elliptic curve point compression formats.
96 * Major overhaul of the `pwsafe' utility: multiple storage backends, so
97 (a) we no longer require GDBM, and (b) we can use a Git-friendly
98 directory-based format. Or SQLite.
99
100 -- Mark Wooding <mdw@distorted.org.uk> Mon, 20 Jul 2015 16:07:51 +0100
101
102 catacomb-python (1.0.6) experimental; urgency=low
103
104 * Fix stupid bug in WriteBuffer resizing.
105
106 -- Mark Wooding <mdw@distorted.org.uk> Sun, 21 Jul 2013 15:57:06 +0100
107
108 catacomb-python (1.0.5) experimental; urgency=low
109
110 * Make Key constructor actually work.
111 * Include human-readable text in KeyError exceptions.
112
113 -- Mark Wooding <mdw@distorted.org.uk> Sat, 04 Jan 2014 01:38:26 +0000
114
115 catacomb-python (1.0.4) experimental; urgency=low
116
117 * Build against Python 2.7.
118
119 -- Mark Wooding <mdw@distorted.org.uk> Wed, 09 Jan 2013 02:47:59 +0000
120
121 catacomb-python (1.0.3) experimental; urgency=low
122
123 * Remove catacomb-python-bin package, because it made building hard and
124 didn't provide any noticeable benefits.
125
126 -- Mark Wooding <mdw@distorted.org.uk> Fri, 05 Nov 2010 15:12:35 +0000
127
128 catacomb-python (1.0.2) experimental; urgency=low
129
130 * Overhaul build system with new support module.
131
132 -- Mark Wooding <mdw@distorted.org.uk> Sun, 04 Oct 2009 14:17:20 +0100
133
134 catacomb-python (1.0.1) experimental; urgency=low
135
136 * Make it work with Python 2.6. Also switched over to the (increasingly
137 winning) CDBS.
138
139 -- Mark Wooding <mdw@distorted.org.uk> Sat, 03 Oct 2009 23:06:29 +0100
140
141 catacomb-python (1.0.0) experimental; urgency=low
142
143 * Debianization!
144
145 -- Mark Wooding <mdw@distorted.org.uk> Mon, 26 Sep 2005 11:27:00 +0100