Debianization.
[u/mdw/catacomb] / debian / catacomb-bin.postinst
diff --git a/debian/catacomb-bin.postinst b/debian/catacomb-bin.postinst
new file mode 100644 (file)
index 0000000..c78ee62
--- /dev/null
@@ -0,0 +1,17 @@
+#! /bin/sh -e
+. /usr/share/debconf/confmodule
+db_version 2.0
+db_get catacomb-bin/pixie-is-setuid; setuid=$RET
+dpkg-statoverride --remove /usr/bin/pixie 2>/dev/null || true
+case $setuid in
+  true)
+    echo "Installing /usr/bin/pixie setuid-root."
+    dpkg-statoverride --add --update root root 4755 /usr/bin/pixie 
+    ;;
+  false)
+    echo "Making /usr/bin/pixie non-setuid."
+    dpkg-statoverride --add --update root root 755 /usr/bin/pixie
+    ;;
+esac
+
+#DEBHELPER#