Rewrite graphical tools in Python.
[xtoys] / debian / rules
index e0a0e84..7aa6821 100755 (executable)
@@ -1,49 +1,10 @@
 #! /usr/bin/make -f
 
-build:
-       rm -rf deb-build build; mkdir deb-build
-       cd deb-build; ../configure --prefix=/usr --mandir=/usr/share/man
-       make -C deb-build
-       touch build
+CDBS = /usr/share/cdbs/1
+include $(CDBS)/rules/debhelper.mk
+include $(CDBS)/class/autotools.mk
 
-clean:
-       dh_clean
-       rm -rf deb-build build
+DEB_BUILDDIR = $(CURDIR)/build
 
-install: build
-       dh_clean
-       for i in xscsize xwait xtell; do \
-               dh_install -p xtoys deb-build/$$i usr/bin; \
-               dh_installman -p xtoys $$i.1; \
-       done
-       for i in xcatch xgetline xmsg xshutdown; do \
-               dh_install -p xtoys-gtk deb-build/$$i usr/bin; \
-               dh_installman -p xtoys-gtk $$i.1; \
-       done
-       dh_strip -a
-
-binary-indep:
-
-binary-arch: install
-       dh_testdir -a
-       dh_testroot -a
-       dh_compress -a
-       dh_installdocs -a
-       dh_shlibdeps -a
-       dh_gencontrol -a
-       dh_fixperms -a
-       dh_installdeb -a
-       dh_md5sums -a
-       dh_builddeb -a
-
-binary: binary-indep binary-arch
-
-source:
-       rm -rf deb-build/*.tar.gz deb-build/=deb=
-       make -C deb-build dist
-       mkdir deb-build/=deb=
-       cd deb-build/=deb=; tar xvfz ../*.tar.gz
-       d=`pwd`; cd ..; dpkg-source -i -b $$d/deb-build/=deb=/*
-       rm -rf deb-build/=deb=
-
-.PHONY: binary binary-arch binary-indep clean install source 
+binary-install/xtoys-gtk::
+       dh_pycentral -pxtoys-gtk