debian/: Update for Debhelper 10.
[tripe] / debian / rules
index b45a6be..9b5065a 100755 (executable)
@@ -1,6 +1,6 @@
 #! /usr/bin/make -f
 
-DH_OPTIONS              = --parallel -Bdebian/build
+DH_OPTIONS              = -Bdebian/build
 
 ###--------------------------------------------------------------------------
 ### Configuration.
@@ -9,6 +9,7 @@ OVERRIDES               += auto_configure
 dh_auto_configure_OPTS  = --
 
 ## Various files and directories.
+dh_auto_configure_OPTS += --libdir="\$${prefix}/lib"
 dh_auto_configure_OPTS += --libexecdir="\$${libdir}/tripe"
 dh_auto_configure_OPTS += --with-configdir="/etc/tripe"
 dh_auto_configure_OPTS += --with-socketdir="/var/run"
@@ -61,7 +62,7 @@ dh-install-hook::
 ###--------------------------------------------------------------------------
 ### Some machinery for overriding Debhelper in a structured way.
 
-%:; dh $@ $(DH_OPTIONS)
+%:; dh $@ --without autoreconf $(DH_OPTIONS)
 
 $(foreach o, $(sort $(OVERRIDES)), dh-$o-hook)::; @:
 $(foreach o, $(sort $(OVERRIDES)), override_dh_$o): override_dh_%: dh-%-hook