debian/: Ship `symbols' file for better downstream dependency versioning.
[sod] / debian / rules
index 005d451..5a407ca 100755 (executable)
@@ -1,5 +1,5 @@
 #! /usr/bin/make -f
-%:; dh $@ --parallel -Bdebian/build
+%:; dh $@ --parallel --without=autoreconf -Bdebian/build
 
 ## The `sbuild' tool sets a fake `home' directory which doesn't exist.  This
 ## breaks ASDF, which wants to write FASL files into `~/.cache/common-lisp/'.
@@ -11,6 +11,9 @@ override_dh_auto_clean:
        rm -rf debian/build/cache
        rm -f doc/*.pdf
 
+## Check that the shared-library symbols are plausible.
+override_dh_makeshlibs:; dh_makeshlibs -- -c4
+
 ## Don't strip the main executable.  (It doesn't work, and you get left with
 ## a bare SBCL.)
 override_dh_strip:; dh_strip -Xusr/bin/sod