debian/: Ship `symbols' file for better downstream dependency versioning.
[sod] / debian / rules
index db3d030..5a407ca 100755 (executable)
@@ -1,5 +1,5 @@
 #! /usr/bin/make -f
-%:; dh $@ --parallel -Bdebian/build
+%:; dh $@ --parallel --without=autoreconf -Bdebian/build
 
 ## The `sbuild' tool sets a fake `home' directory which doesn't exist.  This
 ## breaks ASDF, which wants to write FASL files into `~/.cache/common-lisp/'.
@@ -9,6 +9,10 @@ export XDG_CACHE_HOME := $(shell pwd)/debian/build/cache
 override_dh_auto_clean:
        dh_auto_clean
        rm -rf debian/build/cache
+       rm -f doc/*.pdf
+
+## Check that the shared-library symbols are plausible.
+override_dh_makeshlibs:; dh_makeshlibs -- -c4
 
 ## Don't strip the main executable.  (It doesn't work, and you get left with
 ## a bare SBCL.)