debian/: Ship `symbols' file for better downstream dependency versioning.
[sod] / debian / rules
index cec98bb..5a407ca 100755 (executable)
@@ -1,2 +1,19 @@
 #! /usr/bin/make -f
-%:; dh $@ --parallel -Bdebian/build
+%:; dh $@ --parallel --without=autoreconf -Bdebian/build
+
+## The `sbuild' tool sets a fake `home' directory which doesn't exist.  This
+## breaks ASDF, which wants to write FASL files into `~/.cache/common-lisp/'.
+## Set an explicit cache directory for it, and clear away the FASL cache
+## directory on clean.
+export XDG_CACHE_HOME := $(shell pwd)/debian/build/cache
+override_dh_auto_clean:
+       dh_auto_clean
+       rm -rf debian/build/cache
+       rm -f doc/*.pdf
+
+## Check that the shared-library symbols are plausible.
+override_dh_makeshlibs:; dh_makeshlibs -- -c4
+
+## Don't strip the main executable.  (It doesn't work, and you get left with
+## a bare SBCL.)
+override_dh_strip:; dh_strip -Xusr/bin/sod