Merge remote-tracking branch 'mdw/mdw/powm-sec'
[secnet] / debian / rules
index a85db21..f94e752 100755 (executable)
@@ -6,10 +6,35 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=2
+#  This file is Free Software.  It has been incorporated into, and
+#  extensively modified, for secnet.
+#
+#  Copyright 2001      Joey Hess
+#  Copyright 2011-2014 Ian Jackson
+#
+#  You may redistribute this file (and the other source files in the
+#  debian/ subdirectory) freely - the copyrightholders declare that
+#  they wish these files to be in the public domain.
+#
+#  You may redistribute secnet as a whole and/or modify it under the
+#  terms of the GNU General Public License as published by the Free
+#  Software Foundation; either version 3, or (at your option) any
+#  later version.
+#
+#  This software is distributed in the hope that it will be useful,
+#  but WITHOUT ANY WARRANTY; without even the implied warranty of
+#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+#  GNU General Public License for more details.
+#
+#  You should have received a copy of the GNU General Public License
+#  along with this software; if not, see
+#  https://www.gnu.org/licenses/gpl.html.
 
-build: build-stamp
+export EXTRA_CFLAGS= $(shell dpkg-buildflags --get CPPFLAGS) \
+                    $(shell dpkg-buildflags --get CFLAGS)
+export EXTRA_LDFLAGS=$(shell dpkg-buildflags --get LDFLAGS)
+
+build build-arch: build-stamp
 build-stamp:
        dh_testdir
 
@@ -24,7 +49,7 @@ clean:
        rm -f build-stamp
 
        # Add here commands to clean up after the build process.
-       $(MAKE) realclean
+       -$(MAKE) realclean
 
        dh_clean
 
@@ -35,10 +60,10 @@ install: build
        dh_installdirs
 
        # Add here commands to install the package into debian/<packagename>
-       $(MAKE) prefix=`pwd`/debian/`dh_listpackages`/usr install
+       $(MAKE) DESTDIR=`pwd`/debian/`dh_listpackages` install
 
 # Build architecture-independent files here.
-binary-indep: build install
+build-indep binary-indep:
 # We have nothing to do by default.
 
 # Build architecture-dependent files here.
@@ -46,7 +71,7 @@ binary-arch: build install
        dh_testdir
        dh_testroot
 #      dh_installdebconf       
-       dh_installdocs INSTALL README NOTES TODO NEWS
+       dh_installdocs INSTALL README NOTES TODO NEWS BUGS CREDITS
        dh_installexamples example.conf
 #      dh_installmenu
 #      dh_installlogrotate
@@ -55,9 +80,8 @@ binary-arch: build install
 #      dh_installmime
        dh_installinit
 #      dh_installcron
-#      dh_installman
+       dh_installman
 #      dh_installinfo
-       dh_undocumented
        dh_installchangelogs
        dh_link
        dh_strip