debian/: Add packaging support.
[runlisp] / debian / rules
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..9b128d0
--- /dev/null
@@ -0,0 +1,16 @@
+#! /usr/bin/make -f
+
+DH_OPTIONS              = --parallel -Bdebian/build
+
+OVERRIDES              += auto_configure
+dh_auto_configure_OPTS  = --
+dh_auto_configure_OPTS += --with-imagedir=/var/lib/runlisp
+
+OVERRIDES              += auto_install
+dh_auto_install_OPTS    = --destdir=debian/tmp
+
+%:; dh $@ $(DH_OPTIONS)
+
+$(foreach o, $(sort $(OVERRIDES)), dh-$o-hook)::; @:
+$(foreach o, $(sort $(OVERRIDES)), override_dh_$o): override_dh_%: dh-%-hook
+       dh_$* $(addprefix -O, $(DH_OPTIONS)) $(dh_$*_OPTS)